slide1 n.
Download
Skip this Video
Loading SlideShow in 5 Seconds..
企业局域网接入 Internet PowerPoint Presentation
Download Presentation
企业局域网接入 Internet

Loading in 2 Seconds...

play fullscreen
1 / 30

企业局域网接入 Internet - PowerPoint PPT Presentation


  • 118 Views
  • Uploaded on

学习情境 7. 企业局域网接入 Internet. 帧中继. Internet. 课程结构. 情境三:构建企业交换式局域网. 情境六:企业无线局域网组建. VLAN. VLAN. VLAN. VLAN. VLAN. VLAN. VLAN. 情境二:企业内部路由配置. 情境四:企业内网安全控制. 情境七:企业出口路由 NAT 配置. 北京总部. 情境五:企业广域网接入配置. 上海分公司. 广州分公司. 情境一:网络设备选型. 课程综合项目: Center 公司网络改造项目实施. 本章目标. 熟悉建设广域网络的基本知识

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

PowerPoint Slideshow about '企业局域网接入 Internet' - saxon


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript
slide2

帧中继

Internet

课程结构

情境三:构建企业交换式局域网

情境六:企业无线局域网组建

VLAN

VLAN

VLAN

VLAN

VLAN

VLAN

VLAN

情境二:企业内部路由配置

情境四:企业内网安全控制

情境七:企业出口路由NAT配置

北京总部

情境五:企业广域网接入配置

上海分公司

广州分公司

情境一:网络设备选型

课程综合项目:Center公司网络改造项目实施

slide3
本章目标
  • 熟悉建设广域网络的基本知识
      • 了解私有IP地址的概念和应用
      • 掌握NAT和NAPT技术
      • 掌握企业局域网通过NAT技术接入Internet
slide4
本章结构

公有IP和私有IP

NAT应用

企业局域网接入Internet

NAT概述

NAT类型

静态NAT

配置NAT

动态NAT

NAPT

slide5
任务分解

公有IP和私有IP

NAT概述

1

2

配置NAT

3

公司局域网接入互联网

4

7 1 ip ip
7.1 公有IP和私有IP
  • 公有地址(Public address,也可称为公网地址)由Internet NIC(Internet Network Information Center,因特网信息中心)负责。它可以在全球范围内唯一地表示一台主机或节点,所以使用它可直接访问因特网。
  • 私有地址(Private address,也可称为专网地址)属于非注册地址,专门为组织机构内部自由使用,所以,它只能在局域网范围内实现唯一IP标识,无法在Internet范围内实现唯一IP标识,所以无法直接访问因特网。
7 2 nat
7.2 NAT概述
  • 网络地址转换基本思路是指在一个企业网络内部,根据需要随意自定义IP地址(不需要经过申请),即内部IP地址。在本组织内部,各计算机间通过内部IP地址进行通信。当组织内部的计算机要与外部网络进行通信时,具有NAT功能的设备(如路由器)负责将其内部IP地址转换为外部IP地址,即以该组织申请的合法IP地址进行通信。
  • 简而言之, NAT就是将网络地址从一个地址空间转换到另外一个地址空间的一个行为。
slide10
NAT 应用

Inside

  • NAT 应用:
    • 节省IP地址
    • 安全性,隐藏内部真实IP
    • 解决网络地址重叠

Internet

Outside

10.1.1.2

10.1.1.1

NAT table

Inside Local

Inside Global

IP Address

IP Address

10.1.1.1

200.1.1.2

10.1.1.2

200.1.1.3

slide11

Inside GlobalAddress

Inside Local Address

互联网

Outside

Inside

外部网

企业内部网

OutsideGlobalAddress

OutsideLocalAddress

NAT相关术语
  • 内部本地地址(Inside Local Address):在局域网内部分配给主机使用的私有IP地址。
  • 内部全局地址(Inside Global Address):一个合法的IP地址,通常由服互联网务提供商(ISP)提供。对于外部网络来说,局域网内部主机所表现的IP地址。
  • 外部本地地址(Outside Local Address):外部网络主机的真实地址。
  • 外部全局地址(Outside Global Address):对于内部网络来说,外部网络主机所表现的IP地址。
slide12
NAT三种类型
  • NAT三种类型:静态地址转换 、动态地址转换和端口地址转换(NAPT)
    • 静态NAT技术把内部网络中的每台主机的私有地址,永久地映射成外部网络中合法的公有地址。
    • 动态转换是把申请到的多个IP公有地址使用动态分配的方式映射到内网的私有地址上。
    • NAPT通常将内部网络的多台配置了私有IP的主机地址,映射到外部网络中的一个单独的公有IP上。
slide13

200.1.1.1/24

200.1.1.2/24

源IP:192.168.10.1

源IP:200.1.1.1

源IP:100.1.1.1

源IP100.1.1.1

目的IP:100.1.1.1

目的IP:100.1.1.1

目的IP:200.1.1.1

目的IP:192.168.10.1

NAT工作原理

192.168.10.1

100.1.1.1

192.168.10.2

slide14

200.1.1.1/24

源IP:192.168.10.1:1024

源IP:200.1.1.1:1024

源IP:100.1.1.1:80

源IP:100.1.1.1 :80

目的IP:100.1.1.1:80

目的IP:100.1.1.1:80

目的IP:200.1.1.1:1024

目的IP:192.168.10.1:1024

NAPT工作原理

192.168.10.1

100.1.1.1

192.168.10.2

Web服务

slide15
阶段总结
  • 公有IP和私有IP
    • 公有地址、私有地址
  • NAT概述
    • 静态地址转换、动态地址转换、端口地址转换(NAPT)
slide16

公有IP和私有IP

NAT概述

1

2

配置NAT

3

任务进度

slide17

7.3 配置NAT

  • NAT技术的出现,主要目的是解决IPv4地址匮乏的问题,另外NAT屏蔽了私网用户真实的IP地址,也提高了私网用户的安全性。
7 3 1 nat
7.3.1 配置静态NAT
  • 定义内部接口

Router(config-if)#ip nat inside

  • 定义外部接口

Router(config-if)#ip nat outside

  • 在内部本地地址与内部合法地址之间建立静态地址转换

Router(config)#ip nat inside source static local-ip global-ip

slide19

Web服务器

全局地址池:

200.1.1.1~200.1.1.5

F0/0:10.0.0.254/24

测试PC

Internet

R1

F1/0:200.1.1.1/24

IP:200.1.1.20/24

GW:200.1.1.1

IP:10.0.0.1/24

GW:10.0.0.254

静态NAT配置实例

定义内网接口

R1(config)#interface FastEthernet 0/0

R1(config-if)#ip address 10.0.0.254 255.255.255.0

R1(config-if)#ip nat inside !定义内网接口

R1(config-if)#no shutdown

定义外网接口

R1(config)#interface FastEthernet 1/0

R1(config-if)#ip address 200.1.1.1 255.255.255.0

R1(config-if)#ip nat outside !定义外网接口

R1(config-if)#no shutdown

slide20
建立静态NAT映射关系。

R1(config)#ip nat inside source static 10.0.0.1 200.1.1.2

通过以上三步配置好静态NAT之后中,可以使用以下命令查看静态NAT信息。

R1#show ip nat staticsics 或者show ip nat translations

7 3 2 nat
7.3.2 配置动态NAT
  • 定义内部接口

Router(config-if)#ip nat inside

  • 定义外部接口

Router(config-if)#ip nat outside

  • 定义一个标准的访问列表以允许哪些内部地址可以进行动态地址转换

Router(config)#access-list list-number permit source [source-wildmask]

slide22
配置动态NAT
  • 定义可供动态分配的全局地址

Router(config)#ip nat pool pool-name start-ip end-ip netmask netmask

  • 将由访问控制列表指定的内部地址范围和外部地址池之间进行地址转换

Router(config)#ip nat inside source [list list-number] pool pool-name [overload]

slide23

Web服务器

全局地址池:

200.1.1.1~200.1.1.5

F0/0:10.0.0.254/24

测试PC

Internet

R1

F1/0:200.1.1.1/24

IP:200.1.1.20/24

GW:200.1.1.1

IP:10.0.0.1/24

GW:10.0.0.254

动态NAT配置实例

定义内网接口

R1(config)#interface FastEthernet 0/0

R1(config-if)#ip address 10.0.0.254 255.255.255.0

R1(config-if)#ip nat inside !定义内网接口

R1(config-if)#no shutdown

定义外网接口

R1(config)#interface FastEthernet 1/0

R1(config-if)#ip address 200.1.1.1 255.255.255.0

R1(config-if)#ip nat outside !定义外网接口

R1(config-if)#no shutdown

slide24

通过访问控制列表定义需进行转换的网络。

R1(config)#access-list 10 permit 10.0.0.0 0.0.0.255!定义允许转换本地地址范围

定义可供动态分配的外网地址池

R1(config)#ip nat pool mypool 200.1.1.1 200.1.1.5 netmask 255.255.255.0

将由访问控制列表指定的内部地址范围和外部地址池之间进行动态地址转换。

R1(config)#ip nat inside source list 10 pool mypool

通过以上三步配置好静态NAT之后中,可以使用以下命令查看静态NAT信息。

R1# show ip nat translations

7 3 3 napt

Web服务器

F0/0:10.0.0.254/24

测试PC

Internet

R1

F1/0:200.1.1.1/24

IP:200.1.1.20/24

GW:200.1.1.1

IP:10.0.0.1/24

GW:10.0.0.254

7.3.3 配置NAPT

端口地址转换NAPT的配置方法和动态NAT配制方法基本相同,由于NAPT只有一个外网出口地址,所以,在配置地址池时,起始地址和结束地址都应设为同一个IP地址,或是直接不配置地址池,在进行映射置换时直接对应相应的接口。

R1(config)#ip nat pool mypool 200.1.1.1 200.1.1.1 netmask 255.255.255.0

R1(config)#ip nat inside source list 10 pool mypool overload

或R1(config)#ip nat inside source list 10 interface fastEthernet 1/0 overload

slide26
7.4项目分解实现公司局域网接入互联网
  • Center公司总部设在北京,该公司在广州和上海分别设有分公司,各分公司通过路由器连入总部,现在要求配置总部路由器,利用NATP技术实现公司内部网访问Internet。
  • 如图所示:
slide28
公有IP和私有IP

公有地址、私有地址

NAT概述

静态地址转换、动态地址转换、端口地址转换(NAPT)

配置NAT

配置静态NAT、动态NAT配置

阶段总结
slide29

公有IP和私有IP

NAT概述

1

2

配置NAT

3

公司局域网接入互联网

4

任务进度

slide30
本章结构

公有IP和私有IP

NAT应用

企业局域网接入Internet

NAT概述

NAT类型

静态NAT

配置NAT

动态NAT

NAPT