slide1 n.
Download
Skip this Video
Loading SlideShow in 5 Seconds..
rogramación de PowerPoint Presentation
Download Presentation
rogramación de

Loading in 2 Seconds...

play fullscreen
1 / 64

rogramación de - PowerPoint PPT Presentation


  • 140 Views
  • Uploaded on

P. rogramación de. C. omputadores. Algoritmos: Constructores Básicos. CONTENIDO. Estructura de un algoritmo Los datos en programación Instrucciones sobre variables Estructuras de control Codificación de algoritmos en C++. Los elementos fundamentales: Datos. Instrucciones.

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

PowerPoint Slideshow about 'rogramación de' - lisbet


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript
slide1

P

rogramación de

C

omputadores

contenido
CONTENIDO

Estructura de un algoritmo

Los datos en programación

Instrucciones sobre variables

Estructuras de control

Codificación de algoritmos en C++

estructura de un algoritmo
Los elementos fundamentales:

Datos.

Instrucciones.

Estructuras de control.

ESTRUCTURA DE UN ALGORITMO
concepto de dato
Pieza de información simple

un número

un código

un hecho

una edad

3

1

2

Concepto de Dato
tipo de dato
Un conjunto es una colección ‘bien definida’ de elementos (objetos).

Las vocales

Los dígitos

Tipo de Dato

a,e,i,o,u

0,1,2,3,...,9

tipo de dato1
Todo conjunto debe tener un nombre.

Z y entero

R y real

ASCII y caracter

Booleano

Cadena

Tipo de Dato

Libros

tipo de dato2
Tipo de Dato

El nombre del conjunto al que pertenece el dato constituye el tipo del mismo.

slide9

Datos en programación

  • Entero

son representados utilizando 2, 4 u 8 bytes.

2 bytes:

rango(0 - 65536) enteros sin signo.

rango(-32767 - 32768) enteros con signo.

datos en programaci n
Reales: son representados utilizando dos esquemas:

Punto Flotante: Real representado como un entero y un byte adicional que indica la posición del punto.

Punto Fijo: Real representado por dos enteros, una mantisa y un exponente.

Datos en Programación

12345.6789 es representado como:

Mantisa = 123456789

Exponente =5

pues 0.123456789*105= 12345.6789

datos en programaci n1
Caracteres: representados en codificación ASCII, se asigna a cada carácter un valor numérico representado por un byte.

Ejemplo: el carácter ´A´ mayúscula es representado por el byte 01000001 (65 en decimal), la letra ´B´ mayúscula por el byte 66 en decimal y así sucesivamente.

Datos en Programación
datos en programaci n2
Existe un código ASCII para cada carácter representable (lista utilizada en los Laboratorios), algunos ejemplos:Datos en Programación

Espacio32

;59

048

*42

149

a97

957

datos en programaci n3
Cadenas: secuencia de letras, números u otros caracteres que se escriben dentro de comillas dobles.

Ejemplo:

“Estoy en clase de programación”

Datos en Programación
slide14

Datos en Programación

  • Booleanos: sólo pueden tomar valor falso o verdadero.
datos en programaci n4
Distinciones importantes:Datos en Programación

ENTERO

2

REAL

2.0

CARACTER

‘X’

CADENA

“X”

variables
Variables

Variable: es un símbolo que permite referenciar (señalar o demarcar) un espacio en memoria en el que se puede almacenar un dato.

variables1
Variables

suma

entero

168

nombre

cadena

Pablito Pérez

MEMORIA

Nombre

Tipo

Estado o Valor

variables2
Declaración de una variableVariables

<variable> : <tipo>

Ejemplos

  • x : real
  • contador : entero
literales
Secuencia de caracteres que representa un valor concreto.

Tipos :

entero: 12345, –138

real: 3465.98, –3.987

caracter: ‘a’, ‘3’

cadena: “pepito va al colegio”

booleano: falso o verdadero

Literales
constantes
Constante: es un símbolo que permite referenciar un espacio en memoria en el que hay un dato almacenado que NO se puede cambiar. Constantes
constantes1
Declaración de una constanteConstantes

<nombre> = <literal>

  • PI = 3.1416
  • TAMANO_MAXIMO = 1000
  • MENSAJE = “Digite los datos”
expresiones
Expresión: es una serie de términos (constantes, literales, variables y funciones) posiblemente agrupados mediante paréntesis y conectados mediante operadores (aritméticos como +, - y lógicos como , ), que representan un cálculo matemático.Expresiones
slide24

Evaluación de expresiones

  • Es el proceso que permite determinar el valor de la expresión, es decir, el resultado del cálculo. Según el tipo del resultado, las expresiones se clasifican en:
      • Expresiones numéricas
      • Expresiones lógicas
precedencia de operadores
Orden en el que se deben llevar a cabo las operaciones para evitar ambigüedadPrecedencia de Operadores

3+4*5

  • (3+4)*5
  • 3 +(4*5)
  • Se debe evaluar primero el operador con mayor precedencia.
evaluaci n expresiones num ricas
Evaluación expresiones numéricas

MEMORIA

(a + 5 ) * ( y+ abs (x) )

a

5

(5+ 5 ) * (8+ abs(-1) )

y

8

(5+ 5 ) * ( 8 +1)

x

-1

10 * 9

90

evaluaci n expresiones l gicas

( 4+ 5 < 4 ) (3= 3 )

( 9< 4 ) ( 3 = 3 )

F V

Evaluación expresiones lógicas

( a + 5 < 4 ) ( b = 3 )

MEMORIA

a b

4

3

F

ejemplo
Ejemplo

-3 * a + b * c

MEMORIA

(-3) *5 + 3 * 9

a bc

5

3

9

-15+27

12

instrucciones sobre variables
Operaciones para modificar variables

Asignación

Lectura (entrada).

Operación para mostrar

el valor de las variables

Escritura (salida).

INSTRUCCIONES SOBRE VARIABLES
instrucciones asignaci n
EstructuraINSTRUCCIONES ASIGNACIÓN

<variable> = <valor>

Constante

Variable o

Expresión

Operador de

Asignación

Nombre

ejemplos de asignaci n
EJEMPLOS DE ASIGNACIÓN

Asignar un valor a las

variables a y b

ejemplos de asignaci n1
EJEMPLOS DE ASIGNACIÓN

MEMORIA

a b

a: entero

b: entero

a = 5

b = a

5

5

instrucciones de entrada
INSTRUCCIONES DE ENTRADA
  • LECTURA

leer (variable)

instrucciones de entrada2

a

125

a

INSTRUCCIONES DE ENTRADA

Programa

Teclado

Memoria

a

XXX

instrucciones de salida
ESCRITURA

150

INSTRUCCIONES DE SALIDA

escribir (variable)

instrucciones de salida1

Variable(s)

INSTRUCCIONES DE SALIDA
  • Representación en diagrama de flujo
instrucciones de salida2

a

INSTRUCCIONES DE SALIDA

Programa

Memoria

Pantalla

a

125

125

estructuras de control
ESTRUCTURAS DE CONTROL
  • Constructores que determinan el flujo del programa
secuencia
SECUENCIA

Diagrama de Flujo

Pseudo código

a: entero

leer (a)

a =a*a

escribir (a)

a

a =a*a

a

ejemplo1
EJEMPLO

Hallar el cuadrado de un número

previamente leído

ejemplo2
EJEMPLO

Memoria

a, b: entero

leer (a)

b = a*a

escribir (b)

1

a b

100

2

XX

10

XX

100

3

slide47

SELECCIÓN

Tengo un buen trabajo ?????

No

Si

slide48

SELECCIÓN

si < condición > entonces

< bloque instrucciones 1>

sino

< bloque instrucciones 2>

fin_si

selecci n
SELECCIÓN

Diagrama de Flujo

Pseudo código

si x > 0 entonces

y =0

sino

y =1

fin_si

SI

NO

x>0

y =0

y =1

ejemplo3
EJEMPLO

Hallar el cuadrado o la suma de

un número previamente leído,

según la condición

ejemplo4
EJEMPLO

leer (a)

si a >0

entonces

b =a+a

sino

b =a*a

fin_si

escribir (b)

leer (a)

si a >0

entonces

b =a+a

sino

b =a*a

fin_si

escribir (b)

leer (a)

si a >0

entonces

b =a+a

sino

b =a*a

fin_si

escribir (b)

leer (a)

si a >0

entonces

b =a+a

sino

b =a*a

fin_si

escribir (b)

leer (a)

si a >0

entonces

b =a+a

sino

b =a*a

fin_si

escribir (b)

leer (a)

si a >0

entonces

sino

fin_si

escribir (b)

a, b: entero

Memoria

a b

XXX

40

80

XXX

80

ejemplo5
EJEMPLO

a, b: entero

leer (a)

si a >0

entonces

b =a+a

sino

b =a*a

fin_si

escribir (b)

leer (a)

si a >0

entonces

b =a+a

sino

b =a*a

fin_si

escribir (b)

leer (a)

si a >0

entonces

b =a+a

sino

b =a*a

fin_si

escribir (b)

leer (a)

si a >0

entonces

b =a+a

sino

b =a*a

fin_si

escribir (b)

leer (a)

si a >0

entonces

b =a+a

sino

b =a*a

fin_si

escribir (b)

leer (a)

si a >0

entonces

sino

fin_si

escribir (b)

Memoria

a b

100

XXX

-10

XXX

100

ejemplo6
EJEMPLO

Dados tres números

enteros, calcular el máximo

ejemplo a

a b c

mayor

XXX

XXX

XXX

XXX

EJEMPLO (a)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor := a

sino

si b>=a & b>=c entonces

mayor := b

sino

mayor := c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor := a

sino

si b>=a & b>=c entonces

mayor := b

sino

mayor := c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor := a

sino

si b>=a & b>=c entonces

mayor := b

sino

mayor := c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor := a

sino

si b>=a & b>=c entonces

mayor := b

sino

mayor := c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor := a

sino

si b>=a & b>=c entonces

mayor := b

sino

mayor := c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor := a

sino

si b>=a & b>=c entonces

mayor := b

sino

mayor := c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor := a

sino

si b>=a & b>=c entonces

mayor := b

sino

mayor := c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor := a

sino

si b>=a & b>=c entonces

mayor := b

sino

mayor := c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor := a

sino

si b>=a & b>=c entonces

mayor := b

sino

mayor := c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor := a

sino

si b>=a & b>=c entonces

mayor := b

sino

mayor := c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor := a

sino

si b>=a & b>=c entonces

mayor := b

sino

mayor := c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor := a

sino

si b>=a & b>=c entonces

mayor := b

sino

mayor := c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

Memoria

5

2

10

maximo

10

10

ejemplo b

a b c

mayor

XXX

XXX

XXX

XXX

EJEMPLO (b)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

a, b, c : entero

mayor: entero

leer (a)

leer (b)

leer (c)

si a>=b & a>=c entonces

mayor = a

sino

si b>=a & b>=c entonces

mayor = b

sino

mayor = c

fin_si

fin_si

escribir (“maximo”)

escribir (mayor)

Memoria

2

9

4

maximo

9

9

slide56

SELECCIÓN MÚLTIPLE

seleccionar <opcion> hacer

caso <constante 1>:

<bloque_intrucciones 1>

.

.

.

caso <constante n>:

<bloque_intrucciones n>

otrocaso:

<bloque_intrucciones>

fin_seleccionar

ejemplo7
EJEMPLO

Selección de una transacción

en un cajero automático

ejemplo a1

opcion

XXX

EJEMPLO (a)

opcion: entero

leer (opcion)

seleccionar opcion de

caso1: escribir (“Consignación”)

caso2: escribir (“Retiro”)

caso3: escribir (“Pago de Servicios”)

caso4: escribir (“Cambio de Clave”)

caso5: escribir (“Terminar”)

otrocaso: escribir (“Terminar”)

fin_seleccionar

Cambio de Clave

4

ejemplo b1

opcion

XXX

EJEMPLO (b)

opcion: entero

leer (opcion)

seleccionar opcion de

caso1: escribir (“Consignación”)

caso2: escribir (“Retiro”)

caso3: escribir (“Pago de Servicios”)

caso4: escribir (“Cambio de Clave”)

caso5: escribir (“Salir”)

otrocaso: escribir(“Salir”)

fin_seleccionar

Salir

5

slide64

FIN

Gracias por la atención prestada