slide1 n.
Download
Skip this Video
Loading SlideShow in 5 Seconds..
Initiation à la programmation et algorithmique cours 2 PowerPoint Presentation
Download Presentation
Initiation à la programmation et algorithmique cours 2

Loading in 2 Seconds...

play fullscreen
1 / 39

Initiation à la programmation et algorithmique cours 2 - PowerPoint PPT Presentation


  • 95 Views
  • Uploaded on

Initiation à la programmation et algorithmique cours 2. Plan. Données Opérateurs Les instructions Tableaux Sous-programme Types structurés. 3 Instructions (suite). 3 Instructions (suite). Introduction. En algorithmique comme en programmation : l'ordre des instructions est primordial

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

Initiation à la programmation et algorithmique cours 2


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
    Presentation Transcript
    1. Initiation à la programmationetalgorithmiquecours 2 Introduction à la programmation et algorithmique

    2. Plan • Données • Opérateurs • Les instructions • Tableaux • Sous-programme • Types structurés Introduction à la programmation et algorithmique

    3. 3 Instructions (suite) Introduction à la programmation et algorithmique

    4. 3 Instructions (suite) Introduction • En algorithmique comme en programmation : l'ordre des instructions est primordial • Le processeur exécute les instructions dans l'ordre dans lequel elles apparaissent dans le programme • L’exécution est séquentielle : une fois que le programme a fini une instruction, il passe à la suivante • Tant qu'une instruction n'est pas terminée, il attend avant de continuer (Exemple : Saisir) Introduction à la programmation et algorithmique

    5. 3 Instructions (suite) Introduction • Il peut-être nécessaire pour résoudre un problème • de n'exécuter les instructions que sous certaines conditions • de recommencer plusieurs fois les mêmes instructions • Il existe des instructions particulières appelées structures de contrôle qui le permettent : • instructions conditionnelles : exécuter certaines instructions uniquement sous certaines conditions • instructions répétitives (boucles) : répéter des instructions un certain nombre de fois (sous certaines conditions) Introduction à la programmation et algorithmique

    6. Les instructions conditionnelles Introduction à la programmation et algorithmique

    7. 3 Instructions : les instructions conditionnelles Instructions conditionnelles • Permettent d'exécuter des instructions différentes en fonction de certaines conditions • Une condition (expression conditionnelle ou booléenne) est évaluée, elle est : • soit vrai • soit fausse • Selon le résultat, les instructions à réaliser ne sont pas les mêmes • 3 types principaux : • instruction conditionnelle au sens strict : Si … Alors • instruction alternative :Si … Alors … Sinon • instruction conditionnelle multiple :Selon … Faire Introduction à la programmation et algorithmique

    8. 3 Instructions : les instructions conditionnelles Instruction conditionnelle stricte • Permet d'exécuter une ou plusieurs instructions si une condition est respectée et ne rien faire si la condition est fausse • Une instruction : Si <condition> Alors <instruction> • Bloc instruction : Si <condition> Alors <instruction1> <instruction2> <instruction3> Finsi Introduction à la programmation et algorithmique

    9. 3 Instructions : les instructions conditionnelles Exécution Expression testée Si vrai Si faux Bloc d’instructions à exécuter Introduction à la programmation et algorithmique

    10. 3 Instructions : les instructions conditionnelles Exemple PROGRAMME vote CONST majorite <- 18 : entier VAR age : entier DEBUT Afficher «quel est votre age ?» Saisir age Si age ≥ majorite Alors Afficher «Vous avez le droit de voter» Afficher «vous etes majeur depuis : », age–18, « ans » Finsi FIN Introduction à la programmation et algorithmique

    11. 3 Instructions : les instructions conditionnelles Instruction alternative • Permet de choisir entre deux actions, suivant une condition • L’instruction alternative va permettre d'effectuer des choix Si <condition> Alors <instruction1> <instruction2> Sinon <instruction3> <instruction4> Finsi Introduction à la programmation et algorithmique

    12. 3 Instructions : les instructions conditionnelles Exécution Expression testée Si vrai Si faux Bloc d’instructions à exécuter Bloc d’instructions à exécuter Introduction à la programmation et algorithmique

    13. 3 Instructions : les instructions conditionnelles Exemple PROGRAMME vote CONST majorite <- 18 : entier VAR age : entier DEBUT Afficher «quel est votre age ?» Saisir age Si age ≥ majorite Alors Afficher «Vous avez le droit de voter» Afficher «vous etes majeur depuis : », age – 18 , « ans» Sinon Afficher «Vous n’avez pas le droit de voter» Finsi FIN Introduction à la programmation et algorithmique

    14. 3 Instructions : les instructions conditionnelles Exemple PROGRAMME vote CONST majorite <- 18 : entier VAR age : entier DEBUT Afficher «quel est votre age ?» Saisir age Si age ≥ majorite Alors Afficher «Vous avez le droit de voter» Afficher «vous etes majeur depuis : », age – 18, « ans» Sinon Afficher «Vous n’avez pas le droit de voter» Afficher «vous devez attendre : », 18 - age , « ans» Finsi FIN Introduction à la programmation et algorithmique

    15. 3 Instructions : les instructions conditionnelles Expression conditionnelle • Expression conditionnelle (ou expression booléenne) est : • soit VRAI • soit FAUX • Mais plusieurs types : • Condition simple • Condition complexe • Variable booléenne Introduction à la programmation et algorithmique

    16. 3 Instructions : les instructions conditionnelles Condition simple • Une condition simple est une comparaison de deux expressions de même type • Symboles de comparaison : • < , > , = , ≤ , ≥, ≠ Introduction à la programmation et algorithmique

    17. 3 Instructions : les instructions conditionnelles Exemples Si c = ‘a’ AlorsAfficher «le caractere est a» Si r = 3,3 * x AlorsAfficher « l’expression est vrai » Si (x – 3 + y) * a ≤ z – 2 + b / 3 AlorsAfficher « l’expression est vrai » Introduction à la programmation et algorithmique

    18. 3 Instructions : les instructions conditionnelles Condition complexe • Une condition complexe est une comparaison formées de plusieurs conditions simples ou variables booléennes reliées entre elles par les opérateurs logiques • opérateurs logiques : • ET, OU, NON Introduction à la programmation et algorithmique

    19. 3 Instructions : les instructions conditionnelles Exemples Si (c1 = ‘a’) ET (c2 = ‘a’) AlorsAfficher «les caracteres sont a» Si (r = 3,3 * x) OU (r = 3,3 * y) AlorsAfficher «une expression est vrai» Si (((x – 3 ) * a) ET (z + b / 3)) OU c < 2 AlorsAfficher «le tout est vrai» Introduction à la programmation et algorithmique

    20. 3 Instructions : les instructions conditionnelles Variable booléenne • Une variable booléenne, comme une expression conditionnelle, est : • soit vraie • Soit fausse • On peut donc mettre une variable booléenne à la place d’une expression conditionnelle • Les variables booléennes et les expressions conditionnelles sont équivalentes Introduction à la programmation et algorithmique

    21. 3 Instructions : les instructions conditionnelles Exemple PROGRAMME id VAR nom : chaine age : entier sexe, repEx : caractère homme, exempte : booleen DEBUT Afficher «quel est votre sexe ? (H/F)» Saisir sexe homme <- sexe = ‘H’ Afficher «quel est votre age ?» Saisir age Afficher «quel est votre nom ?» Saisir nom Si homme Alors Afficher «etes-vous exempte de service militaire ? (O/N)» Saisir repEx exempte <- repEx = ‘O’ Finsi FIN Introduction à la programmation et algorithmique

    22. 3 Instructions : les instructions conditionnelles Instructions conditionnelles imbriquées • Exemple : Si (x < 0) Alors Afficher «x negatif» SinonSi (x < 10) Alors Afficher «x unite» SinonSi (x < 20) Alors Afficher «x dizaine» Sinon Afficher «x ≥ 20» Finsi Finsi Finsi Introduction à la programmation et algorithmique

    23. 3 Instructions : les instructions conditionnelles Instruction conditionnelle multiple • Permet de choisir les instructions à effectuer en fonction de la valeur (ou de l'intervalle de valeur) d'une variable ou d'une expression • Permet de remplacer une succession d’instructions Si … Alors Introduction à la programmation et algorithmique

    24. 3 Instructions : les instructions conditionnelles Syntaxe Selon expression Faire valeur 1 : bloc d’instructions 1 valeur 2 : bloc d’instructions 2 valeur 3 : bloc d’instructions 3 … [Sinon instructions par défaut] Finselon Introduction à la programmation et algorithmique

    25. 3 Instructions : les instructions conditionnelles Exécution Évaluer expression Tester expression = valeur 1 Si vrai Bloc instructions 1 Si faux Tester expression = valeur 2 Si vrai Bloc instructions 2 Si faux Tester expression = valeur 3 Si vrai Bloc instructions 3 Si faux Bloc instructions par défaut Introduction à la programmation et algorithmique

    26. 3 Instructions : les instructions conditionnelles Exemples Selon mois Faire 1 : Afficher "Janvier" 2 : Afficher "Février" 3 : Afficher "Mars" 4 : Afficher "Avril" … 11: Afficher "Novembre" 12: Afficher "Décembre" Sinon Afficher "Un numéro de mois doit être compris entre 1 et 12" Finselon Introduction à la programmation et algorithmique

    27. 3 Instructions : les instructions conditionnelles Exemples Selon montant Faire <1000 : taux <- 1,0 ≥1000 ET < 3000: taux <- 2,0 ≥3000 ET < 10000: taux <- 3,0 ≥ 10000: taux <- 4,0 FinSelon montant <- montant * ( 1,0 – taux / 100,0) Introduction à la programmation et algorithmique

    28. Les instructions répétitives(les boucles) Introduction à la programmation et algorithmique

    29. 3 Instructions : les boucles Instructions répétitives (boucles) • Permettent de répéter une instruction (ou un bloc) autant de fois qu'il est nécessaire : • soit tant qu'une condition est vraie • soit un nombre déterminé de fois • 3 grands types : • Tant que … Faire : si condition répète • Pour : répète n fois • Répéter … Jusqu'à : répète jusqu’à condition Introduction à la programmation et algorithmique

    30. 3 Instructions : les boucles Boucle Tant que • la boucle Tant que est fondamentale • avec cette boucle, on peut réaliser toutes les autres boucles • permet d'effectuer un bloc d’instructions tant qu'une condition est satisfaite • Syntaxe : Tant que <condition> Faire <instruction> FinTantque Introduction à la programmation et algorithmique

    31. 3 Instructions : les boucles Exécution Bloc d’instructions De la boucle Expression testée Si vrai Si faux Introduction à la programmation et algorithmique

    32. 3 Instructions : les boucles Exemples PROGRAMME gestion VAR budget, depense : entier DEBUT Afficher « quel est le budget de depart ? » Saisir budget Tant que budget > 0 Faire Afficher « vous ne pouvez pas depenser plus de », budget Afficher « montant de la depense ? » Saisir depense budget <- budget – depense FinTantque Afficher « le budget a ete depasse de: », budget * (-1) FIN Introduction à la programmation et algorithmique

    33. 3 Instructions : les boucles Boucle Pour • permet de répéter un bloc d’instructions un certain nombre de fois • permet de simplifier la boucle Tantque lorsque le nombre de « tour » de boucle est connu d’avance • Syntaxe : Pour <cpt> de <val init> à <val fin> [pas de <incrément>] Faire <bloc instructions> FinPour Introduction à la programmation et algorithmique

    34. 3 Instructions : les boucles Exécution Instruction initialisation Compteur <- valeur initiale Instruction incrémentation Compteur <- compteur + incrément Bloc d’instructions de la boucle Expression Testée Si vrai Compteur ≠ val finale Si faux Introduction à la programmation et algorithmique

    35. 3 Instructions : les boucles Exemples Programme table3 Var x : entier Début Pour x de 1 à 10 pas de 1 Faire Afficher x, " * 3 = ", x * 3 FinPour Fin Introduction à la programmation et algorithmique

    36. 3 Instructions : les boucles Boucle Répéter • permet de répéter un bloc d’instructions jusqu'à ce qu'une condition soit satisfaite • moins utilisée • Syntaxe : Répéter <instructions> Jusqu'à <condition> Introduction à la programmation et algorithmique

    37. 3 Instructions : les boucles Exécution Bloc d’instructions de la boucle Expression testée Si vrai Si faux Introduction à la programmation et algorithmique

    38. 3 Instructions : les boucles Exemples Programme carre Var x, res : entier rep : caractère Début Répéter Afficher « Entrez un entier : » Saisir x Afficher x, « au carré = », x * x Afficher «voulez-vous continuez ? (O/N)» Saisir rep Jusqu’à rep = ‘N’ Afficher « au revoir » Fin Introduction à la programmation et algorithmique

    39. 3 Instructions : les boucles Exemples Programme exposant Var x, n, res : entier rep : caractère Début Aff « Entrez un entier : » Saisir x res <- x n <- 1 Répéter res <- res * res n <- n + 1 Afficher x, « puissance », n, « = », res Afficher «voulez-vous continuez ? (O/N)» Saisir rep Jusqu’à rep = ‘N’ Afficher « au revoir » Fin Introduction à la programmation et algorithmique