network design wan n.
Download
Skip this Video
Loading SlideShow in 5 Seconds..
Network Design 第六章 WAN 接入设计 PowerPoint Presentation
Download Presentation
Network Design 第六章 WAN 接入设计

Loading in 2 Seconds...

play fullscreen
1 / 110

Network Design 第六章 WAN 接入设计 - PowerPoint PPT Presentation


  • 160 Views
  • Uploaded on

Network Design 第六章 WAN 接入设计. 中国科学技术大学网络学院 李艺 leeyi@ustc.edu.cn. 第一章 概述 第二章 用户需求分析 第三章 现有网络分析 第四章 逻辑网络设计 第五章 网络设备选择 第六章 WAN 接入设计 第七章 网络介质设计 第七章 网络设计案例. 6.1 广域网技术 6.2 广域网接入设计 6.3 优化广域网设计. 6.1 广域网技术.

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

PowerPoint Slideshow about 'Network Design 第六章 WAN 接入设计' - federico


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript
network design wan
Network Design第六章 WAN接入设计

中国科学技术大学网络学院 李艺

leeyi@ustc.edu.cn

slide2
第一章 概述

第二章 用户需求分析

第三章 现有网络分析

第四章 逻辑网络设计

第五章 网络设备选择

第六章 WAN接入设计

第七章 网络介质设计

第七章 网络设计案例

slide3
6.1 广域网技术

6.2 广域网接入设计

6.3 优化广域网设计

slide4
6.1 广域网技术

广域网(WAN)对于企业的网络建设、使用成本是一个最大的单项开支。因此,强调得最多的和最重要的是有一个权衡性价比。本节将探讨各种可选的方法。这些方法在选择和设计WAN基础设施的时候是必须要进行评估的。不同的拓扑的和技术的选择将从它们与基本的WAN设计目标的关系的角度进行讨论。

slide5

服务供应商

广域网的概念
  • 局域网只能在一个相对比较短的距离内实现,当主机之间的距离较远时,例如,相隔几百公里或几千公里,局域网显然就无法完成通信任务。这时就需要另一种结构的网络,即广域网。广域网的地理覆盖范围可以从数公里到数千公里,可以连接若干个城市、地区甚至跨越国界而成为遍及全球的一种计算机网络。广域网将地理上相隔很远的局域网互连起来。
slide6

HDLC, PPP

专线

PPP, HDLC

电路交换

服务供应商

X.25, Frame-Relay

分组交换

服务供应商

广域网接入技术
slide7
广域网接入技术
  • CPE:用户室内设备
  • Demarcation:分界点
  • Local loop:本地回路
  • CO Switch:中心局交换机
  • Toll network:长途网络
slide8
广域网设备
  • 广域网交换机
  • 接入服务器
  • 调制解调器
  • CSU/DSU
  • ISDN终端适配器
  • 路由器(Router)
slide9
广域网中的数据链路层协议
  • 点到点协议(PPP)
  • 高级数据链路控制(HDLC)协议
  • 帧中继(Frame Relay)
slide10
点到点专线

常见的广域网协议有,Link Access Procedure on the D channel (LAPD),High-Level Data Link Control (HDLC),和Point-to-Point Protocol (PPP)。他们都具有以下的功能:

  • LAPB,HDLC和PPP都提供了数据通过单一的点到点的串行连接的投递。
  • LAPB,HDLC和PPP都可以在同步串行接口上投递数据。(PPP也可以在异步接口上使用)
slide11
点到点专线
  • 帧是任何同步数据链路协议的核心特征。每个协议都对帧进行定义,所以接收的工作站知道哪里是帧的开始,头中的地址是什么,以及数据开始的位置。
  • 同步连接通常在路由器之间使用。同不简单的说就是在线路两端发送和接收信号时要收时序的影响。这就意味着两端都要同意使用某种速度,但是如果要让所有的设备都真正的按同样速度操作,代价是相当昂贵的,所以一般让设备和某个时钟源的速率同步。
slide17
PPP会话建立
  • PPP 支持两种身份认证协议:PAP、CHAP
slide18
PPP认证
  • PAP利用双向握手确认呼叫方的合法性
  • 当PPP链路建立阶段完成后,呼叫方重复发送用户名/口令对,直到认证被确认或未通过认证而拆除链路
  • 口令以明文的形式在链路上传送
slide19
PPP认证
  • CHAP使用三次握手的方法周期性地验证
  • Hash值(MD5)
slide20
PPP封装和认证例

Router(config-if)#encapsulation ppp

  • Enables PPP encapsulation

Router(config)#hostname name

  • Assigns a host name to your router

Router(config)#username name password password

  • Identifies the username and password of remote router

Router(config-if)#ppp authentication{chap | chap pap | pap chap | pap}

  • Enables PAP and/or CHAP authentication
frame relay protocols

Access

Link

Access

Link

Frame

Relay

DCE

DCE

LMI Messages

LMI Messages

Frame Relay

Header

Layer 3

Packet

帧中继(Frame Relay Protocols)
frame relay protocols1

OSI Reference Model

Frame Relay

Application

Presentation

Session

Transport

Network

IP/IPX/AppleTalk, etc.

Data-Link

Frame Relay

EIA/TIA-232, EIA/TIA-449, V.35, X.21, EIA/TIA-530

Physical

帧中继(Frame Relay Protocols)
  • 帧中继运行在OSI的下二层
frame relay protocols2
帧中继(Frame Relay Protocols)
  • Local Management Interface (LMI)
    • LMI消息提供了关于当前DLCI值,虚电路状态等的信息。
    • 主要有下面这些LMI信号格式:
      • ANSI: Annex D defined by ANSI standard T1.617
      • ITU-T(Q.933A): Annex A defined by Q.933A
      • Cisco: LMI defined by the gang of four (default)

(从IOS11.2起,LMI类型可以被自动检测到)

  • 帧中继术语
    • 本地接入速率 虚电路(VC) PVC SVC
    • 数据链路连接符(DLCI) 承诺信息速率(CIR)
    • 反向地址解析协议(反向ARP) 本地管理接口(LMI)
    • 前向显式拥塞通知(FECN) 后向显式拥塞通知(BECN)
frame relay protocols3
帧中继(Frame Relay Protocols)
  • Data-Link Connection Identifiers
    • DLCI用来区分虚电路。
  • Sub interfaces
    • 在一个串行界面上可以使用多个虚电路,可以把每个虚电路当成一个独立的接口,叫做子界面。
  • 问题:
    • 只有建立虚电路的两点间才能通信
    • 水平分割问题
slide26
解决水平分割问题
  • Split horizon can cause problems in NBMA environments.
  • Subinterfaces can resolve split horizon issues.
  • Solution: A single physical interface simulates multiple logical interfaces.
slide27
6.2 广域网接入设计

随着企业规模的发展,很多企业的分散性和流动性逐渐明显,远程访问技术已经成为很多企业网络设计中的重要部分。企业网络使用远程接入结束为远离企业的员工提供网络接入能力。

企业网络设计中,远程接入技术的多样化让用户有充分的选择余地。要考虑的基本的技术要求有:

1. 广域网要为企业网提供合适的接入方案。

2. 广域网链路提供的通信服务质量要有保证,这样互连起来的企业网之间的数据传输才能畅通,广域网上的业务才能顺利开展。

slide28
广域网接入设计趋势及相关技术
  • 设计要点
    • 1. 充分分析WAN的带宽效率和带宽费用,保证WAN链路的可用性和可靠性。
    • 2. 详细设计WAN链路和接入技术的控制策略。
    • 3. 彻底评估WAN中的安全性。
  • 设计趋势
    • 1. 远程连接的增多
    • 2. 远程访问的增多
    • 3. 企业内部网的高速增长
    • 4. 企业网要求提供的服务日益增多
slide29
WAN设计的新特点

(1)优化传统链路的带宽:以便在节约成本的前提下,支持更多的服务。

(2)光传输技术的发展(SDH、DWDM等)为IP网络宽带化提供了坚实的技术基础,IP over SDH、IP over DWDM等技术为WAN设计提供了新的思路。

(3)宽带骨干网技术的发展,例如多协议标鉴交换MPLS,为WAN设计提供了新的选择。

slide31
拨号线路

拨号线路在可少 WAN 网络成本、提供后援附加带宽线路。这些连接还可以在不需要时被释放掉。有三种请求拨号的方法:

  • 按需拨号(DOD):工作在DOD模式的拨号连接会提高或减少流量对连接的依赖性。请求很多时,链路会一直保持挂起状态(如果连上的话),流量很少时,链路在用户配置的时间到期后中断连接。DOD是利用电话线连入WAN。
  • 按需带宽(BOD):在主要的 WAN 连接于用户指定时间段内出现拥塞时,路由器可自动连接拨号线路来提供附加带宽。
  • 灾难恢复:当路由器检测到主要的WAN连接失败,且鼓掌时间长达用户指定的时间段时,路由器可自动启动备用拨号连接。
slide32

AAA

Modem

NAS

Router

  • 拨号接入:用户通过拨号接入Internet

AAA:认证、授权、计费

slide33
拨号接入的原理
    • PSTN作为物理线路,MODEM进行调制和解调
    • 香农定理:线路的最大传输速率=线路的采样频率*log2(1+信噪比)
    • 经过模拟/数字转化的传输速率应当小于35kbs
    • MODEM 下行的速率可达56kbps,这是由于现行PSTN中,部分已由数字电路取代模拟网络的工作
slide34
ISDN

ISDN是通过网络互联,使用户与分组交换网中分组终端及电话网中的电话用户相连的。随着因特网及数据业务接入技术的发展,宽带ISDN已成为发展方向。

  • 与电话拨号方式相比, ISDN提供了更有效的多样化业务服务,不仅增加了图像、图形、数据多种业务,而且可为用户提供64Kbit/s为基础的数字连接,传输速率比在电话网上利用Modem传数据的速率提高数倍以上;
  • 与DDN相比, ISDN可以同时使用多个终端,在一条ISDN电话线上,可以用一条通道保持一个声音通话,用另一条通道上网; ISDN提供的64Kbit/s或128Kbit/s数据信息,比目前使用的DDN的数据信息可靠性高,而且可以同时进行数据传输和电话交谈;此外,ISDN的数据信息能力作为DDN的后备,在DDN出故障时即可自动切换成ISDN数据通信方式。
slide35

ISDN

Service-Server

ISDN的特性

NAS (Network Access Server)

接入服务器

SOHO 用户

  • 特点:
    • 高可用带宽(128K)
    • 按需拨号
    • 快速联接
    • 高性价比
    • 安全特性 (PAP、CHAP、 RADIUS)
  • Voice, data, video, and special services
slide36
基本速率接口 (BRI)

单一物理连接

两条逻辑连接

客户端适用

基群速率接口 (PRI)

单一物理连接

30条逻辑连接

中心节点适用

64K*30

2B

30B

D

16K

144kbps

D

64K

2Mbps

ISDN 接口

64K*2

ISDN使用D信道进行呼叫和控制。

使用B信道进行数据传输。

isdn cpe
功能是设备或硬件

参考点是分界点或接口

ISDN CPE和参考点
isdn spid
ISDN 交换机类型和服务配置文件标识符(SPID)
  • Many providers use many different switch types.
  • Services vary by region and country.
isdn bri1
配置ISDN BRI
  • The command specifies the type of ISDN switch with which the router communicates.
  • Other configuration requirements vary for specific providers.

Step 1: Specify the ISDN switch type.

Router(config)#isdn switch-type switch-type

Router(config-if)#isdn switch-type switch-type

isdn bri2
Sets a B channel SPID required by many service providers配置ISDN BRI(续)

Step 2: (Optional) Setting SPIDs

Router(config-if)#isdn spid1 spid-number [ldn]

Router(config-if)#isdn spid2 spid-number [ldn]

  • Sets a SPID for the second B channel
isdn pri1
配置ISDN PRI

Step 1: 指定D信道的交换机类型

Router(config)#isdn switch-type switch-type

Step 2: 配置控制器时钟脉冲源、帧类型和线路编码特征

Router(config)#controller controller slot/port

Step 3: 指定PRI使用T1/E1的哪些信道/时隙

Router(config-controller)#pri-group timeslots range

itu t isdn

控制

管理

C

M

U

L7

用户

L6

L5

L4

L3

L2

L1

物理媒体

ITU-T的ISDN协议模型
slide46
ISDN的用户-网络接口规范

TE1:ISDN

设备

TA:终端

适配器

NT2:智能网络终端,

与ISDN 2、3层连接

NT1:一类网络终端,

与ISDN物理层连接

TE2:非ISDN终端

NT1

TE1

NT2

T

S

R

U

TE2

TA

R参考点:定义

了TE2设备和

TA之间的接口

S参考点:定义了

TE1(或T2)设备和

NT2之间的接口

T参考点:定义

了NT1和NT2

之间的接口

U参考点:定义

了NT1和ISDN

服务之间的接口

slide47

NT1

ISDN适配卡

TA128适配器

ISDN 数字话机

ISDN终端设备的功能

网络终端(NT)

  • 一类网络终端(NT1),提供2B+D二

线双向传输能力,它完成线路传输码型的

转换,并实现回波抵消数码传输技术

  • 智能网络终端(NT2)

ISDN用户终端

  • ISDN适配卡
  • ISDN适配器
  • ISDN数字电话
  • ISDN可视电话

TA和ISDN卡的区别就像外置Modem和内置

Modem的区别。外置的就是TA,内置的就是

ISDN卡。

typical isdn connection

2 Wire

ISDN

Modem

RS-232

广域网

(R)

(U)

TA & NT1

Typical ISDN Connection
isdn pri examples
ISDN PRI Examples

T1 Sample Configuration

Router(config)#controller T1 3/0

Router(config-controller)#framing esf

Router(config-controller)#linecode b8zs

Router(config-controller)#pri-group timeslots 1-24

Router(config-controller)#interface Serial3/0:23

Router(config-if)#isdn switch-type primary-5ess

Router(config-if)#no cdp enable

E1 Sample Configuration

Router(config)#controller E1 3/0

Router(config-controller)# framing crc4

Router(config-controller)# linecode hdb3

Router(config-controller)# pri-group timeslots 1-31

Router(config-controller)#interface Serial3/0:15

Router(config-if)# isdn switch-type primary-net5

Router(config-if)# no cdp enable

slide50
按需拨号路由选择
  • Connects when needed
  • Disconnects when finished
  • ISDN or PSTN
slide51
何时用DDR?
  • Periodic(间歇性) connections
  • Small amounts of data
slide52
DDR工作原理

1. Route to destination is determined.

2. Interesting packets dictate DDR call.

3. Dialer information is looked up.

4. Traffic is transmitted.

5. Call is terminated.

slide53

2

1

3

配置标准DDR

Define static routes—What route do I use?

Specify interesting traffic—What traffic enables the link?

Configure the dialer information—What number do I call?

1

slide55
指定感兴趣的数据流

dialer-list 1 protocol ip permit

  • Any IP traffic will initiate the link without access lists.

dialer-list 1 protocol ip list 101

access-list 101 deny tcp any any eq ftp

access-list 101 deny tcp any any eq telnet

access-list 101 permit ip any any

Denies FTP

Denies Telnet

  • Any IP traffic, except FTP and Telnet, will initiate the linking.
  • Using access lists gives finer control.
slide56
配置拨号信息
  • Applies rules defined by dialer-list to individual interfaces

hostname Home

!

isdn switch-type basic-5ess

!

username central password cisco

interface BRI0

ip address 10.1.0.1 255.255.255.0

encapsulation ppp

dialer idle-timeout 180

dialer map ip 10.1.0.2 name Central 5552000

dialer-group 1

no fair-queue

ppp authentication chap

!

router rip

network 10.0.0.0

!

no ip classless

ip route 10.10.0.0 255.255.0.0 10.1.0.2

ip route 10.20.0.0 255.255.0.0 10.1.0.2

!

dialer-list 1 protocol ip permit

Both ValuesMust Match

slide58
定义负载均衡(可选)和计时器

Router(config-if)#dialer load-threshold load [outbound | inbound | either]

  • Establishes the amount of traffic on the link before a second link is enabled

Router(config-if)#dialer idle-timeout seconds

  • Establishes the idle time before disconnect
slide59
配置总结

hostname Home

!

isdn switch-type basic-5ess

!

username central password cisco

interface BRI0

ip address 10.1.0.1 255.255.255.0

encapsulation ppp

dialer idle-timeout 180

dialer map ip 10.1.0.2 name Central 5552000

dialer-group 1

no fair-queue

ppp authentication chap

!

router rip

network 10.0.0.0

!

no ip classless

ip route 10.10.0.0 255.255.0.0 10.1.0.2

ip route 10.20.0.0 255.255.0.0 10.1.0.2

dialer-list 1 protocol ip permit

!

3

1

2

slide63
配置拨号接口

interface dialer1

ip address 10.1.1.1 255.255.255.0

encapsulation ppp

dialer remote-name Smalluser

dialer string 5554540

dialer idle-timer 180

dialer pool 1

dialer-group 1

ppp authentication chap

!

interface dialer2

ip address 10.2.2.1 255.255.255.0

encapsulation ppp

dialer remote-name Mediumuser

dialer string 5551234

dialer idle-timer 180

dialer pool 1

dialer-group 2

interface dialer3

ip address 10.3.3.1 255.255.255.0

encapsulation ppp

dialer remote-name Poweruser

dialer string 4155554321

dialer idle-timer 300

dialer pool 1

dialer-group 3

(cont.)

ddr isdn
验证DDR和ISDN

Router#ping or telnet

  • Triggers a link

Router#show dialer

  • Displays current status of the link

Router#show isdn active

  • Displays call status while call is in progress

Router#show isdn status

  • Displays the status of an ISDN connection

Router#show ip route

  • Displays all routes, including static routes
ddr isdn1
验证DDR和ISDN

NASX#show dialer interface bri0

Dial String Successes Failures Last called Last status

5553872 6 0 19 secs Successful

0 incoming call(s) have been screened.

BRI0: B-Channel 1

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Time until disconnect 102 secs

Current call connected 00:00:19

Connected to 5553872 (system1)

BRI0: B-Channel 2

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

BRI0 - dialer type = ISDN

Dialer state is data link layer up

Dial reason: ip (s=10.1.1.8, d=10.1.1.1)

Interface bound to profile Dialer0

ddr isdn2
诊断DDR和ISDN

Router#debug isdn q921

  • Shows ISDN Layer 2 messages

Router#debug isdn q931

  • Shows ISDN call setup and teardown activity

Router#debug dialer [events | packets]

  • Displays DDR debugging information about the packets received on a dialer interface

Router(config-if)#shutdown

  • Clears currently established connections from the interface
ddr isdn3
诊断DDR和ISDN

Router#debug isdn q921

Jan 3 14:52:24.475: ISDN BR0: TX -> INFOc sapi = 0 tei = 64 ns = 5 nr = 2

i = 0x08010705040288901801837006803631383835

Jan 3 14:52:24.503: ISDN BR0: RX <- RRr sapi = 0 tei = 64 nr = 6

Jan 3 14:52:24.527: ISDN BR0: RX <- INFOc sapi = 0 tei = 64 ns = 2 nr = 6

i = 0x08018702180189

Jan 3 14:52:24.535: ISDN BR0: TX -> RRr sapi = 0 tei = 64 nr = 3

Jan 3 14:52:24.643: ISDN BR0: RX <- INFOc sapi = 0 tei = 64 ns = 3 nr = 6

i = 0x08018707

Jan 3 14:52:24.655: ISDN BR0: TX -> RRr sapi = 0 tei = 64 nr = 4

%LINK-3-UPDOWN: Interface BRI0:1, changed state to up

Jan 3 14:52:24.683: ISDN BR0: TX -> INFOc sapi = 0 tei = 64 ns = 6 nr = 4

i = 0x0801070F

Jan 3 14:52:24.699: ISDN BR0: RX <- RRr sapi = 0 tei = 64 nr = 7

%LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state to up

%ISDN-6-CONNECT: Interface BRI0:1 is now connected to 61885 goodie

Jan 3 14:52:34.415: ISDN BR0: RX <- RRp sapi = 0 tei = 64 nr = 7

Jan 3 14:52:34.419: ISDN BR0: TX -> RRf sapi = 0 tei = 64 nr = 4

ddr isdn4
诊断DDR和ISDN

Router#debug isdn q931

TX -> SETUP pd = 8 callref = 0x04

Bearer Capability i = 0x8890

Channel ID i = 0x83

Called Party Number i = 0x80, `415555121202'

RX <- CALL_PROC pd = 8 callref = 0x84

Channel ID i = 0x89

RX <- CONNECT pd = 8 callref = 0x84

TX -> CONNECT_ACK pd = 8 callref = 0x04....

Call SetupProcedure forOutgoing Call

Router#debug isdn q931

RX <- SETUP pd = 8 callref = 0x06

Bearer Capability i = 0x8890

Channel ID i = 0x89

Calling Party Number i = 0x0083, `81012345678902'

TX -> CONNECT pd = 8 callref = 0x86

RX <- CONNECT_ACK pd = 8 callref = 0x06

Call SetupProcedure forIncoming Call

ddr isdn5
诊断DDR和ISDN

Router#debug dialer events

Dialing cause: Serial0: ip (s=172.16.1.111 d=172.16.2.22)

Router#debug dialer packets

BRI0: ip (s=10.1.1.8, d=10.1.1.1), 100 bytes, interesting (ip PERMIT)

ddr isdn6
诊断DDR和ISDN

Cause

Missing or incorrect “interesting traffic” definitions

Incorrect interface state

Misconfigured dialer map

Misconfigured dialer profile

Suggested Actions

Verify the configuration using show running-configuration

Ensure that the interface state is “up/up” (spoofing)

Make sure the dialing interface has at least one dialer map statement

Make sure the dialer interface is configured with a dialer pool X command

slide72
ADSL接入方式
  • ADSL接入是DSL(Digital Subscribe Line)接入的一种
  • SDSL ( Symmetrical DSL)上行和下行几乎相同
  • ADSL(Asymmetrical DSL)上行一般为640Kbps-1Mbps,下行可达1Mbps-8Mbps
  • 用户上网一般用ADSL,从用户发简短控制信息,而从Internet发送大量的数据流
slide73

MA 5100

滤波器

电话交换机

ADSL MODEM

ADSL接入的过程
slide74
ADSL的原理
  • 使用电话线的高频段传输,存在衰减、群时延、传扰、回波干扰、相位误差
  • ADSL采用DMT(离散多音频)调制编码技术,有效减小衰减和群时延
  • ADSL将上下行数字信道分开,避免回波干扰
cable modem

前端

TV

分前端

分前端

分前端

Cable Modem

Cable Modem接入技术

前端+光纤环网+“树”型同轴电缆网构成

cable modem1

有线电视网

Cable Modem的接入方式

下 行 数 据

Cable Modem

上 行 数 据

前端+光纤环网+“树”型同轴电缆网构成

cable modem2

有线电视网

Cable Modem的接入方式

下 行 数 据

Cable Modem

上 行 数 据

将有线电视网中的同轴电缆进行划分,可分为低分割、中分割,高分割三种

slide78
6.3 优化广域网设计

WAN环境与LAN环境完全不同,LAN的设计原则是带宽有效、价格低廉、能自行控制。而WAN由于带宽很窄、价格昂贵,其连入的解决思路就完全不同。下表列出了LAN与WAN的区别:

  • 学习目标:掌握WAN路由特点,掌握距离向量和状态路由协议的区别。
  • 关键知识:典型的WAN电路的带宽是典型LAN电路带宽的1/160。
slide79

WAN瓶颈

WAN的网络瓶颈

企业的LAN接入WAN时,接口出会产生瓶颈。因为通常64 Kb/s的WAN电路只提供相当于10 Mb/s以太网的1/160的带宽。所以接入的基本问题就变为:如何有效地利用连接设备在WAN有限的带宽内满足应用需求。

构成 LAN/WAN 连接的网络设备负责管理对有限的WAN带宽的访问。它不能让不必要的数据进入 WAN,提供对 WAN带宽的利用和管理。提供网络拥塞时临时增加带宽的有效管理办法。

slide80
用路由器软件为WAN提供优化连接

路由器提供 LAN 与 WAN 之间的连接。路由器具有如下优越性能:

  • 非常适合用于“保持”(即不向外网转发)不必要的LAN流量,比如广播流量、不支持的协议流量、目的地不明确的流量。
  • 处在 LAN 和 WAN接口处,能很好地控制、排队和选择优先流量。
  • 提供向 WAN 技术的接入,允许网管为网络需求选择最优值。
  • 标记网络边缘,将由于错误配置、“饶舌”设备限制在出错的区域内而不扩散到外网和因特网。
slide81
选择路由器的路由转发协议

路由器为了保证将数据包沿最佳转发到目的地,网络管理员得考虑选择一个较好的路由转发协议。有两类路由协议:

  • 距离矢量路由协议:如RIP,定时想其邻接的路由器发送全部路由表,即使拓扑结构不改变。
  • 链路状态路由协议:如OSPF,只在拓扑结构发生变化时才发送更新信息。更新信息只描述拓扑结构变动的地方,而不是整个路由表。

两类路由协议相比较,对于大型网络,一般选择链路状态路由协议,这类协议虽然计算繁琐,但有如下难得的优点:

    • 占用网络带宽少;
    • 收敛快;
    • 支持分层路由;此优点使得该协议的消耗的带宽进一步降低。
slide82
数据包整形

数据包整形器将网络通信业务依其重要性的不同放入队列中,比如关键应用和对延迟敏感的应用程序将获得更高的优先权。这可以通过限制某些应用程序所占的带宽或阻止某些应用程序来实现。

slide83
增加路由控制

在拥有超过一条因特网连接的站点实现路由控制或路由优化,这是一种被称为多宿主主机(Multi-Homing)的配置。站点的路由控制设备作为BGP (Border Gateway Protocol)连接到网络,BGP是一种路由机制,用以确定使用哪一条因特网连接。这种选择是根据哪一条连接将使用最少的路由器跳数到达目的地来决定的。路由控制更可以根据性能与价格的综合影响因素来选择最佳的路由,这一点比BGP做得还要好。

slide84
减少串行化延迟
  • 什么是串行化延迟?

发送数据包所需要的时间称为传输延迟 (Transmission Delay),或称为串行化延迟 (Serialization Delay)。什么时候必须考虑广域网上串行化延迟的问题?

    • 在低速广域网上传输大数据包(如运行FTP)时;
    • 在广域网上传输语音、视频等多媒体数据包时;
    • 在广域网上传输象Telnet之类的,对延时很敏感的数据包时;
    • 在广域网上,当一个小数据包等待一个大数据包在这个连接上发送 时;
    • 广域网上的卫星链路 。

下面介绍减小串行化延迟的一些思路。

slide85
减少串行化延迟:TCP加速

延时问题可通过加速技术得以解决,其中最基本的是TCP加速。这项技术认为,延时造成的响应时间减慢多半是TCP协议等待确认的结果。有以下一些方法:

  • 拦截设备“监听” TCP ACK消息,同时管理广域网上的信息传输。这样,最终主机便认为远程端与它并排位于局域网上,从而能够以更快的速度与加速平台互动。
  • 在“闲谈式”协议(如CIFS、Microsoft Exchange MAPI等)所在的应用级别,应用加速也可以“欺骗”应用响应速度和TCP ACK。
  • Web加速,它使用嵌入在广域网加速设备中的web代理来进一步加快请求速度。Web加速尤其适用于来自支持 web 的核心应用、不断重复的序列。
slide86
减少串行化延迟:压缩技术

从狭窄的 WAN 连接中挤出带宽余量的一个方法就是采用数据压缩。在 Intranet环境中有两种基本压缩类型。

  • 基于历史的压缩:从多个数据包中找出重复的数据模式,用更短的代码代替。发送、接收端都有加密模式和密码词典,用来对数据包进行加密解密。因为历史信息随着压缩数据一起传输,发送方必须保证接收方可靠地接收到数据,因此必须在可靠的数据链路上运行。
  • 所有数据压缩包:在每个数据包中寻找重复模式,并用短代码替换。因为发送方和接收方不用保持数据间的历史,所有数据包压缩就不需要可靠的数据链路。
slide87

64 Kbps

租用线路

28.8 Kbps

POTS

28.8 Kbps

POTS

ISDN

B

64 Kbps

租用线路

64 Kbps

租用线路

ISDN

B

64 Kbps

租用线路

28.8 Kbps

POTS

ISDN

B

28.8 Kbps

POTS

增加流量

减少流量

减少串行化延迟:带宽集合

从本质上说,流量都是突发型的。浏览网页就是一种典型的突发流量行为。网络设计者的一个巨大挑战就是如何确定WAN接入带宽。如果线路带宽过大,用户就要为没有用到的带宽付费;如果带宽过窄,瓶颈效应太明显,网络性能下降。一种比较的解决方法是采用带宽集合技术。

  • 原理图示:带宽集合建立在多链路点对点(PPP,RFC1717)之上。原理见下图示。

带宽集合

slide88
PPP多链路:定义了多个传输路径的分离、重组和数据包排序的方法。其最初的设计目的是要在ISDN中开发多通道,但是同样可应用于PPP多链路连接两个系统的任何情形,包括专用线路或异步链路的组合。PPP多链路:定义了多个传输路径的分离、重组和数据包排序的方法。其最初的设计目的是要在ISDN中开发多通道,但是同样可应用于PPP多链路连接两个系统的任何情形,包括专用线路或异步链路的组合。
  • 带宽集合可视为BOD的扩展。BOD只受底层可用拨号资源的限制。初始结构可按底层串行链路资源的虚通道提供,它们可以是专线、拨号或二者的结合。这种虚拟方式可灵活地扩展或缩小,以满足不断变化的、突发型的流量需要。
slide89
减少串行化延迟:数据优先排序

网络拥塞时,优先权高的信息不能够尽快地通过WAN,是因为时间敏感信息(如终端会话)和批量通信量(如文件传输)混在一起占用一个WAN接口。解决的思路在于,首先得限制占用更多的带宽,然后指出如何有效地共享有限的带宽。

实际办法常常是,给每个进入WAN的数据包赋予一个优先权,通常对时间敏感的数据包得到较高的优先权。优先权分为紧急、高级、一般、低级四个级别。路由器首先转发紧急优先队列中的数据包,发完后再转发高级优先队列中的数据包,以次类推,直至数据包转发完毕。

网络关键信息,诸如有关拓扑结构变化的路由更新信息,自动分配到紧急优先权队列中。

slide90

10% HTTP

10% FTP

3% Telnet

协议预留

减少串行化延迟:协议预留

某些重要应用任务要求保证一定良的带宽。协议预留可让网管保证一定比例的WAN链接带宽用于这类特殊应用。

协议预留利用不同与数据优先权排序的方案,为交互式网络和面向事务处理网络应用提供高级服务。少量的连接带宽是为运行WAN连接的各个协议静态配置的。例如,网管可以为HTTP应用预留10%的带宽,即使线路上有传输更高优先级别的数据包,也必须保证这10%的带宽用于HTTP服务。如果HTTP通信下降到10%以下,未用部分就可以用于其他协议或应用程序。

slide91

25% HTTP

15% FTP

15个正在进行

的HTTP会话

对话公平

减少串行化延迟:对话公平

公平对话是对协议预留技术的增强,它保证通信带宽平等地让所有用户分享,不允许某个用户垄断WAN带宽。公平对话对网管来说是非常有力的工具,因为它要为用户团体指定平均响应时间。

如果不采用公平对话技术,来自单个用户的HTTP通信可能会控制整个HTTP预留带宽。比如(见下图),若将25%的WAN带宽预留给HTTP,而同时有15个HTTP对话,没有单个用户被允许占用超过为HTTP预留的1/15。如果对话数量改变到10个HTTP对话,这时每个用户就可以占用为HTTP预留带宽的1/10。

slide92
减少网络资源争用

网络资源争用也是低速广域网中的常见问题。不同的应用对延时和响应时间有着不同要求,而某些应用在教育环境中更受欢迎。优良的广域网加速设备可通过服务质量(QoS)技术为延迟敏感型应用和重要应用分配高于其他服务的优先级。更优秀的加速产品还能使用基于策略的多路径技术,来优化那些存在着多条路径且每条路径都有不同特征的网络。

slide93
链路层分片与交织

链路层的分片与交织,通过将大数据包分片成多个小数据包,并将这些小数据包和来自延迟敏感型应用程序的数据包交织起来,减少广域网上的穿性化延迟。广域网上大多数技术,如PPP、帧中继、ATM等都使用这种技术来优化低速线路上的延迟性能。

以PPP协议为例,它允许在一条PPP链路上进行多种网络通信,即在一条PPP链路上传输多种NCP报文 ,这种协议的优点是显而易见的,可以获得额外的吞吐量。

多链路PPP(MLP)是一种在两个端点之间通过把多个PPP连接捆绑在一起,形成一条逻辑上的或虚拟的PPP连接,来增加全部带宽的技术。可以通过把较小的、对时延敏感的PPP包与较大的PPP包(能够在不同的MP链路上传输)的分片交织起来实现QOS。

slide94
冗余广域网段
  • 多宿主Internet连接

多宿主(multi-homing)的意思是,一个服务器具有多个网络层地址,并提供多条连接。这里多宿主的概念是指为一个园区网络提供多条进入Internet 的连接。多宿主有许多类型。见下列图、表:

slide95

广域网

SP1

广域网

SP1

广域网

SP2

广域网

SP1

广域网

SP1

广域网

SP2

局域网

局域网

北京

东京

北京

东京

企业

企业

类型A

类型B

类型C

类型D

  • 对于类型C、D,可以提高网络性能可以实现本地用户通过本地的因特网连接访问因特网。
  • 应该注意的是,园区网采用了多宿主连接后,可能成为其它网络之间互连的过境网络。如果园区路由器通告了这些路由,就存在这样的风险。为了避免于此,园区路由器要么仅通告它们自己的路由,要么不运行路由选择协议,而仅依靠缺省的和静态选择路由。
  • 提高网络的冗余度以增加可靠性,会导致不复杂性的增长,实际上反而降低了可用性。
slide96
优化网络服务器

一般的企业管理信息系统大都使用B/S(如SAP)和C/S(J2EE和.NET)构架。无论何种构架,一台高档的服务器是不可少的。现代的技术如J2EE等虽然稳定可靠,但服务器的负载是早期的数倍,尤其是Web服务器。通过使用双或四处理器,SCSI接口的硬盘,RAID阵列或者增大内存,都能够大大提高Web服务器的性能。同时,为Web服务器配置一块千兆、万爪以太网卡也是很好的方法。

Linux在服务方面的特性较好一些,用户不妨考虑Linux平台。如果公司的规模非常大,那么使用IBM、HP等名牌服务器和完整解决方案远胜于一台你认为很好的普通服务器。

slide97
使用组播技术优化带宽

网络上如果有许多高带宽、多用户、多媒体的应用,如象远程教学,视频会议和协同计算,没有足够的带宽是不行的。对于一些许多单播点到点或广播数据流,我们可以选用ITEF制定的IP组播寻址技术,避免这种带宽开销。有些广播程序或多个点到点单播应用,可以使用IP组播技术,只有单个数据流被发送到需要接收数据流的设备,这就减少了带宽的压力,优化了带宽的使用。

IP 组播是指在IP 网络中将数据包以尽力传送best-effort 的形式发送到网络中的某个确定节点子集,这个子集称为组播组(multicast group)。IP 组播的基本思想是源主机只发送一份数据,这份数据中的目的地址为组播组地址。组播组中的所有接收者都可接收到同样的数据拷贝,并且只有组播组内的主机目标主机可以接收该数据。

slide98
IP组播编址

IANA (Internet Assigned Numbers Authority,因特网地址授权委员会)把D类地址空间分配给IP组播,范围从224.0.0.0到239.255.255.255,IP组播地址的二进制值前四位均为1110,网络设备可以通过此特征标识D类地址。   从224.0.0.0至224.0.0.255被IANA保留为网络协议使用。例如:244.0.0.1 全主机组,244.0.0.2 全多播路由器组,244.0.0.3 全DVMRP路由器组,244.0.0.5 全OSPF路由器组。在这一范围的多播包不会被转发出本地网络,也不会考虑多播包的TTL值。  地址从239.0.0.0至239.255.255.255作为管理范围地址,保留为私有内部域使用。  以太网和FDDI的MAC地址01:00:5E:00:00:00到01:00:5E:7F:FF:FF用于将三层IP组播地址映射为二层地址,方法是将IP组播地址中的低23位放入IEEE MAC地址的低23位。IP组播地址有28位地址空间,但只有23位被映射到IEEE MAC地址,这样会有32个IP组播地址映射到同一MAC地址上。

slide99
这样,D类地址的高9位不使用,,MAC地址的高25位固定为01:00:5E。见下图示: 这样,D类地址的高9位不使用,,MAC地址的高25位固定为01:00:5E。见下图示:
slide100
IGMP

IGMP:Internet Group Management Protocol, 即Internet 组管理协议,它运行于主机和与主机直接相连的组播路由器之间,是IP主机用来报告组播组成员身份的协议。通过IGMP协议,一方面让主机通知本地路由器希望加入并接收某个特定组播组的信息;另一方面,让路由器周期性地查询局域网内某个已知组的成员是否处于活动状态。IGMP 信息封装在 IP 报文中,其 IP 的协议号为 2。

当主机要加入一个组播组时,主机就发送一个IGMP的report来加入一个组播组,而要保持组播组就需要路由器定期(每隔60s)来发送一个查询,如果还有主机在组中,主机就会对查询作出一个应答,路由器就会保持组数据的传输,但如果组中已经有一个成员做出了应答,那么其他成员就会通过一个抑止技术,来抑止自己的应答,相当于只有一个主机做出了应答。

在IGMPv1中,当一个主机要离开一个组时,它是不会通知路由器的,路由器通过3次查询都没有应答来知道该主机已经来开组了,就不在传输该组的数据,这样一来,路由器知道主机离开组播组就存在延时。在IGMPv2中,当主机要离开时就会发送一个消息通知路由器,路由马上就会发送一个查询看还有没有其他的成员如果没有了就马上停止该组数据的传输。

slide101
组播树

组播分布树有四种基本类型:泛洪法、有源树、有核树和Steiner树。

  • 洪泛法(Flooding):这是最简单的向前传送组播路由算法,并不构造所谓的分布树。当组播路由器收到发往某个组播地址的数据包后,首先判断是否是首次收到该数据包,如果是首次收到,那么将其转发到所有接口上,以确保其最终能到达所有接收者;如果不是首次收到,则抛弃该数据包。

洪泛法不适用于Internet,因为它不考虑链路状态,并产生大量的拷贝数据包。此外,对于高速网络而言,“首次收到”列表将会很长,占用相当大的内存;尽管它能保证不对相同的数据包进行二次转发,但不能保证对相同数据包只接收一次。

  • 有源树:也称为基于信源的树或最短路径树(Shortest Path Tree:SPT),它是以组播源为根构造的从根到所有接收者路径都最短的分布树。由于不同组播源发出的数据包被分散到各自分离的组播树上,因此采用SPT有利于网络中数据流量的均衡。同时,因为从组播源到每个接收者的路径最短,所以端到端(end-to-end)的时延性能较好,有利于流量大、时延性能要求较高的实时媒体应用。缺点是:当数据流量不大时,构造SPT的开销相对较大。
slide102
共享树:也称RP树,是指为每个组播组选定一个共用根(汇合点RP或核心),以RP为根建立的组播树。同一组播组的组播源将所要组播的数据单播到RP,再由RP向其它成员转发。目前,最具代表性的两种共享树是Steiner树和有核树(CBT)。共享树:也称RP树,是指为每个组播组选定一个共用根(汇合点RP或核心),以RP为根建立的组播树。同一组播组的组播源将所要组播的数据单播到RP,再由RP向其它成员转发。目前,最具代表性的两种共享树是Steiner树和有核树(CBT)。
    • Steiner树:是总代价最小的分布树,它使连接特定图(graph)中的特定组成员所需的链路数最少。若考虑资源总量被大量的组使用的情况,那么使用资源较少最终就会减少产生拥塞的风险。Steiner树相当不稳定,树的形状随组中成员关系的改变而改变,且对大型网络缺少通用的解决方案。Steiner树只是一种理论模型,而非实用工具。目前,出现了许多Steiner树的次优启发式生成算法。
    • 有核树:是由根到所有组成员的最短路径合并而成的树。

共享树在路由器所需存储的状态信息的数量和路由树的总代价两个方面具有较好的性能。当组的规模较大,而每个成员的数据发送率较低时,使用共享树比较适合。但当通信量大时,使用共享树将导致流量集中及根(RP)附近的瓶颈。

slide103
组播的转发

单播只关心下一跳在那里,而组播只关心数据从那里来的,所以router用RPF(Reverse Path Forward)对数据进行检查看是否进行转发,如果router的接收数据端口是数据源到该端口的最短路径,则转发该数据,如果不是则丢掉。

slide104
提高广域网互联的服务质量

随着Internet的发展,企业信息化的高潮正在蓬勃开展。电子商务成为企业取得进一步发展的关键。把企业内部的信息系统和外界广域网连接起来,需要有可靠的质量保证,特别是多媒体信息的交互,对质量的要求更高了。在许多情况下,仅仅增加带宽并不能解决上述问题,以让企业承受不起高昂的广域网租用费。因此,提高广域网的服务质量(QoS),是每个企业亟待解决的问题。

对于广域网接入,提高QoS的关键就是带宽管理。

slide105
管理带宽

保证关键应用的信息流,如电子交易、音频和视频会议等,占有充足的带宽,使得这些关键应用不受到任何阻碍;而其他非实时和非关键应用的信息流,如电子邮件和文件传输等,在关键应用的信息流量较大时,则分配较低的带宽。

但是,在一般情况下,广域网本身是不具备这种功能的。目前,企业主要通过Internet和外界互联,而Internet是IP网络,它不具备区分对实时性要求极高的信息流和可以容忍一定延时或丢包的信息流的能力。通过QoS则可以解决这些问题。QoS并没有创造带宽,但是它可以管理带宽,使其得到更加有效的利用,并满足关键应用的需求。通过执行各种QoS协议就可以实现这一目标。

slide106
QoS协议

主要的QoS协议有以下四种。

  • 资源保留协议(ReSerVation Protocol,RSVP) RSVP是一个经常发信息的协议,它提供对资源保留的设置和控制,以便实现集成服务。对于运行在系统主机上的应用和网络的关键设备路由器和交换机来说,RSVP是最为复杂的QoS技术。它和“尽量努力”IP协议有很大不同,RSVP向QoS应用和用户提供了很高的服务保障、资源划分和详细的反馈。
  • 服务区分协议(Differentiated Services,DiffServ) 它对各种不同的应用提供了服务分类方法。和早期802.1p协议的标记与服务类别的机制不同,DiffServ不是简单地做优先级的标记,而是根据比较复杂的策略或规则来决定如何传送数据包。通过DiffServ协议,使得QoS的实现更加灵活,更具备可伸缩性。再结合使用DiffServ和RSVP协议,可以在保证关键服务的条件下更加有效地利用带宽。
slide107
主要的QoS协议(续)
  • 多协议标记交换协议(Multi-Protocol Label Switching,MPLS) MPLS和DiffServ在某些方面比较类似,也是在网络的入口为信息流做标记。但是,DiffServ是在路由器里面做优先级标记,而MPLS的主要目的是确定下一个目标路由器。MPLS是独立于任何协议的,即多协议的,所以可以用于任何网络。一般网络管理人员在运用MPLS协议时,需要采取策略管理的方式,确定在哪里使用标记,以及如何分发标记。
  • 子网带宽管理协议(Subnet Bandwidth Management,SBM) IEEE的802.1p、802.1Q和802.1D等标准定义了以太网交换机如何对信息帧进行分类,以便满足关键信息的实时性需求。SBM是IETF根据上述标准制定的协议,实现高层QoS和第2层交换的映射,它负责网络节点和交换机之间的通信和协调。
ipv6 qos
IPv6下的QoS体系

IPv6协议在基本和扩展报头中包含了少量与特定于QoS的服务元素,可以按不同方式使用并可综合应用。IPv6基本报头中与QoS直接有关的服务元素包括流和相应的流标签。

  • Traffic Class (流类,1字节):代替了IPv4中的Type of Service字段,有助于处理实时数据以及任何需要特别处理的数据。发送节点和转发路由器可以使用该字段来识别和分辨IPv6数据包的类别和优先级。
  • Flow Label(流标签,20位):用于区分需要相同处理的数据包,以此来促进实时性流量的处理。发送主机能够用一组选项标记数据包的顺序。路由器跟踪数据流并更有效地处理属于相同数据流的数据包,因为他们无须重新处理每个数据包的报关。数据流由流标签和源节点的地址惟一标识。
ipv6 icmp
IPv6的ICMP机制

IP的重新设计为解决QoS以及其他一些新增功能等问题提供了契机,在IPv6中,不同的服务类别同样可以由不同的多播组实现,比如,可以定义同一音频流量的四种不同类别,每种都按不同品质进行编码(如5.5KHz、11KHz、22KHz和44KHz)。在这种范例下,甚至无须显式地表示优先级,因为它是和各多播组(必须通过由路由器和终端系统执行的不同的队列和处理来操作)隐式绑定的。 现有的IPv6 ICMP多播回放控制消息机制可被用来塑造发送方和中间路由器的流量特点(比如由发送方生成最高品质;由于多播成员顺流,所以哪条链路要传送这个多播组;如何进入/离开一个多播组等等)。不利的方面是,发送者将不得不多次提供基本相同的数据(但品质不同),接收方需要知道预订哪个组,以便匹配特定的传输和终端系统功能。 路由器则可以在拥塞的情况下,按第四、第三、第二和第一的顺序进行丢包处理。音频品质可能不同,但音频数据包只会在所有数据包都被丢弃的情况下才完全丢失。基于分类/优先级的QoS的副作用是,额外增加了发送者的负担(例如IP报头管理和分级编码),并且接收方得到的服务质量也不同。