implementaci n de ipv6 en un proveedor de internet el caso de anteldata n.
Download
Skip this Video
Loading SlideShow in 5 Seconds..
Implementación de IPv6 en un Proveedor de Internet El caso de Anteldata PowerPoint Presentation
Download Presentation
Implementación de IPv6 en un Proveedor de Internet El caso de Anteldata

Loading in 2 Seconds...

play fullscreen
1 / 25

Implementación de IPv6 en un Proveedor de Internet El caso de Anteldata - PowerPoint PPT Presentation


  • 119 Views
  • Uploaded on

Implementación de IPv6 en un Proveedor de Internet El caso de Anteldata. LACNIC - IPv6 Tour Montevideo, Uruguay 31 de Agosto de 2005. Leonardo Vidal Álvaro Sánchez Carlos Marcelo Martínez. Agenda. Introducción – El backbone actual IPv4 IPv6 en el backbone de Anteldata

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

PowerPoint Slideshow about 'Implementación de IPv6 en un Proveedor de Internet El caso de Anteldata' - bond


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript
implementaci n de ipv6 en un proveedor de internet el caso de anteldata

Implementación de IPv6 en un Proveedor de InternetEl caso de Anteldata

LACNIC - IPv6 Tour

Montevideo, Uruguay

31 de Agosto de 2005

Leonardo Vidal

Álvaro Sánchez

Carlos Marcelo Martínez

agenda
Agenda
  • Introducción – El backbone actual IPv4
  • IPv6 en el backbone de Anteldata
  • Implementación de la propuesta
  • Conclusiones

Implementación de IPv6 en un Proveedor de Internet

agenda1
Agenda
  • Introducción – El backbone actual IPv4
  • IPv6 en el backbone de Anteldata
  • Implementación de la propuesta
  • Conclusiones

Implementación de IPv6 en un Proveedor de Internet

backbone actual anteldata ipv4
Backbone Actual Anteldata (IPv4)

Implementación de IPv6 en un Proveedor de Internet

backbone actual anteldata ipv41
Backbone Actual Anteldata (IPv4)
  • Diseño clásico en capas o anillos colapsados sobre infraestructura de switching Ethernet
    • Estabilidad de la red
      • Múltiples puntos de sumarización de rutas
      • Múltiples puntos de control de tráfico
    • Flexibilidad en el despliegue de servicios
  • División geográfica y funcional
    • Backbone
    • Core y Distribución Centro
    • Core y Distribución Aguada
    • Core y Distribución Unión

Implementación de IPv6 en un Proveedor de Internet

backbone actual anteldata ipv42
Backbone Actual Anteldata (IPv4)
  • Infraestructura
    • Routers Cisco, plataformas 7200 VXR y 7500 RSP8
    • Switches Catalyst 6500
  • Tráfico

Implementación de IPv6 en un Proveedor de Internet

agenda2
Agenda
  • Introducción – El backbone actual IPv4
  • IPv6 en el backbone de Anteldata
  • Implementación de la propuesta
  • Conclusiones

Implementación de IPv6 en un Proveedor de Internet

ipv6 en el backbone de anteldata
IPv6 en el backbone de Anteldata
  • Objetivos
    • Implementación en un subconjunto de la red
    • Reproducir los roles presentes en la red IPv4
    • Habilitación de DNS y enlaces con otros sistemas autónomos (nuestros carriers y la RAU)
  • Restricciones
    • Plazos
    • Recursos
      • Horas-hombre
      • Disponibilidad de equipos
      • Obtención de imágenes de IOS

Implementación de IPv6 en un Proveedor de Internet

ipv6 en el backbone de anteldata1
IPv6 en el backbone de Anteldata

Implementación de IPv6 en un Proveedor de Internet

ipv6 en el backbone de anteldata2
IPv6 en el backbone de Anteldata

Implementación de IPv6 en un Proveedor de Internet

agenda3
Agenda
  • Introducción – El backbone actual IPv4
  • IPv6 en el backbone de Anteldata
  • Implementaciónde la propuesta
  • Conclusiones

Implementación de IPv6 en un Proveedor de Internet

implementaci n de la propuesta
Implementación de la propuesta
  • Tareas realizadas
    • Diseño de la red piloto
    • Solicitud de direcciones IPv6 a LACNIC
    • Instalación de equipos
    • Migración de sistemas operativos
    • Establecimiento de enlaces con RAU y Carriers
    • Instalación y configuración de DNS

Implementación de IPv6 en un Proveedor de Internet

implementaci n de la propuesta1
Implementación de la propuesta
  • Tareas Realizadas (2)
    • Definición de un plan de numeración IPv6
    • Configuración de básica de los equipos
    • Configuración del enrutamiento
      • Rutas estáticas + RIP como IGP
      • BGP4 con otros AS
    • Testing
      • Conectividad y Enrutamiento
      • Otras funcionalidades
        • DHCP, ping, traceroute

Implementación de IPv6 en un Proveedor de Internet

implementaci n de la propuesta2
Implementación de la propuesta
  • Interfaces nativas
    • Pasos de configuración idénticos a la configuración tradicional

!

interface ATM2/0.5 multipoint

description - SECIU - PRUEBA - TOUR IPv6

bandwidth 4096

no ip mroute-cache

map-group ipv6-seciu

atm pvc 32 0 32 aal5snap 13142 2190 1

ipv6 address 2001:1328::4A/126

ipv6 enable

Implementación de IPv6 en un Proveedor de Internet

implementaci n de la propuesta3
Implementación de la propuesta
  • Interfaces túnel
    • Tampoco hay grandes diferencias!

!

interface Tunnel14

description Tunel con MCI - IPV6 Tour – Ago 2005

no ip address

load-interval 30

ipv6 address 2001:408:3FFE::6/126

tunnel source Loopback1

tunnel destination 137.39.24.1

!

Implementación de IPv6 en un Proveedor de Internet

implementaci n de la propuesta4
Implementación de la propuesta
  • Rutas Estáticas y RIP
    • Las estáticas como siempre...
    • RIP

ipv6 route 2001:1328:12::/48 Null0

ipv6 route 2001:13C0::/32 Null0

ipv6 route ::/0 Tunnel13

ipv6 router rip 100

ipv6 router rip 100

redistribute static

!

interface FastEthernet1/0

description BACKBONE - swcoreagu1 4/27

ipv6 address 2001:13C0::1/38

ipv6 enable

ipv6 rip 100 enable

Implementación de IPv6 en un Proveedor de Internet

implementaci n de la propuesta5
Implementación de la propuesta
  • BGP4
    • Intercambio de prefijos con otros sistemas autónomos

ipv6-borde#sh ip bgp summary

BGP router identifier 200.40.0.60, local AS number 6057

BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

2001:408:3FFE::5

4 284 29 78 0 0 0 00:19:51 (NoNeg)

2001:1328::49 4 1797 40943 21698 0 0 0 1d00h (NoNeg)

3FFE:2900:1002:13::1

4 6175 34379 17234 0 0 0 1w4d (NoNeg)

Implementación de IPv6 en un Proveedor de Internet

implementaci n de la propuesta6
Implementación de la propuesta
  • Resolución de Nombres
    • Se instalaron dos servidores DNS, primario y secundario
      • Ambos atienden tanto en v4 como en v6

~>dig ns antelv6.net.uy

;; QUESTION SECTION:

;antelv6.net.uy. IN NS

;; ANSWER SECTION:

antelv6.net.uy. 83775 IN NS ns2.antelv6.net.uy.

antelv6.net.uy. 83775 IN NS ns1.antelv6.net.uy.

;; ADDITIONAL SECTION:

ns1.antelv6.net.uy. 83775 IN A 200.2.42.45

ns1.antelv6.net.uy. 170175 IN AAAA 2001:13c0:800::c828:1ef5

Implementación de IPv6 en un Proveedor de Internet

implementaci n de la propuesta7
Implementación de la propuesta
  • Peerings con otros sistemas autónomos
    • Red Académica Uruguaya
      • Enlace ATM IPv6 nativo
    • Sprint
      • Túnel GRE con un terminador en Dallas, USA
    • MCI
      • Túnel GRE igualmente, habilitación en curso

Implementación de IPv6 en un Proveedor de Internet

implementaci n de la propuesta8
Implementación de la propuesta
  • Y finalmente...

dns4# traceroute www.sixxs.net

traceroute to noc.sixxs.net (2001:838:1:1:210:dcff:fe20:7c7c), 30 hops max, 60 byte packets

1 ipv6-cen-3640-serv.antelv6.net.uy (2001:13c0:800::1) 1.350 ms 1.449 ms

2 icorecen1-dist.antelv6.net.uy (2001:13c0:1000::1) 0.894 ms 0.965 ms

3 ipv6-borde-backb.antelv6.net.uy (2001:13c0::1) 1.374 ms 1.100 ms 1.617 ms

4 sl-bb1v6-fw-t-13.sprintv6.net (3ffe:2900:1002:13::1) 178.399 ms 177.293 ms

5 sl-bb1v6-rly-t-1005.sprintv6.net (2001:440:1239:1010::1) 210.683 ms

6 3ffe:2900:b:e::2 433.536 ms 428.926 ms 424.028 ms

7 2001:240:bb62:8000::4001 428.786 ms 431.123 ms 436.658 ms

8 2001:240:bb20:f002::4004 445.117 ms 456.476 ms 465.716 ms

9 ge-1-0-0.nyc10.ip6.tiscali.net (2001:504:1::a500:3257:1) 469.841 ms

10 so-1-1-3.nyc33.ip6.tiscali.net (2001:668:0:2::330) 439.897 ms 465.755 ms 11 so-4-0-0.lon12.ip6.tiscali.net (2001:668:0:2::1e0) 448.197 ms 571.863 ms 12 pos-7-1-1.ams11.ip6.tiscali.net (2001:668:0:2::30) 454.246 ms 442.896 ms

..............

Implementación de IPv6 en un Proveedor de Internet

agenda4
Agenda
  • Introducción – El backbone actual IPv4
  • IPv6 en el backbone de Anteldata
  • Implementación de la propuesta
  • Conclusiones

Implementación de IPv6 en un Proveedor de Internet

conclusiones
Conclusiones
  • Implementaciones de IPv6 en el software de los routers bastante maduras
    • Problemas relativamente menores.
  • Se cuenta con buenos interlocutores!
    • Se tuvo muy buena respuesta de los carriers a la hora de solicitar el servicio.
    • También en los proveedores de equipamiento

Implementación de IPv6 en un Proveedor de Internet

conclusiones1
Conclusiones
  • Curva de aprendizaje
    • Mecanismos de configuración similares a lo acostumbrado
  • Interoperabilidad y transición
    • Los mecanismos están y funcionan
      • Túneles
      • Funcionamiento en dual-stack

Implementación de IPv6 en un Proveedor de Internet

conclusiones2
Conclusiones
  • Presencia de Antel y de Uruguay en la incipiente Internet IPv6

Implementación de IPv6 en un Proveedor de Internet

muchas gracias por su atenci n
MUCHAS GRACIAS POR SU ATENCIÓN

Implementación de IPv6 en un Proveedor de Internet