programowanie w j zyku logo komeniusz l.
Download
Skip this Video
Loading SlideShow in 5 Seconds..
Programowanie w języku LOGO KOMENIUSZ PowerPoint Presentation
Download Presentation
Programowanie w języku LOGO KOMENIUSZ

Loading in 2 Seconds...

play fullscreen
1 / 39

Programowanie w języku LOGO KOMENIUSZ - PowerPoint PPT Presentation


  • 1101 Views
  • Uploaded on

Programowanie w języku LOGO KOMENIUSZ. TEMAT: GRAFICZNE PROCEDURY PIERWOTNE. Język LOGO KOMENIUSZ tworzą procedury i funkcje pierwotne. Są to słowa, które system LOGO KOMENIUSZ rozumie i wie, jak wykonać. OKNO LOGO KOMENIUSZA. Tutaj wykonywane są polecenia. Tutaj wpisujemy polecenia.

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

PowerPoint Slideshow about 'Programowanie w języku LOGO KOMENIUSZ' - yelena


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript
temat graficzne procedury pierwotne

TEMAT:GRAFICZNE PROCEDURY PIERWOTNE

Język LOGO KOMENIUSZ tworzą procedury i funkcje pierwotne. Są to słowa, które system LOGO KOMENIUSZ rozumie i wie, jak wykonać.

slide3

OKNOLOGO KOMENIUSZA

Tutaj wykonywane są polecenia

Tutaj wpisujemy polecenia

slide4

Tutaj znajdują się przykładowe programiki napisane przy pomocy języka LOGO. Sprawdź ich działanie.

zadanie1
Zadanie1

Narysuj prostokąt, kwadrat, trójkąt. PRZYKŁAD:

zadanie2
Zadanie2

Narysuj prostokąt, kwadrat, trójkąt. Każda z figur ma mieć obwódkę innego koloru i inny kolor wypełnienia. PRZYKŁAD:

zadanie3
Zadanie3

Narysuj prostokąt, kwadrat, trójkąt. Każda z figur ma być wypełniona innym wzorem malowania. PRZYKŁAD:

zadanie4

Zadanie4

Narysuj domek w trybie bezpośrednim. Użyj różnych kolorów i wypełnień.

temat procedury wt rne

TEMAT:PROCEDURY WTÓRNE

Polecenia możemy wydawać w trybie bezpośrednim lub poprzez redagowanie procedur wtórnych.

Procedurą wtórną nazywamy procedurę złożoną z procedur pierwotnych.

slide13

Budowa procedury wtórnej w języku LOGO KOMENIUSZ:

oto nazwa_procedury DEKLARACJA PROCEDURY

........ {instrukcja do wykonania}

........ {instrukcja do wykonania} TREŚĆ PROCEDURY

........ {instrukcja do wykonania}

już ZAKOŃCZENIE PROCEDURY

W treści procedur można umieszczać komentarze. Umieszcza się je w nawiasach { }. Są one pomijane przez komputer.

Wywołanie procedury wtórnej następuje poprzez napisanie jej nazwy.

slide14

PRZYKŁAD:

oto trójkąt

np 60 pw 120 np 60 pw 120 np 60 pw 120

już

PRZYKŁAD:

oto kwadrat

np 60 pw 90 np 60 pw 90 np 60 pw 90 np 60 pw 90

już

zadanie115

Zadanie1

Napisz procedury wtórne rysujące prostokąt, kwadrat i trójkąt. Wywołaj je.

slide16

Spis wszystkich procedur wtórnych które definiujemy znajduje się tutaj.

Kliknięcie na ten przycisk powoduje wyświetlenie okna z procedurami.

Aby poprawić procedurę wtórną należy kliknąć jej nazwę i przycisnąć przycisk F11

slide17

Gdy tworzymy procedury wtórne wygodnie jest stworzyć przyciski je wywołujące. Służy do tego narzędzie

Kliknięcie na to narzędzie powoduje wyświetlenie listy z przyciskami tworzonymi przez użytkownika.

Aby stworzyć przycisk klikamy prawym przyciskiem myszy na wolny przycisk. Następnie nadajemy mu nazwę i podajemy polecenie wywołujące narysowanie żądanego obiektu.

zadanie218
Zadanie2

Napisz procedury wtórne rysujące różnokolorowe figury. Stwórz przyciski wywołujące ich narysowanie. Ponadto stwórz przycisk czyszczący ekran.

Pamiętaj, że z nazwy przycisku powinniśmy się domyślać co zostanie narysowane.

zadanie319
Zadanie3

Napisz procedury wtórne rysujące elementy widoczku: domek, drzewko, płotek, …

(Użyj różnych kolorów i wypełnień.)

Stwórz przyciski wywołujące narysowanie poszczególnych elementów.

Tworząc procedury zwróć uwagę na to, aby każdy element był rysowany w innym miejscu ekranu.

temat realizacja p tli iteracja

TEMAT: REALIZACJA PĘTLI - ITERACJA

Wielokrotne powtórzenie wykonania listy procedur ujętych w nawiasy:

POWTÓRZ ile [ lista procedur]

slide21

PRZYKŁADY:

oto trójkąt

powtórz 3 [ np 60 pw 120 ]

już

oto sześciokąt

powtórz 6 [ np 50 pw 60 ]

już

oto kwadrat

powtórz 4 [ np 50 pw 90 ]

już

oto koło

powtórz 360 [ np 1 pw 1 ]

już

slide22

WNIOSEK:

Aby narysować n- wielokąt stosujemy procedurę:

powtórz n [ np a pw 360 / n ]

zadanie123
Zadanie1
  • Zdefiniuj procedurę rysującą:
  • koło pokolorowane na czerwono (czerwień ma numer 4)
  • kwadrat pokolorowany na zielono (zieleń ma numer 2)
  • kwadrat pokratkowany na czarno (wzór kratki odpowiada numerowi 2 lub 3)
  • trójkąt pokolorowany na niebiesko (niebieski ma numer 1)
  • trójkąt pokratkowany na czerwono
  • sześciokąt pokolorowany na żółto (żółty ma numer 14)
  • sześciokąt pokratkowany na zielono
  • prostokąt pokolorowany na szaro. (szary ma numer 7)
  • Zdefiniuj przyciski wywołujące te procedury.
zadanie 2
Zadanie 2

Napisz procedurę rysującą pawie oko.

Pokoloruj kilka „oczek”

temat procedury wt rne wzajemnie zale ne
TEMAT:PROCEDURY WTÓRNE WZAJEMNIE ZALEŻNE.

Jeżeli jedna procedura wtórna stanowi część treści innej procedury wtórnej, to mamy do czynienia z procedurami wtórnymi wzajemnie zależnymi.

slide26

Przykład 1.

oto kwadrat

powtórz 4 [ np 40 pw 90]

już

oto serweta

powtórz 36 [kwadrat pw 10]

już

slide27

Przykład 3.

oto okrąg

powtórz 180 [ np 2 pw 2 ]

już

oto motyw

powtórz 36 [okrąg pw 10]

już

slide28

Przykład 2.

oto sześć

powtórz 6 [ np 30 lw 60]

już

oto coś

powtórz 6 [sześć lw 60]

już

Sprawdź co zostanie narysowane.

slide29

Przykład 4.

oto gwiazda

powtórz 9 [ np 50 pw 160 ]

już

oto gwiazdki

powtórz 4 [gwiazda pw 90]

już

Sprawdź co zostanie narysowane.

slide34

Zadanie

Napisz procedurę wtórną wzajemnie zależną według własnego pomysłu.

slide35

Zadanie:

Wykonaj procedurę wtórną wzajemnie zależną:

slide36

Kolejne etapy pracy:

1) Napisz procedurę o nazwie igły

2) Napisz procedurę o nazwie gałązka1

slide37

3) Napisz procedurę o nazwie gwiazda1

4) Napisz procedurę o nazwie gałązka2

slide38

5) Napisz procedurę o nazwie gwiazda2

6) Napisz procedurę o nazwie gwiazda, która będzie składała się z procedur gwiazda1 i gwiazda2