imagine n.
Download
Skip this Video
Loading SlideShow in 5 Seconds..
IMAGINE PowerPoint Presentation
Download Presentation
IMAGINE

Loading in 2 Seconds...

play fullscreen
1 / 27

IMAGINE - PowerPoint PPT Presentation


  • 200 Views
  • Uploaded on

IMAGINE. Mgr. Miloš Jurč ZŠ s MŠ C II 87 Dubnica nad Váhom. Korytnačka. Kreslenie Programovanie v detskom programovacom jazyku. Program. Koniec práce. Ponuka príkazov a nástroje. Stránka pre pohyb korytnačky. Korytnačka. Záznam predchádzajúcich príkazov.

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

IMAGINE


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
    Presentation Transcript
    1. IMAGINE Mgr. Miloš Jurč ZŠ s MŠ C II 87 Dubnica nad Váhom

    2. Korytnačka • Kreslenie • Programovanie v detskom programovacom jazyku

    3. Program Koniec práce Ponuka príkazov a nástroje Stránka pre pohyb korytnačky Korytnačka Záznam predchádzajúcich príkazov Príkazový riadok

    4. Príkazový riadok Za ? napíš príkaz a potvrď Enter

    5. Nezabudni: • Korytnačka urobí iba to, čo jej prikážeš • Je dobré vedieť príkazy na ovládanie korytnačky • Za každým príkazom, číslicou či zátvorkou je medzerník • Ak dopíšeš príkaz do príkazového riadka, stlač ENTER

    6. PRÍKAZY V PROGRAME IMAGINE • Klávesnica SK/EN shift+ atl • Dopredu do • Dozadu (vzad) vz • Vpravovp • Vľavo vl • Bod bod • Pero hore (nepíše) ph • Pero dole (píše) pd • Zmena farby pera nechfp • Zmena hrúbky pera nechhp • Opakovať príkaz opakuj • Vymazanie práce znova • Ľubovoľná farba/hrúbka ? • Ohraničenie príkazu [ ]

    7. Pohyb • Korytnačka sa pohybuje v krokoch • do 100 Dopredu 100 krokov • vz 100 Vzad 100 krokov • Vytvára uhly vp vpravo vl vľavo

    8. Uhly • Vytváram uhol z 360o • 3 uholník (360:3)= 120 • 4 uholník (360:4)= 90 • 5 uholník (360:5)= 72 • 6 uholník (360:6)= 60 • 7 uholník (360:7)= 51,42 Pri ďalších viac uholníkoch analogicky vľavo vpravo

    9. Štvorec do 50 vp 90 do 50 vp 90 do 50 vp 90 do 50 vp 90

    10. Štvorec s použitím opakuj • Možný aj tento zápis: opakuj 4 [ do 50 vp 90 ]

    11. Farba pera • Príkaz: • V príkazovom riadku napíš • nechfp • F9 • Vyber farbu • Potvrď

    12. Hrúbka pera • Príkaz: • V príkazovom riadku napíš • nechhp • F9 • Vyber hrúbku pera • Potvrď

    13. Bod • Príkaz: • bod 100 • 100 je veľkosť bodu • Možem ho vytvoriť v akejkoľvek farbe a veľkosti

    14. Príkazy: do, vz, bod, vp, nechfp, F9 nechfp"azúrová bod 40 nechfp"žltá bod 20 nechfp"zelená vz 60 vp 45 do 30

    15. Nové tlačidlo • Ľavým tlačidlom myši kliknem na ikonku • Ozelenie a vytvorí sa jej tieň • Ťahaním ho presuniem na stránku • Kliknem ľavým tlačidlom tam, kde ju chcem uložiť

    16. Na uložené tlačidlo t1 kliknem pravým tlačidlom myši

    17. Kliknem na zmeň t1

    18. Popis tlačidla • Možemzadať názov tlačidla: - Znova - Štvorec - Kvet - atď Potvrdím OK

    19. Udalosti Pri zapnutí: • Napíšem príkaz - pri kliknutí na tlačidlo bude vykonaný • Potvrdím OK

    20. Zmením veľkosť tlačidla: - Šírka - Výška • Potvrdím OK

    21. Tlačidlá používam na uľahčenie práce • Využívam jedno kliknutie myšou

    22. Zábava • Použitie príkazov • Kombinácie príkazov • Vytváranie obrázkov PRAJEM PEKNÚ ZÁBAVU

    23. opakuj 10 [ phvp 90 do 5 vl 45 pdnechfp ? opakuj 360 [ do 1 vp1] ] Príkaz napíšeme do príkazového riadka za ?

    24. opakuj 10 [ phvp 90 do 5 vl 90 pdnechfp ? opakuj 360 [ do 1 vp1 ] ]

    25. Zdroje • Tvorivá dramatika

    26. Ďakujem za pozornosť