structuri de control n.
Download
Skip this Video
Loading SlideShow in 5 Seconds..
Structuri de control PowerPoint Presentation
Download Presentation
Structuri de control

Loading in 2 Seconds...

play fullscreen
1 / 27

Structuri de control - PowerPoint PPT Presentation


  • 182 Views
  • Uploaded on

Structuri de control. !. O structură înseamnă o combinaţie de operaţii utilizată în scrierea algoritmilor. Orice algoritm poate fi reprezentat ca o combinaţie a trei structuri de control: Structura liniară (secvențială); Structura alternativă (decizională); Structura repetitivă. .

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

PowerPoint Slideshow about 'Structuri de control' - india-walton


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript
structuri de control
Structuri de control

!

O structură înseamnă o combinaţie de operaţii utilizată în scrierea algoritmilor. Orice algoritm poate fi reprezentat ca o combinaţie a trei structuri de control:

  • Structura liniară (secvențială);
  • Structura alternativă (decizională);
  • Structura repetitivă.
structura secven ial
Structura secvenţială

!

Secvenţa reprezintă o succesiune de două sau mai multe operaţii care conţine o transformare de date.

exemplu
Exemplu:

citeşte x, y, z

S=x+y+z

P=x*y*z

D=x-y-z

scrie S, P, D

stop

  • Să se calculeze suma, produsul şi diferenţa a trei nume întregi x, y şi z.
structura decizional

!

Structura decizională

Decizia reprezintă alegerea unei operaţii sau a unei secvenţe de operaţii dintre două alternative posibile.

Forma generală:

dacă condiţie atunci

instrucțiune1

altfelinstrucțiune2

slide5

!

Descriere:

  • se evalueză condiţia;
  • dacă condiţia este adevărată, se execută “instrucțiune1”;
  • în caz contrar (dacă condiţia este falsă) se execută “instrucțiune2”.
exemplu1
Exemplu:

citeşte a

dacă a>b atunci

max=a

altfelmax=bscrie max

stop

  • Se dau două numere naturale a şi b. Să se determine care dintre ele are valoarea mai mare.

Rezolvare:

exemplu2
Exemplu:
  • citeşte a
  • dacă a=0atunci
  • scrie‘am citit zero’
    • stop
  • Se citeşte o valoare întreagă a. În cazul în care aceasta este nulă (egală cu 0) se va tipări mesajul “am citit zero”. Altfel, nu se va da mesaj.

Rezolvare:

exerci ii
Exerciții:
  • Să se determine dacă un număr x este pozitiv sau nu.
  • Se dau trei numere naturale a, b şi c. Să se calculeze valorile expresiilor:
      • S1=(a+b)*(a-b)
      • S2=a*b+a*c+b*c
      • P=S1*S2
slide9
Temă:
  • Se citeşte x număr natural. Să se evalueze expresia de mai jos:
structura repetitiv
Structura repetitivă

!

  • Repetiţia asigură execuţia unei secvenţe în mod repetat în funcţie de o anumită condiţie.
  • Există trei tipuri de structuri repetitive:

- structura cu test iniţial;

- structura cu test final;

- structura cu contor.

structura repetitiv cu test ini ial
Structura repetitivă cu test inițial

cât timp condiţie execută

instrucțiune;

slide12

Execuţia structurii repetitive cu test iniţial presupune parcurgerea următoarelor etape:

  • Se evaluează condiţia; dacă rezultatul este adevărat se trece la pasul 2, altfel execuţia se încheie;
  • 2. Se execută instrucțiunea, apoi se trece la pasul 1).

a

exemplu3
Exemplu:
  • Să se calculeze suma primelor n numere naturale.

Rezolvare:

a) Algoritmul: n-numărul de numere, s-suma, i – variabilă ce va reține pe rând toate numerele

1. Se dă valoare lui n;

2. Se dă lui S valoarea 0 şi lui i valoarea 1

3. Cât timp i este mai mic sau egal cu n se calculează suma după formula S=S+i

şi i ia valoarea următorului termen al sumei, după formula i=i+1

4. Se afişează valoarea sumei S.

b pseudocodul
b) Pseudocodul:

citeşte n

S=0

i=1

cât timp i<=n execută

S=S+i

i=i+1

scrie S

stop

slide15
Temă
  • Să se calculeze produsul primelor n numere naturale.

Se cer:

a) algoritmul;

b) pseudocodul;

structura repetitiv cu test final
Structura repetitivă cu test final:

Forma generală:

repetă

instrucțiune

până când condiţie

slide17

Execuţia buclei cu test final presupune parcurgerea următoarelor etape:

  • Se execută instrucțiunea
  • 2. Se evaluează condiţia; dacă rezultatul este fals, se continuă cu pasul 1), în caz contrar, se încheie execuţia buclei.

a

exemplu4
Exemplu:
  • Să se calculeze suma primelor n numere naturale.

Rezolvare:

a) Algoritmul:

1. Se dă valoare lui n;

2. Se dă lui S valoarea 0 şi lui I valoarea 1

3. Se calculează suma după formula S=S+I

şi I ia valoarea I=I+1, până când I>n.

4. Se afişează valoarea sumei.

b pseudocodul1
b) Pseudocodul:

citeşte n

S=0

I=1

repetă

S=S+I

I=I+1

până cândI>n

scrie S

stop

a

slide20
Temă:
  • Să se calculeze produsul primelor n numere naturale.

Se cer:

- algoritmul;

- pseudocodul;

slide21

Structura repetitivă cu contor:

pentrucontor=vi, vf execută

instrucțiune

slide22

Execuţia structurii repetitive cu contor presupune parcurgerea următoarelor etape:

1).Variabila de ciclare “contor” ia valoarea iniţială “vi”.

2). Dacă “contor” este mai mic sau egal cu valoarea finală “vf”, se execută instrucțiunea, se adună 1 la “contor” şi se reia cu pasul 2).. Altfel, execuţia este încheiată.

exemplu5
Exemplu:
  • Să se calculeze suma primelor n numere naturale.

Rezolvare:

a) Algoritmul:

1. Se dă valoare lui n;

2. Se dă lui S valoarea 0 şi lui I valoarea 1

3. Pentru I luând valori de la 1 până la n se calculează suma după formula S=S+I

4. Se afişează valoarea sumei.

b pseudocodul2
b) Pseudocodul:

citeşte n

S=0

petntru I=1, n execută

S=S+I

scrie S

stop

slide25
Temă:
  • Să se calculeze produsul primelor n numere naturale.

Se cer:

- algoritmul;

- pseudocodul;

slide26
Temă

1. Se citesc două valori întregi a şi b. Se cere să se tipărească media lor aritmetică.

2. Se citesc 3 numere naturale. Se cere să se tipărească primul număr, suma dintre primul şi al doilea, suma celor trei numere.

3. Se citeşte x număr natural. Să se evalueze expresia de mai jos:

slide27

4. Se citesc trei numere întregi. Să se tipărească (dacă există) numărul care este egal cu suma celorlalte două.

5. Se citeşte n (număr întreg). Se cere să se calculeze suma:

S=1+3+5+…+n.

6. Să se calculeze suma:

S=0,1+0,2+0,3+…+0,9.

7. Să se calculeze media aritmetică a primelor n numere naturale.