universidade federal do esp rito santo n.
Download
Skip this Video
Loading SlideShow in 5 Seconds..
Universidade Federal do Espírito Santo PowerPoint Presentation
Download Presentation
Universidade Federal do Espírito Santo

Loading in 2 Seconds...

play fullscreen
1 / 10

Universidade Federal do Espírito Santo - PowerPoint PPT Presentation


  • 67 Views
  • Uploaded on

Universidade Federal do Espírito Santo. Programação II Professora: Norminda Luiza. Estrutura Condicional. A estrutura condicional permite a escolha do grupo de ações e estruturas a ser executado quando determinadas condições, representadas por expressões lógicas, são ou não satisfeitas.

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

PowerPoint Slideshow about 'Universidade Federal do Espírito Santo' - eros


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript
universidade federal do esp rito santo

Universidade Federal do Espírito Santo

Programação II

Professora: Norminda Luiza

estrutura condicional
Estrutura Condicional

A estrutura condicional permite a escolha do grupo de ações e estruturas a ser executado quando determinadas condições, representadas por expressões lógicas, são ou não satisfeitas.

Esta estrutura pode se apresentar de duas formas.

Estrutura condicional simples

se condição

então sequência de comandos

fim se

Neste caso, a sequência de comandos só será executada se a condição for verdadeira.

Obs.: Ao ser mencionada “sequência de comandos” está implícito que ela contém um ou mais comandos e pode conter uma ou mais estruturas.

Exemplo:

Algoritmo

declare A, B, C real

leia (A, B)

se A+ B < C

entãoescreva (“MENSAGEM”)

fim se

fim algoritmo

estrutura condicional1
Estrutura Condicional

Estrutura condicional composta

se condição

então sequência A de comandos

senão sequência B de comandos

fim se

Neste caso, a sequência A de comandos só será executada se a condição (expressão lógica) for verdadeira e a sequência B de comandos só será executada se a condição for falsa.

Exemplo:

Algoritmo

declare A, B, X, Y real

leia (A, B)

se A = B

então X  1,5

Y  2,5

senão X  - 1,5

Y  - 2,5

fim se

escreva (X, Y)

fim algoritmo

estrutura condicional2
Estrutura Condicional

Seleção encadeada heterogênea

Quandonãoconseguimosidentificar um padrãológico de construçãoemumaestrutura de seleçãoencadeada.

Seleção Encadeada

Quando, devido à necessidade de processamento, agrupamos várias seleções, formaremos uma seleção encadeada.

se (condição 1)

entãose (condição 2)

então seq. comandos A

fimse

senãose (condição 3)

então seq. comandos B

senãose (condição 4)

entãose (condição 5)

então seq. comandos C

fim se

senão comando D

fimse

fimse

fimse

sele o encadeada heterog nea

Estrutura Condicional

se (condição 1)

entãose (condição 2)

então seq. comandos A

fimse

senãose (condição 3)

então seq. comandos B

senãose (condição 4)

entãose (condição 5)

então comando C

fim se

senão comando D

fimse

fimse

fimse

Seleção encadeada heterogênea

Tabela de decisão

estrutura condicional3

Seleção encadeada heterogênea homogênea

Chamamos de seleçãoencadeadahomogênea a construção de diversasestruturas de seleçãoencadeadasqueseguem um determinadopadrãológico.

Estrutura Condicional

Exemplo: se então se

se (condição 1)

entãose (condição 2)

então se (condição 3)

entãose (condição 4)

então comando W

fim se

fimse

fimse

fimse

Tabela de decisão

Forma equivalente porém simplificada

se ((condição 1) e (condição 2) e (condição 3) e (condição 4))

então comando W

fim se

estrutura condicional4

Não se trata de uma seleção encadeada

Estrutura Condicional

Exemplo: se senão se

se (x = v1)

então C1

fim se

se (x = v2)

então C2

fim se

se (x = v3)

então C3

fim se

se (x = v4)

então C4

fim se

Tabela de decisão

estrutura condicional5

Podemos transformar o exemplo anterior numa estrutura de seleção encadeada

Estrutura Condicional

Exemplo: se senão se

se (x = v1)

então C1

senão se (x = v2)

então C2

senão se (x = v3)

então C3

senão se (x = v4)

então C4

fimse

fim se

fim se

fim se

Estrutura de seleção encadeada homogênea

Tabela de decisão

slide9

Seleção de múltipla escolha

Quando um conjunto de valoresdiscretosprecisa ser testado e açõesdiferentessãoassociadas a essesvalores, estamosdiante de umaseleçãoencadeadahomogênea do tipo se-senão-se. Nestecasoutilizaremos a seleção de múltiplaescolha, específicaparaestescasos.

Exemplo anterior

Exemplo 2: se-senão-se

escolha x

caso v1: C1

caso v2: C2

caso v3: C3

caso v4: C4

fimescolha

se (x = v1)

então C1

senãose (x = v2)

então C2

senãose (x = v3)

então C2

senãose (x = v4)

então C3

senãose (x = v5)

então C4

senão C5

fimse

fimse

fim se

fim se

fim se

Exemplo 2: múltipla escolha

escolha x

caso v1: C1

caso v2, v3: C2

caso v4: C3

caso v5: C4

caso contrário: c5

fimescolha

sele o de m ltipla escolha

Exemplo

Construa um algoritmoque, tendocomo dados de entrada o preço de um produto e seucódigo de origem, mostre o preçojundo de suaprocedência. Caso o códigonãosejanenhum dos especificados, o produtodeve ser encaradocomoimportado. Siga a tabela de códigos a seguir:

Seleção de múltipla escolha