algoritmos n.
Download
Skip this Video
Loading SlideShow in 5 Seconds..
Algoritmos PowerPoint Presentation
Download Presentation
Algoritmos

Loading in 2 Seconds...

play fullscreen
1 / 10

Algoritmos - PowerPoint PPT Presentation


  • 111 Views
  • Uploaded on

Algoritmos. Comandos condicionais. Comandos condicionais. Problema: Se cair a bola vermelha o retângulo deve ficar deitado, mas se cair a bola amarela, ele deve ficar em pé. Alguém sabe qual vai ser a resposta que o computador vai apresentar?. Comandos condicionais. f. v. Se condição.

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

PowerPoint Slideshow about 'Algoritmos' - arvin


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript
algoritmos

Algoritmos

Comandos condicionais

comandos condicionais
Comandos condicionais

Problema: Se cair a bola vermelha o retângulo deve ficar deitado, mas se cair a bola amarela, ele deve ficar em pé.

Alguém sabe qual vai ser a resposta que o computador vai apresentar?

comandos condicionais1
Comandos condicionais

f

v

Se condição

comandos condicionais2
Comandos condicionais

algoritmo bolas

{ determina, a partir da cor da bola qual a posição do retânguilo}

declare cor: literal

posicao: inteiro

início

{ leitura da cor da bola }

leia(cor)

{ verificação }

se cor = “vermelha” então

posicao  0

senão

posicao  1

fim-se

{ saída }

desenhe_retangulo(posicao)

fim

comandos condicionais3
Comandos condicionais

Problema: O aluno vai fazer 2 provas e precisa obter média acima ou igual a 6,0 para ser aprovado.

Alguém sabe qual a mensagem que o computador vai fornecer antes do professor informar ao computador a nota do aluno?

comandos condicionais4
Comandos condicionais

algoritmo aprovação

{ determina, a partir de duas notas, a média e se

houve aprovação }

declare notaProva1, notaProva2, média: real

mensagem: literal

início

{ leitura }

leia(notaProva1, notaProva2)

{ cálculo }

média  (notaProva1 + notaProva2) / 2

{ verificação }

se média ≥ 6.0 então

mensagem  “Aprovado”

senão

mensagem  “Reprovado”

fim-se

{ saída }

escreva(média, mensagem)

fim

comandos condicionais5
Comandos condicionais

se expressão-lógica então

lista-de-comandos-se-verdadeiro

fim-se

Se a expressão-lógica resultar em verdadeiro, a lista-de-comandos-se-verdadeiro é executada; se resultar em falso, não.

Se houver a especificação do senão e a expressão-lógica resultar em falso, a lista-de-comandos-se-falso é executada.

se expressão-lógica então

lista-de-comandos-se-verdadeiro

senão

lista-de-comandos-se-falso

fim-se

comandos condicionais6
Comandos condicionais
  • Aninhamento de comandos
    • Os comandos “internos” de um comando condicional podem ser
      • Leituras
      • Escritas
      • Outros comandos condicionais
      • Ou seja, qualquer comando

se expressão-lógica-1 então

comando_1

comando_2

se expressão-lógica-2 então

comando_3

fim-se

senão

se expressão-lógica-3 então

se expressão-lógica-4 então

comando_4

fim-se

senão

comando_5

fim-se

fim-se

comandos condicionais7
Comandos condicionais

caso condição-inteira

lista-de-seleção

fim-caso

lista-de-coincidência: lista-de-comandos

lista de constantes ou intervalos

caso condição-inteira

lista-de-seleção

senão

lista-de-comandos-de-exceção

fim-caso

comandos condicionais8
Comandos condicionais

...

leia(idade)

caso idade

0: escreva(“nenê”)

1..9: escreva(“criança”)

10-13: escreva(“pré-adolecente”)

15: escreva(“debutante”)

14, 16-18: escreva(“adolecente”)

19-99: escreva(“adulto”)

senão

escreva(“idade não classificada”)

fim-caso

...