CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA - PowerPoint PPT Presentation

addison
slide1 n.
Skip this Video
Loading SlideShow in 5 Seconds..
CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA PowerPoint Presentation
Download Presentation
CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA

play fullscreen
1 / 20
Download Presentation
102 Views
Download Presentation

CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA

- - - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript

  1. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Operadores São meios pelo qual incrementamos, comparamos e avaliamos dados dentro do computador. Temos três tipos de operadores: - Operadores Aritméticos - Operadores Relacionais - Operadores Lógicos

  2. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Operadores Aritméticos São os utilizados para obter resultados numéricos.

  3. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Hierarquia das Operações Aritméticas 1º ( ) Parênteses 2º Exponenciação 3º Multiplicação, divisão (o que aparecer primeiro) 4 º Adição, subtração (o que aparecer primeiro) Exemplo TOTAL = PRECO * QUANTIDADE 1 + 7 * 2 ** 2 – 1 = 28 3 * (1-2) + 4 * 2 = 5

  4. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Operadores Relacionais São utilizados para comparar String de caracteres e números . Os valores a serem comparados podem ser caracteres ou variáveis.

  5. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Operadores Relacionais Os operadores relacionais podem aparecer misturados com os aritméticos, sendo que esse último tem prioridade de execução sobre o primeiro. Exemplo: SE R + 10 = 50 ENTÃO ... No exemplo acima, a operação R + 10 será executado em primeiro lugar e o seu resultado é que será comparado com 50.


  6. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Operadores Lógicos Servem para combinar resultados de expressões, retornando se o resultado final é verdadeiro ou falso. Os operadores lógicos são:

  7. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Operadores Lógicos E / AND - Uma expressão E é verdadeira se todas as condições forem verdadeiras. OU / OR – Um expressão OU é verdadeira se pelo menos uma condição for verdadeira. NÃO / NOT – Um expressão NÃO inverte o valor da expressão ou condição, se verdadeira inverte pela falsa e vice-versa.

  8. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Operadores Lógicos Exemplo: Suponha que temos e variáveis: A = 5, B = 8, C = 1, O resultado das expressões seriam: Expressões Resultado

  9. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Operadores Lógicos

  10. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Prioridade entre todos os operadores • A = 1 e (B + C < > 0 ou K <= 2) • não (TOTAL >= 2 e A < > B) ou TESTE

  11. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Exercícios 1) Tendo as variáveis SALARIO, IR e SALLIQ, e considerando os valores abaixo. Informe se as expressões são verdadeiras ou falsas. SALARIO IR SALLIQ EXPRESSÃO V ou F 100,00 0,00 100 (SALLIQ >= 100,00) ? 200,00 10,00 190,00 (SALLIQ < 190,00) ? 300,00 15,00 285,00 SALLIQ = SALARIO – IR ? 2) Sabendo que A=3, B=7 e C=4, informe se as expressões abaixo são verdadeiras ou falsas. a) (A+C) > B ( ) b) B >= (A + 2) ( ) c) C = (B –A) ( ) d) (B + A) <= C ( ) e) (C+A) > B ( )

  12. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Exercícios 3) Sabendo que A=5, B=4 e C=3 e D=6, informe se as expressões abaixo são verdadeiras ou falsas. a) (A > C) E (C <= D) ( ) b) (A+B) > 10 OU (A+B) = (C+D) ( ) c) (A>=C) E (D >= C) ( )

  13. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Estrutura condicional Permite a escolha do grupo de ações e estruturas a ser executado quando determinadas condições, representadas por expressões lógicas, são ou não satisfeitas.

  14. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Estrutura condicional SIMPLES Neste caso, a seqüência de comandos só será executada se a condição for verdadeira. Caso seja falsa não entra no bloco, vamos direto para a linha abaixo do fim se. se condição então comando 1 comando 2 . . . fim se

  15. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL Programa exemplo Var a,b,c: real Início a <- 0 b <- 0 c <- 0 mostre (“Leia o um numero para a:”) leia (a) mostre (“Leia o um numero para b:”) leia (b) mostre (“Leia o um numero para c:”) leia (c) Se a + b < c então mostre (“A soma de a e b são menores que c”) fim se Fim

  16. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Estrutura condicional COMPOSTA Neste caso, quando a condição for verdadeira entramos na primeira parte do bloco. Caso falsa, entramos na segunda parte do bloco. se condição então comando 1 comando 2 senão comando 3 comando 4 fim se

  17. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL . . . mostre (“Leia o um numero para a:”) leia (a) mostre (“Leia o um numero para b:”) leia (b) mostre (“Leia o um numero para c:”) leia (c) se a + b >= c então mostre (“A soma de a e b e maior ou igual a c”) senão mostre (“A soma de a + b e menor que c”) fim se Fim

  18. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Exercícios • Faça um algoritmo que receba via teclado o nome, idade e telefone de uma pessoa. Caso a idade seja maior ou igual a 18 escreva a mensagem “Maior de idade” e caso a idade seja menor que 18 escreva a mensagem “Menor de idade”. • Receber 2 valores numéricos, verificar se formam os lados de um retângulo, caso verdadeiro calcular a área e mostrar no vídeo, senão, mostrar uma mensagem “Estes valores não formam os lados de um retângulo. • obs: Para formar os lados de um retângulo os lados não podem ser iguais, e cada lado tem que ser maior que 0.

  19. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • “Se” Múltiplos Sintaxe: Se condição 1 então c1 c2 senão se condição 2 então c3 c4 senão c5 c6 fim se fim se

  20. CENTRO FEDERAL DE EDUCAÇÃO TECNOLÓGICA ENGENHARIA DE AUTOMAÇÃO INDUSTRIAL • Exercício • Fazer um algoritmo que receba uma sigla de estado brasileiro, verificar se é igual “MG”, “SP”,”RJ”,”ES”. Senão de uma mensagem “Sigla informada não pertence a região sudeste”. • Receber quatro notas de um aluno (desprezar verificação caso a nota seja menor que zero e maior que 10), calcular a média, e logo a seguir verificar se a média é maior que 6,0. Caso verdadeiro mostrar “APROVADO “, senão mostrar “RECUPERAÇÃO”.