Configuring routers
Download
1 / 27

Configuring Routers - PowerPoint PPT Presentation


  • 150 Views
  • Uploaded on

Configuring Routers. I’ve got to program a router! . What do I have to do. Log on to the router. Router> Router>enable Router# Router#config t. Config t is the place to be!. Name the router!. Step One. Router(config)#hostname Lab-A. Lab-A.

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

PowerPoint Slideshow about ' Configuring Routers' - walker-ortiz


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript


Log on to the router
Log on to the router

Router>

Router>enable

Router#

Router#config t

Config t is the place to be!


Name the router
Name the router!

Step One

Router(config)#hostname Lab-A

Lab-A


Password protect the privilege mode
Password protect the Privilege Mode

Step Two

Lab-A(config)#enable secret class

Commands

Password

Results in:

enable secret 5 $1$emBK$WxqLahy7YOAf0nifub


Configure the interfaces
Configure the Interfaces

Step Three

Lab-A(config)#interface serial0

Lab-A(config-if)#

(Note prompt change)


Address the interface s0
Address the Interface(S0)

Lab-A(config-if)#ip address 201.100.11.1 255.255.255.0

Ip address

Subnet mask

S0=201.100.11.1


Clock ticks must be set between routers on the interface with the serial cable dce end
Clock ticks MUST be set between routers on the interface with the serial cable DCE end.

Serial0 is where the DCE connects in our lab.


We use serial0
We use Serial0 with the serial cable DCE end.

  • Lab-A(config-if)#clock rate 56000


Address the next interface e0
Address the next Interface (E0) with the serial cable DCE end.

Lab-A(config-if)#interface ethernet0

(This changes to program interface e0)

Lab-A(config-if)#ip address 192.5.5.1 255.255.255.0

E0=192.5.5.1

S0=201.100.11.1


Control z
Control z with the serial cable DCE end.

Lab-A#

Lab-A#show running-config



Like people routers have to talk to one another1
Like people, routers have to talk to one another! with the serial cable DCE end.

Step Four

Set up routing protocols


Routing protocols
Routing Protocols: with the serial cable DCE end.

RIP RIPv2

IGRP EIGRP

OSPF


Set up the routing protocol
Set up the routing protocol with the serial cable DCE end.

Lab-A(config)#router rip

Lab-A(config-router)# version 2

Lab-A(config-router)#network 192.5.5.0

Lab-A(config-router)#network 201.100.11.0

(Note prompt change)


Note! with the serial cable DCE end.

  • You have to configure for EACH network

  • (remember network # is the “wire” #)

  • Each network is on a separate line

  • Hit Control z to activate and return to:

  • Lab-A#


Control access
Control Access with the serial cable DCE end.

Control and secure access from:

CONSOLE

VTY (telnet)

AUX (modem)


Control access1
Control Access with the serial cable DCE end.

Step Five

Lab-A(config)#line console 0

Lab-A(config-line)#password cisco

(Note prompt change)

Lab-A(config-line)#login


Continue
Continue with the serial cable DCE end.

Lab-A(config)#line vty 0 4

Lab-A(config-line)#password cisco

Lab-A(config-line)#login


Want to save time and move fast between routers
Want to save time and move fast between routers? with the serial cable DCE end.

Step Six


Create a host file
Create a host file with the serial cable DCE end.

Lab-A(config)#ip host Lab-A 192.5.5.1 205.7.5.1 201.100.11.1

Lab-A(config)#ip host Lab-B 219.17.100.1 199.6.13.1 201.100.11.2

Lab-A(config)#ip host Lab-C 223.8.151.1 204.204.7.1 199.6.13.2

Lab-A(config)#ip host Lab-D 210.93.105.1 204.204.7.2

Lab-A(config)#control z


Turn on the interfaces
Turn on the interfaces: with the serial cable DCE end.

Step Seven

  • Lab-A(config)#interface s0

  • Lab-A(config-if)#no shutdown

  • Lab-A(config-if)#interface e0

  • Lab-A(config-if)#no shutdown


Check and save your configuration step 8
Check and save your configuration (Step 8) with the serial cable DCE end.

  • Router#show run (Check)

  • Router#copy run start (Save)


Let s review
Let’s Review: with the serial cable DCE end.

  • Step 1 – name router

  • Hostname xxxxx

  • Step 2 – set “privilege” password and encode it

  • Enable secret xxxxx

  • Step 3 – configure interfaces

  • Interface sX (or eX)


Let us review with the serial cable DCE end.

  • Step 4 – Set the routing protocols

  • Router rip

  • Step 5 – Set who and where access comes from

  • Line console (vty)

  • Step 6 – Create a host file

  • Ip host xxx.xxx.xxx yyy.yyy.yyy

  • Step 7 – Turn on interfaces

  • Router(config-if)#no shutdown


Step 8 check and save your work
Step 8:Check and Save your work! with the serial cable DCE end.

  • Check your config

  • Router#show run

  • Save your configuration from RAM to NVRAM

  • Router#copy run start


You re through
You’re Through! with the serial cable DCE end.


ad