第
This presentation is the property of its rightful owner.
Sponsored Links
1 / 28

第 7 讲 虚拟局域网( 2 ) PowerPoint PPT Presentation


  • 131 Views
  • Uploaded on
  • Presentation posted in: General

第 7 讲 虚拟局域网( 2 ). 3.3 VLAN 间的通信. 在一般的二层交换机组成的网络中, VLAN 实现了网络流量分割,不同的 VLAN 间不能通信。 要实现 VLAN 间的通信必须借助路由来实现。实现方法有: 利用路由器连接; 采用三层交换机。. 3.3.1 VLAN 间通信的方法. 1. 多交换机 VLAN 与路由器的连接. 172.10.0.0/16. 172.20.0.0/16. VLAN20. VLAN10. VLAN30. 172.30.0.0/16.

Download Presentation

第 7 讲 虚拟局域网( 2 )

An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -

Presentation Transcript


7 2

第7讲 虚拟局域网(2)


3 3 vlan

3.3 VLAN间的通信

  • 在一般的二层交换机组成的网络中,VLAN实现了网络流量分割,不同的VLAN间不能通信。

  • 要实现VLAN间的通信必须借助路由来实现。实现方法有:

    • 利用路由器连接;

    • 采用三层交换机。


3 3 1 vlan

3.3.1 VLAN间通信的方法

1. 多交换机VLAN与路由器的连接

172.10.0.0/16

172.20.0.0/16

VLAN20

VLAN10

VLAN30

172.30.0.0/16

当有多个交换机组成多个VLAN时,路由器采用多个端口连接VLAN。并且在各端口上配置静态路由实现VLAN间的通信。它与一般的子网连接相同。


7 2

3.3.1 VLAN间通信的方法

2. 单交换机VLAN的路由器连接方式1:多条链路连接多个VLAN

VLAN10

VLAN20

VLAN30

当有一个交换机组成多个VLAN时,路由器采用多个端口连接多个VLAN。右图的交换机有3个VLAN,那么交换机与路由器间就需要三个连接端口及线缆。这样在不同的线路上配置不同的子网地址及路由即可。但是需要太多的路由器接口,所以这种方法不实用。


7 2

3.3.1 VLAN间通信的方法

3. 单交换机VLAN的路由器连接方式2:一条链路连接多个VLAN

当有一个交换机组成多个VLAN时,路由器只采用一个端口连接多个VLAN。利用子接口技术(SubInterface)将所有VLAN的数据通过一个端口传输。

VLAN将交换机从逻辑上分割成了多台,因而用于VLAN间路由的路由器也必须拥有分别对应各个VLAN的虚接口(SVI)作为各个VLAN成员的网关。这样各个VLAN之间就可以利用路由器来实现数据交换。

VLAN10

VLAN20

VLAN30

Interface FA 1

Subinterface 1.1

Subinterface 1.2

Subinterface 1.3


3 3 2 vlan

3.3.2 利用路由器实现VLAN间的通信

  • 单臂路由:使用IEEE 802.1Q来启动一个路由器上的子接口成为干道模式 ,实现VLAN之间的通信

F0/0

802.1Q

Trunk

FastEthernet 0/0

FastEthernet 0/0.1

FastEthernet 0/0.3

FastEthernet 0/0.2

VLAN 10

VLAN 20

VLAN 30


3 3 2

3.3.2 单臂路由的配置

Router(config)# Interfaceinterface-id

Router(config-if)#no ip address

Router(config-if)#exit

Router(config)#interface fastethernetslot-number/interface-number.subinterface-number

Ruijie(config-subif)#encapsulation dot1QVlanID

Router(config-subif)#ip addressip-address mask


7 2

单臂路由配置举例

Router(config)#interface fastEthernet 0/0

Router(config-if)#no ip address

Router(config-if)#exit

Router(config)#interface fastEthernet 0/0.10

Router(config-subif)#encapsulation dot1Q 10

Router(config-subif)#ip address 192.168.10.1 255.255.255.0

Router(config-subif)#exit

Router(config)#interface fastEthernet 0/0.20

Router(config-subif)#encapsulation dot1Q 20

Router(config-subif)#ip address 192.168.20.1 255.255.255.0

Router(config-subif)#exit

Router(config)#interface fastEthernet 0/0.30

Router(config-subif)#encapsulation dot1Q 30

Router(config-subif)#ip address 192.168.30.1 255.255.255.0

Router(config-subif)#end


7 2

检查单臂路由的配置

Router#show ip route

Codes: C - connected, S - static, R - RIP B - BGP

O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default

Gateway of last resort is no set

C 192.168.10.0/24 is directly connected, FastEthernet 0/0.10

C 192.168.10.1/32 is local host.

C 192.168.20.0/24 is directly connected, FastEthernet 0/0.20

C 192.168.20.1/32 is local host.

C 192.168.30.0/24 is directly connected, FastEthernet 0/0.30

C 192.168.30.1/32 is local host.


3 3 3 vlan

3.3.3 利用三层交换机配置VLAN间路由

  • 单臂路由容易产生瓶颈

    • 端口带宽小

    • 转发速率低

  • 采用三层交换机实现VLAN间的路由

    • 内含交换机模块和路由器模块

    • 使用ASIC硬件处理路由,可以实现高速路由。

    • 路由与交换模块内部连接,可以确保大的带宽


3 3 4 vlan

3.3.4 使用三层交换机进行VLAN间路由

VLAN10

Network 172.16.10.3

VLAN20

Network 172.16.20.4

VLAN30

Network 172.16.30.5

  • 三层交换机在功能上实现了VLAN的划分、VLAN内部的二层交换和VLAN间路由的功能。


7 2

SVI端口

  • VLAN的虚拟接口 (Switch virtual interface ,SVI )

    • 路由端口,可设置IP地址

    • 作为VLAN内主机的网关

SVI:VLAN 10

192.168.1.1

SVI:VLAN 20

192.168.2.1

VLAN 20

IP:192.168.2.10

VLAN 10

IP:192.168.1.10


3 3 4 vlan1

3.3.4 VLAN间通信的配置方法

使用三层交换机实现VLAN间通信:

  • 第一步:分别创建每个VLAN三层虚接口SVI端口,并分别配置IP地址:

    • Switch(config)# interface vlan <vlan>

    • Switch(config-if)# ip address <address> <netmask>

    • Switch(config-if)#no shutdown

  • 第二步:将交换机间的连接端口设置为Trunk口

  • 第三步:将每个VLAN内主机的网关指定为本VLAN接口地址


3 3 4 vlan2

3.3.4 VLAN间通信的配置方法实例

【试验目的】通过三层交换机实现VLAN间的相互通信。

【试验设备】1台S2126G(SA)、1台S3550(SB)。

【试验拓扑】:见下图

VLAN20

IP: 192.168.20.10

网关:192.168.20.254

PC2

VLAN10

IP: 192.168.10.30

网关:192.168.10.254

SA

SB

F0/15

PC2

F0/24

VLAN10

IP: 192.168.10.20

网关:192.168.10.254

F0/5

F0/24

F0/5

PC3

PC1


3 3 4 vlan3

3.3.4 VLAN间通信的配置方法实例

  • 试验步骤:

    • 第一步:在交换机SA上创建VLAN 10,并将0/5端口划分到VLAN 10中:

    • SA(config)# vlan 10 !创建VLAN 10

    • SA(config-vlan)#name teacher !将VLAN 10命名为teacher

    • SA(config-vlan)#exit

    • SA(config)#interface fastethernet 0/5

    • SA(config-if)#switchport access vlan 10

    • !将0/5端口划分到VLAN 10

  • 验证测试:

    • SA#show vlan id 10


3 3 4 vlan4

3.3.4 VLAN间通信的配置方法实例

  • 试验步骤(续):

    • 第二步:在交换机SA上创建VLAN 20,并将0/15端口划分到VLAN 20中:

    • SA(config)# vlan 20

    • SA(config-vlan)#name student

    • SA(config-vlan)#exit

    • SA(config)#interface fastethernet 0/15

    • SA(config-if)#switchport access vlan 20

  • 验证测试:

    • SA#show vlan id 20


3 3 4 vlan5

3.3.4 VLAN间通信的配置方法实例

  • 试验步骤(续):

    • 第三步:在交换机SA与SB的连接端口(假如为0/24端口)上创建TAG VLAN:

    • SA(config)# interface fastethernet 0/24

    • SA(config-if)#switchport mode trunk

  • 验证测试:

    • SA#show interface fastethernet 0/24 switchport


3 3 4 vlan6

3.3.4 VLAN间通信的配置方法实例

  • 试验步骤(续):

    • 第四步:在交换机SB上创建VLAN 10,并将0/5端口划分到VLAN 10中:

    • SB(config)# vlan 10

    • SB(config-vlan)#name teacher

    • SB(config-vlan)#exit

    • SB(config)#interface fastethernet 0/5

    • SB(config-if)#switchport access vlan 10

  • 验证测试:

    • SB#show vlan id 10


3 3 4 vlan7

3.3.4 VLAN间通信的配置方法实例

  • 试验步骤(续):

    • 第五步:在交换机SB与SA的连接端口(假如为0/24端口)上创建TAG VLAN:

    • SB(config)# interface fastethernet 0/24

    • SB(config-if)#switchport mode trunk

  • 验证测试:

    • SB#show interface fastethernet 0/24 switchport


3 3 4 vlan8

3.3.4 VLAN间通信的配置方法实例

  • 试验步骤(续):

    • 第六步:验证VLAN内可以通信,但VLAN间不能通信,即PC1与PC3可以通信,但PC2与PC3不能通信:

    • 在PC1的DOS模式下用ping命令验证:

    • C:\>ping 192.168.10.30 !在PC1下能够ping通PC3

    • 在PC2的DOS模式下用ping命令验证:

    • C:\>ping 192.168.10.30 !在PC2下不能ping通PC3


3 3 4 vlan9

3.3.4 VLAN间通信的配置方法实例

  • 试验步骤(续):

    • 第七步:设置三层交换机VLAN间通信。在交换机SB上创建虚接口:

    • SB(config)# int vlan 10 !创建虚拟接口vlan 10

    • SB(config-if)#ip address 192.168.10.254 255.255.255.0

    • !配置虚拟接口vlan 10的地址为192.168.10.254

    • SB(config-if)#exit

    • SB(config)# int vlan 20 !创建虚拟接口vlan 20

    • SB(config-if)#ip address 192.168.20.254 255.255.255.0

    • !配置虚拟接口vlan 10的地址为192.168.20.254


3 3 4 vlan10

3.3.4 VLAN间通信的配置方法实例

  • 试验步骤(续):

    • 第八步:验证VLAN内及VLAN间都能通信:

    • 将PC1和PC3的默认网关设置为192.168.10.254,将PC2的默认网关设置为:192.168.20.254

    • 在PC1的DOS模式下用ping命令验证:

    • C:\>ping 192.168.10.30 !在PC1下能够ping通PC3

    • 在PC2的DOS模式下用ping命令验证:

    • C:\>ping 192.168.10.30 !在PC2下能够ping通PC3

    • 【注意事项】

    • 两台交换机连接端口应为Trunk模式;

    • 验证PC的网关要设置正确。


7 2

课程议题

3.4 VLAN排错


7 2

常规局域网排错方法


7 2

常见故障举例

  • 吞吐量很低:需要检查存在错误的类型,可能是网卡的故障

  • 大量的帧RCS校验错误、长度小于64字节等:往往是端口之间双工不匹配,原因可能是设备之间的自动协商或是双方的连接错误所导致,可以下面的命令检查:

    • Switch(config-if)#duplex {auto | full | half}


7 2

常见故障举例

  • VLAN内的主机不能和其他VLAN通信 ,原因可能是:

    • 主机上错误的网关、IP地址和子网掩码设置

    • 主机所连接的端口被划分到了错误的VLAN

    • 交换机上的Trunk端口设置错误,例如缺省VLAN设置不匹配,允许的VLAN列表不正确等

    • 路由器子接口或三层交换机SVI端口的IP地址和子网掩码设置错误

    • 路由器或者三层交换机可能需要添加到达其他子网的路由


7 2

VLAN错误排查方法

  • 从低层(物理层)逐步向上排查,如端口和线缆无故障,则:

    • 检查主机的网络设置是否匹配和正确

    • 通过show vlan命令,确定VLAN内的端口划分正确

    • 通过show interface trunk命令,检查Trunk链路两端的Trunk设置是否匹配且正确

    • 通过show interface命令,确定是否设置了正确的IP地址和子网掩码

    • 通过show ip route命令,确定各个子网都能够正确出现在路由表中

    • 通过show interface subinterface命令,检查路由器的子接口是否正确封装了802.1Q,并指定到了正确的VLAN

    • 通过show interface命令,检查主机和交换机端口的速度和双工设置是否匹配


7 2

课程回顾

  • VLAN的概念

  • VLAN的用途和优点

  • VLAN的定义方法

  • 802.1Q

  • 配置VLAN和Trunk

  • 利用路由器实现VLAN间的通信

  • 利用三层交换机实现VLAN间的通信


  • Login