第
This presentation is the property of its rightful owner.
Sponsored Links
1 / 41

第 9 章 交换机配置 PowerPoint PPT Presentation


  • 122 Views
  • Uploaded on
  • Presentation posted in: General

第 9 章 交换机配置. 清华大学出版社 ISBN 978-7- 302 - 2 6 755 - 3. 9.1 交换机配置基础知识. 9.1.1 交换机在组网中的作用 9.1.2 交换机的命名和标识 9.1.3 Cisco 交换机内部组成和产品分类. 9.1.1 交换机在组网中的作用. 交换机是一台专门用于通信连接的计算机 它由交换机硬件系统和交换机操作系统组成 交换机硬件包括: 中央处理器、随机存储器、只读存储器、可读写存储器和外部端口等 交换机操作系统与具体产品有关

Download Presentation

第 9 章 交换机配置

An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -

Presentation Transcript


9

第9章 交换机配置

清华大学出版社 ISBN 978-7-302-26755-3


9

9.1交换机配置基础知识

  • 9.1.1 交换机在组网中的作用

  • 9.1.2 交换机的命名和标识

  • 9.1.3 Cisco交换机内部组成和产品分类


9 1 1

9.1.1 交换机在组网中的作用

  • 交换机是一台专门用于通信连接的计算机

  • 它由交换机硬件系统和交换机操作系统组成

  • 交换机硬件包括:

    • 中央处理器、随机存储器、只读存储器、可读写存储器和外部端口等

  • 交换机操作系统与具体产品有关

    • 例如,Cisco Catalyst交换机主要采用的操作系统是Cisco IOS。


9 1 2

9.1.2 交换机的命名和标识

  • Cisco的交换机产品以“Catalyst”为商标

  • 交换机可以分为两类:

    • 一类是固定配置交换机

    • 另一类是模块化交换机

  • Cisco交换机的命名格式如下:

    • Catalyst NNXX [-C] [-M] [-A/-EN]

    • 其中

      • NN是交换机的系列号;

      • XX对于固定配置的交换机来说是端口数,对于模块化交换机来说是插槽数,有-C标志表明带光纤接口;

      • -M表示模块化;

      • -A和-EN分别是指交换机软件是标准板或企业版。


9 1 3 cisco

9.1.3 Cisco交换机组成和产品分类

  • 1、CPU,交换机的中央处理器;

  • 2、RAM/DRAM,交换机的工作存储器,存储交换机的运行配置等信息;

  • 3、NVRAM(非易失RAM),存储备份配置文件等信息;

  • 4、Flash ROM(闪存,又称可擦除、可编程ROM),用来存储系统软件映像、启动配置文件等信息;

  • 5、ROM(只读存储器),存储开机诊断程序、引导程序和操作系统软件;

  • 6、接口电路,交换机各端口的内部电路。


Cisco catalyst

Cisco Catalyst三款交换机的技术指标

  • 低端、中端、高端产品


9

9.2 交换机的配置

  • 9.2.1 配置交换机的过程

  • 9.2.2 配置交换机的工作模式

  • 9.2.3 交换机端口的默认配置

  • 9.2.4 交换机的常规配置

  • 9.2.5 清除交换机配置的方法


9 2 1

9.2.1配置交换机的过程

  • 交换机常用的配置方式有:

    • 1、用Console线把配置计算机直接连接到Console端口进行配置;

    • 2、通过网络环境中的计算机以Telnet方式进行配置;

    • 3、通过Web界面环境或网管软件对交换机进行一些基本的配置和管理;

    • 4、通过TFTP服务器实现对交换机软件的保存、升级、配置文件的保存和下载。


9 2 2

9.2.2 配置交换机的工作模式

  • Catalyst IOS系统软件的CLI与Cisco IOS的CLI类似

  • 交换机提供的其他访问模式还有:

    • 配置对话模式和故障恢复模式


9 2 3

9.2.3交换机端口的默认配置


9

不同交换机端口速率和数据包转发速率


9 2 4

9.2.4 交换机的常规配置

  • 1、交换机密码设置

  • 2、Cisco网络设备的SNMP配置

  • 3、交换机MAC地址的管理

    • (1)静态MAC地址设置

    • (2)安全MAC地址设置

    • (3)端口安全性设置

    • (4)端口安全性设置违规时采取的措施

    • (5)取消端口安全性设置


9 2 5

9.2.5 清除交换机配置的方法

  • 清除交换机配置用来把交换机的配置参数恢复到出厂时的默认配置

  • 主要步骤描述如下

    • switch>enable

    • switch#set default

    • Are you sure?[y/n]=y

    • switch#write

      • !清空系统启动配置文件startup-config

    • switch#show startup-config

    • This is first time startup system.

    • switch#reload

    • Process with reboot? [y/n]=y

    • switch#show flash

    • switch#write

      • !将当前运行的配置文件写入系统启动配置文件


9 3 vlan

9.3 VLAN的配置技术

  • 9.3.1 VLAN的配置技术概述

  • 9.3.2 基于端口划分VLAN

  • 9.3.3 VLAN的配置步骤

  • 9.3.4 在同一个交换机上创建VLAN

  • 9.3.5 创建跨越交换机的VLAN


9 3 1 vlan

9.3.1 VLAN的配置技术概述

  • 1、VLAN的标准

    • VLAN的标准有:IEEE802.1q;IEEE 802.1p;IEEE802.10;ISL(仅Cisco适用)

    • 不同VLAN之间的通信需要路由设计

    • VLAN和IP子网之间没有必然的联系

  • 2、VLAN设计的基本原则

  • 3、PVLAN技术

  • 4、SVLAN技术


9 3 2 vlan

9.3.2基于端口划分VLAN

  • 是目前定义VLAN最广泛、最简单有效的方法

  • 交换机端口划分成不同端口集合(即它们具有相同VLAN ID)

    • 而无论交换机端口上连接着什么设备

  • VLAN从逻辑上把一个LAN按照交换机的端口划分成多个VLAN

  • VLAN对广播域的划分是通过交换机软件来完成的


9 3 3 vlan

9.3.3 VLAN的配置步骤

  • 通过控制线连接计算机和交换机console接口

  • 再用直通线连接计算机和交换机的端口

  • 打开交换机电源

  • 创建VLAN时,需要给出VLAN号,在特权模式下输入:

  • switch#vlan database

  • switch(vlan)#vlan 2

  • 返回特权模式,进入全局配置模式,再进入端口配置模式,将交换机的端口加入到VLAN中(以交换机端口5为例)。

  • switch(config)#interface fa0/5

  • switch(config-if)#switchport mode access

  • switch(config-if)#switchport access vlan 2


9 3 4 vlan

9.3.4 在同一个交换机上创建VLAN

  • 同一个交换机上创建VLAN实验环境


9 3 5 vlan

9.3.5 创建跨越交换机的VLAN

  • 可使用交换机的干道(Trunk)技术,跨交换机实现VLAN

  • 配置成Trunk模式的这些交换机端口不隶属于某个VLAN了

    • 而是用于承载所有VLAN之间的数据帧


9 4 vlan

9.4 VLAN之间的路由配置

  • 9.4.1 单臂路由应用环境

  • 9.4.2 对Cisco 3750交换机的配置

  • 9.4.3 VLAN的单臂路由配置

  • 9.4.4 对Cisco 2950交换机的配置

  • 9.4.5 VLAN之间路由配置的测试

  • 9.4.6 删除VLAN的方法


9 4 1

9.4.1单臂路由应用环境

  • 采用1台Cisco 2811路由器,2台交换机,一台为Cisco 3750,另一台为Cisco 2950。两台计算机PC-A和PC-B通过直通线分别与交换机Cisco 3750和Cisco 2950连接。设置两个VLAN:vlan2和vlan3。


9 4 2 cisco 3750

9.4.2 对Cisco 3750交换机的配置

C3750#vlan database

C3750(vlan)#vlan 2 name market

C3750(vlan)#vlan 3 name develop

C3750(vlan)#vtp server

C3750(vlan)#exit

C3750#config terminal

C3750(config)#interface range fa1/0/1 -4

C3750(config-if-range)#switchport access vlan 2

C3750(config-if-range)#int range fa1/0/5 -8

C3750(config-ifi-range)#switchprot access vlan 3

C3750(config)#int fa1/0/24

C3750(config-if)#switchport trunk encapsulation dot1q

C3750(config-if)#switchport mode trunk


9 4 3 vlan

9.4.3 VLAN的单臂路由配置

Router#config terminal

Router(config)#interface fa0/0

Router(config-if)#no shutdown

Router(config-if)#int fa0/0.2

Router(config-subif)#encapsulation dot1q 2

Router(config-subif)#ip add 192.168.2.1 255.255.255.0

Router(config-subif)#no shutdown

Router(config-subif)#int fa0/0.3

Router(config-subif)#encapsulation dot1q 3

Router(config-subif)#ip add 192.168.3.1 255.255.255.0

Router(config-subif)#no shutdown

Router(config-subif)#exit


9 4 4 cisco 2950

9.4.4 对Cisco 2950交换机的配置

C2950#vlan database

C2950(vlan)#vtp client

C2950(vlan)#exit

C2950#show vlan brief

C2950#config terminal

C2950(config)#int fa0/24

C2950(config-if)#switchprot mode trunk

C2950(config)#interface range fa1/0/1 -4

C2950(config-if-range)#switchport access vlan 2

C2950(config-if-range)#int range fa1/0/5 -8

C2950(config-ifi-range)#switchprot access vlan 3

C2950(config-ifi-range)#exit


9 4 5 vlan

9.4.5 VLAN之间路由配置的测试

  • 1、用直通线将PC-A、PC-B计算机分别接入两个VLAN(vlan2、vlan3)

    • vlan2对应两个交换机的端口1─4

    • vlan3对应两个交换机的端口5─8

    • 两个VLAN网段的网络号分别为192.168.2.0,192.168.3.0

  • 2、设置PC-A计算机的IP地址192.168.2.2,网关地址为192.168.2.1,PC-B计算机的IP地址192.168.3.5,网关地址为192.168.3.1

    • 两台计算机的子网掩码均为255.255.255.0

    • 通过单臂路由配置实现互连两个VLAN上的计算机

  • 3、测试连通性

    • 分别在PC-A计算机或PC-B计算机上执行命令测试VALN之间路由的连通性


9 4 6 vlan

9.4.6 删除VLAN的方法

  • 1、删除VLAN的一种方法

    • 删除VLAN的一种方法是,先把两台交换机恢复成出厂配置,再执行删除命令。

    • switch#erase startup-config

    • switch#del vlan.dat

    • switch#reload

  • 2、删除全部VLAN

    • switch#del flash:vlan.dat

    • switch#show vlan

    • switch#dir flash:

  • 但是真正删除VLAN,还需要通过:

    • C2950(config-if)#no switchprot mode trunk

    • C2950(config-if)#switchprot mode access

    • 并把交换机的端口恢复到默认的VLAN 1中。


9 5 telnet

9.5 用Telnet远程配置交换机

  • 9.5.1 为交换机开启登录权限和操作权限

  • 9.5.2 使用Telnet对交换机进行远程管理


9 5 1

9.5.1 为交换机开启登录和操作权限

  • 对交换机进行远程配置操作之前,需要确认并做好三项工作:

    • 给交换机配置用于远程管理的IP地址;

    • 交换机需要开启远程管理功能;

    • 交换机已经通过普通端口连接到以太网上,并且运行Telnet的PC机也连接到同一个以太网的网段上,所设置的IP地址网络标识是一样的

  • 1、为交换机配置管理IP地址

  • 2、为交换机开启远程登录权限

  • 3、为交换机开启特权级操作权限


9 5 2 telnet

9.5.2 用Telnet对交换机进行远程管理

  • 在运行Windows XP的PC机上单击“开始”按钮,选择“运行”项

    • 在弹出的运行对话框中,输入命令行“Telnet 192.168.1.1”,按“确定”按钮,登录到远程交换机

  • 登录到远程交换机以后,PC机进入命令行窗口

  • 接着输入远程登录访问权限密码

  • 此时PC机就相当于所登录交换机的一个远程访问终端


9 6 web

9.6 通过Web界面访问交换机的配置

  • 9.6.1 交换机的Web管理

  • 9.6.2 交换机Web管理配置过程


9 6 1 web

9.6.1 交换机的Web管理

  • 交换机的Web管理界面直观清晰,可以在Web管理界面方便地对交换机进行管理和配置

  • 通过Web界面访问交换机也是属于远程访问方法

  • 还需要将交换机配置成HTTP服务器


9 6 2 web

9.6.2交换机Web管理配置过程

  • 开启交换机HTTP服务并配置Web认证的命令是:

    • Switch(config)#ip http server!启动HTTP服务

    • Switch(config)#ip http authentication enable!HTTP服务器接口为使用enable类型的身份验证

  • 1、交换机管理接口的配置

  • 2、配置交换机的Web端口

  • 3、在PC机上通过Web界面访问交换机


9

9.7 三层交换机配置

  • 9.7.1 三层交换机配置要点

  • 9.7.2 三层交换机配置过程


9 7 1

9.7.1三层交换机配置要点

  • 用三层交换机实现VLAN间的路由,可以通过开启三层交换机SVI接口方法实现

  • 先在三层交换机上创建各个VLAN的虚拟接口SVI(Switch Virtual Interface),并设置IP地址

  • 将所有VLAN连接的PC主机的网关指向该SVI的IP地址


9

三层交换机配置环境

  • 在三层交换机划分VLAN 2和VLAN 3,把SW1的端口24设置为trunk端口,SW2的端口24设置为trunk端口,并分别封装VLAN trunk协议dot1q。在三层交换机上创建VLAN的虚拟接口SVI


9 7 2

9.7.2三层交换机配置

  • 为SW1开启三层交换机的路由交换功能

    • Switch1(config)#ip routing //在三层交换机的任意一个端口都有路由功能

  • 在三层交换机设置两个VLAN虚拟接口(虚拟路由器接口)SVI 2和SVI 3,分别与VLAN2和VLAN3相关联

  • 虚拟接口用于连接不同的VLAN,虚拟接口的IP网络标识与对应的VLAN一致

  • 虚拟接口的IP地址分别作为VLAN2、VLAN3中计算机的默认网关地址


9

9.8 交换机的系统维护

  • 9.8.1 交换机密码的恢复

  • 9.8.2 交换机IOS的恢复


9 8 1

9.8.1 交换机密码的恢复

  • 1、断开交换机电源,按住交换机的“Mode”按钮,然后接通交换机电源,等到超级终端屏幕中出现“ switch:”提示时,释放“Mode”

  • 2、初始化Flash文件系统

  • 3、将包含了密码定义的配置文件config.text改名为config.rext.old

  • 4、交换机重启后会提示是否进入初始配置模式,选择no不进行配置

  • 5、在用户模式(user mode)下,输入“enable”进入特权模式(privileged mode)下,进行取消控制台密码的操作

  • 6、交换机重新启动后,系统直接进入到用户模式,出现Switch>的提示,表明console密码已经取消成功


9 8 2 ios

9.8.2 交换机IOS的恢复

  • 交换机系统软件IOS的恢复与路由器IOS的恢复类似

  • 在无法正常开机的情况下,可以通过Xmodern恢复交换机的IOS


Xmodem ios

Xmodem恢复交换机IOS的过程

  • 1、连接好控制线后,按住交换机上的Mode键,启动交换机

  • 2、输入命令:Switch:flash_init

  • 3、输入复制命令

  • 4、选择Xmodem传送IOS

  • 5、传送完毕之后,执行boot命令重新引导系统


9

发送文件对话框

  • 点击超级终端菜单传送—发送文件,在协议选项中选择Xmodem 或者 Xmodem-1k ,选择IOS的映像文件,输入文件名。然后点击发送按钮进行发送


  • Login