Introduction to is is
This presentation is the property of its rightful owner.
Sponsored Links
1 / 109

Introduction to IS-IS PowerPoint PPT Presentation


  • 83 Views
  • Uploaded on
  • Presentation posted in: General

Introduction to IS-IS. NANOG 20, Washington DC October 22-24. Abe Martey [email protected] Topics. 1. IS-IS Overview 2. IS-IS Protocol Concepts 3. CLNP Addressing 4. IS-IS Database 5. MPLS TE Extensions for IS-IS 6. ISP Network Design Considerations 7. Configuration Examples

Download Presentation

Introduction to IS-IS

An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -

Presentation Transcript


Introduction to is is

Introduction to IS-IS

NANOG 20, Washington DC

October 22-24

Abe Martey

[email protected]


Topics

Topics

1. IS-IS Overview

2. IS-IS Protocol Concepts

3. CLNP Addressing

4. IS-IS Database

5. MPLS TE Extensions for IS-IS

6. ISP Network Design Considerations

7. Configuration Examples

8. Basic Troubleshooting

9. Further Reading


1 is is overview

1. IS-IS Overview

Terminology and Acronyms

Intermediate system (IS)- Router

Designated Intermediate System (DIS) - Designated Router

Pseudonode - Broadcast link emulated as virtual node by DIS

End System (ES) - Network Host or workstation

Network Service Access Point (NSAP) - Network Layer Address

Subnetwork Point of attachment (SNPA) - Datalink interface

Packet data Unit (PDU) - Analogous to IPPacket

Link State PDU (LSP) - Routing information packet


Is is overview

IS-IS Overview

  • The Intermediate Systems to Intermediate System Routing Protocol (IS-IS) was originally designed to route the ISO Connectionless Network Protocol (CLNP) . (ISO10589 or RFC 1142)

  • Adapted for routing IP in addition to CLNP (RFC1195) as Integrated or Dual IS-IS

  • IS-IS is a Link State Protocol similar to the Open Shortest Path First (OSPF). OSPF supports only IP


Is is overview1

IS-IS Overview

  • IS-IS is an Interior Gateway Protocol (IGP) - for Intra-domain (AS) routing

  • BGP provides inter-domain routing for IP networks

  • ISO-IGRP is a Cisco proprietary routing protocol that can be used between CLNP domains


Is is overview2

IS-IS Overview

  • 3 network layer protocols play together to deliver the ISO defined Connectionless Network Service

    • - CLNP

    • - IS-IS

    • - ES- IS - End System to Intermediate System Protocol

  • All 3 protocols independently go over layer 2


Is is overview3

IS-IS Overview

  • CLNP is the ISO equivalent of IP for datagram delivery services (ISO 8473, RFC 994)

  • ES-IS is designed for routing between network hosts and routers (ISO9542, RFC 995).

  • IS-IS for layer 3 routing between routers. (ISO 10589/RFC 1142). Integrated IS-IS (RFC 1195) works within the ISO CNLS framework even when used for routing only IP.


Is is overview4

IS-IS Overview

  • End System Hellos (ESH) from Hosts and Intermediate System Hellos (ISH) from Routers used for ES-IS neighbor discovery

  • Intermediate System to Intermediate Systems Hellos (IIH) are used for establishing IS-IS layer3 adjacencies

  • ES-IS is somehow tied into IS-IS layer 3 adjacency discovery. ES-IS enabled automatically when IS-IS is configured on Ciscos


2 is is protocol concepts

2. IS-IS Protocol Concepts

  • Nodes

  • Links

  • Areas and Adjacencies

  • Level-1 and level-2 routing


Is is protocol concepts network nodes

IS-IS Protocol ConceptsNetwork Nodes

  • Hosts

  • Level-1 Routers

  • Level-2 Routers

  • Level-1 and Level-2 Pseudonodes on broadcast links only


Is is protocol concepts network nodes1

IS-IS Protocol ConceptsNetwork Nodes

DIS

DIS

PSN

  • Broadcast link represented as virtual node, referred to as Pseudonode (PSN)

  • PSN role played by the Designated Router (DIS)

  • DIS election is preemptive, based on interface priority with highest MAC address being tie breaker

  • IS-IS has only one DIS. DIS/PSN functionality supports database synchronization between routers on a broadcast type link


Is is protocol concepts network link types

IS-IS Protocol ConceptsNetwork/Link Types

  • Point-to-Point Links (PoS, ptp FR, ptp ATM)

  • Broadcast Links (Multi-point/multi-access, ie Ethernet, mpt FR, mpt ATM or Cisco DPT)

  • Non-broadcast multi-access treated as broadcast or point-to-point by configuration


Is is protocol concepts areas

IS-IS Protocol Concepts Areas

Area 49.001

L1

Level-1

Area

L1L2

Level-2

Backbone

Area 49.003

Area 49.0002

Level-1

Area

Level-1

Area

L1L2

L1L2

L1

L1


Is is protocol concepts is is adjacencies

IS-IS Protocol ConceptsIS-IS Adjacencies

  • IIH advertised for detecting neighbor and forming network layer adjacencies

  • 3 types of IIHs:

    • Point-to-point

    • LAN Level-1

    • LAN Level-2


Is is protocol concepts point to adjacencies

IS-IS Protocol ConceptsPoint-to Adjacencies

Bytes

Intra-domain Routing Protocol Discriminator

1

Length Indicator

1

Version/Protocol ID Extension

  • Pt-to-pt IIH used to establish level-1 or Level-2 pt-to-point adjacency

  • Only two way communication required on pt-to-pt links by ISO 10589

  • 3-way reliable process recently proposed for standardization in the IETF. Introduces pt-to-pt adjacency state TLV (Type 240)

1

ID Length

1

R

R

R

PDU Type

1

Version

1

Reserved

1

Maximum Area Addresses

1

Reserved (6 bits)

Circuit Type

1

Source ID

ID Length

Holding Time

2

2

PDU Length

Local Circuit ID

1

Variable Length

TLV Fields


Is is protocol concepts lan broadcast link adjacencies

IS-IS Protocol Concepts LAN (Broadcast link) Adjacencies

bytes

1

1

1

1

1

1

1

1

1

ID Length

2

2

1

ID Length + 1

Variable

Holding Time = Hello Interval x Hello Multiplier

Priority - Interface Priority for DIS arbitration

LAN ID - System ID of DIS + PSN number

Intradomain Routing Protocol Descr.

  • LAN Level-1 and LAN Level-2 IIH multicast independently to AllL1ISs (01-80-C2-00-00-14)and AllL2ISs (01-80-C2-00-00-14)

  • 3-way reliable adjacency formation can be enforced due to IS neighbors TLV (Type 2) appended to LAN IIHs

Lenth Indicator

Version/Protocol ID Extension

ID Length

R

R

R

PDU Type

Version

Reserved

Maximum Area Addresses

Reserved/Circuit type

Source ID

Holding Time

PDU Length

R

Priority

Lan ID

TYPE LENGTH FIELDS


Is is protocol concepts hierarchical routing

IS-IS Protocol ConceptsHierarchical Routing

Backbone

Area 49.0002

Area 49.001

  • IS-IS supports 2-level routing hierarchy

  • Routing domain is carved into areas. Routing in an area is level-1. Routing between areas is level-2

  • All ISO 10589/RFC1195 areas are stubs

Level-1

Routing

Level-1

Routing

Level-2

Routing


Is is protocol concepts is is packet types

IS-IS Protocol ConceptsIS-IS Packet Types

  • IS-IS Hello Packets (IIH)

    • Level 1 LAN IS-IS Hello

    • Level 2 LAN IS-IS Hello

    • Point-to-point Hello

  • Link State Packets (LSP)

    • Level 1 and Level 2

  • Complete Sequence Number packets (CSNP)

    • Level 1 and Level 2

  • Partial Sequence Number Packets (PSNP)

    • Level 1 and Level 2


3 clns addressing

3. CLNS Addressing

  • NSAP Format

  • AFI Values

  • Requirements and Caveats

  • Examples

  • Globally unique NSAPs


Clns addressing nsap format

CLNS AddressingNSAP Format

Area ID

Sys ID

NSEL

AFI

Variable length Area address

System ID

NSEL

  • NSAP format has 3 main components

    • Area ID

    • System ID

    • N-Selector (NSEL) - value is 0x00 on a router

  • NSAP of a router is also called a NET

1 byte

1 - 12 bytes

6 bytes

1 byte


Clns addressing afi values

CLNS AddressingAFI Values

Address Domain

AFI Value

37

39

47

49

  • X.121 - Int’l plan for public data networks

  • ISO DCC - Data country code

  • IS0 6523 ICD - Telex

  • Local - For local use within network domain only

X.121

ISO DCC

ISO 6523

Local


Clns addressing requirements and caveats

CLNS AddressingRequirements and Caveats

  • At least one NSAP is required per node

  • All routers in the same area must have a common Area ID

  • Each node in an area must have a unique System ID

  • All level 2 routers in a domain must have unique System IDs relative to each other

  • All systems belonging to a given domain must have System IDs of the same length in their NSAP addresses


Clns addressing requirements and caveats1

CLNS AddressingRequirements and Caveats

  • Multiple NSAPs allowed on Cisco routers for merging, splitting or renumbering

  • All NSAPs on the same router must have the same system ID.

  • The maximum size of an NSAP is 20 bytes

  • Minimum of 8 bytes allowed on Ciscos.

    • 1 byte for area, 6 bytes for system ID and 1 byte for N-selector.

    • AFI prefix recommended to make minimum of 9 bytes


Clns addressing nsap examples

CLNS AddressingNSAP Examples

Example 1

47.0001.aaaa.bbbb.cccc.00

Area = 47.0001, SysID = aaaa.bbbb.cccc, NSel = 00

Example 2

39.0f01.0002.0000.0c00.1111.00

Area = 39.0f01.0002, SysID = 0000.0c00.1111, NSel = 00

Example 3.

49.0002.0000.0000.0007.00

Area = 49.0002, SysID = 0000.0000.0007, Nsel = 00


Clns addressing how do most isp define system ids

CLNS AddressingHow do most ISP define System IDs?

Router A#

Interface Loopback 0

IP address 192.168.3.25

Router isis

Net 49.0001.1921.6800.3025.00

IP Address conversion process:

192.168.3.25 -> 192.168.003.025

|

V

1921.6800.3025

|

V

49.001.1921.6800.3025.00


Clns addressing globally unique nsaps

CLNS AddressingGlobally Unique NSAPs

  • AFI 47 (ISO 6523 ICD) is allocated via national sponsoring authority of the International Registration Authority (RA), usually a national standards body

    • NIST - allocated IDI 0005 and 0006

    • BSI subsidiary IOTA allocated 0124 for assignment of ATM End Systems Addresses

  • AFI 39 also administered through national institutions

    • IDI 0840 allocated to ANSI

NIST - United States National Institute of Standards

BSI - British Standards Institute

IOTA -Identifiers for Organizations for Telecommunications Addressing


Clns addressing globally unique nsaps1

CLNS AddressingGlobally Unique NSAPs

47 0124 XXXXX YYYYYYYYYYYYYY AABBCCDDEEFF 00

NSEL

SYS ID

AFI

IDI

ORG ID

ORG ASSIGNED

Globally unique NSAPs make sense for interconnected

telecommunications systems such as ATM switches, SONET/SDH

ADMs that use CLNS based applications for management. For ISP

networks, the local AFI (49) would just be fine! Why?


4 is is link state database

4. IS-IS Link State Database

  • Link State Packets

  • Sequence Number Packets

  • More on IS- IS Metrics

  • Flooding

  • Database Parameters, Flags and Timers

  • SPF Algorithm


Is is ls database link state packets

IS-IS LS DatabaseLink State Packets

LSP: RTB.00-00

LSP: RTC.00-00

RTC

RTB.

RTA

LSP: RTA.00-00

RTD.

RTE

LSP: RTE.00-00

LSP: RTD.00-00


Is is ls database is is packet format

IS-IS LS DatabaseIS-IS Packet Format

IS-IS Packets are made of the following:

  • A Fixed Header

    • Contains generic packet information and other specific information about the packet

  • Type, Length, Value (TLV) Fields

    • TLVs are blocks of specific routing-related information in IS-IS packets


Is is ls database generic packet format

No. of Octets

Intra-domain Routing Protocol Discriminator

1

Length Indicator

1

Version/Protocol ID Extension

1

ID Length

1

R

R

R

PDU Type

1

Version

1

1

Reserved

Maximum Area Addresses

1

Packet-Specific Header Fields

TLV Fields

IS-IS LS DatabaseGeneric Packet Format


Is is ls database lsp format

IS-IS LS DatabaseLSP Format

Octets

1

1

1

1

1

1

1

1

2

2

ID Length + 2

4

2

1

Variable

Intradomain Routing Proto Descriminator

Lenth Indicator

Version/Protocol ID Extension

ID Length

R

R

R

PDU Type

Version

Reserved

Maximum Area Addresses

PDU Length

Remaining Lifetime

LSP ID

Sequence Number

Checksum

P

ATT

LSPDBOL

IS Type

TYPE LENGTH VALUE FIELDS


Is is ls database ls packet identifier lspid

IS-IS LS DatabaseLS Packet Identifier (LSPID)

00c0.0040.abcd.02-01

  • Sys ID - System ID of IS or DIS in case of PSN LSP.

  • PSN ID - Zero for Non-PSN LSP and Non-zero for PSN LSP

  • LSP Number - Fragmentation number

Sys ID

PSN ID

LSPNo.


Complete sequence number packets csnps

Complete Sequence Number Packets (CSNPs)

  • Describes all known LSPs in the LS Database

  • Standard IS-IS packet format

    • Fixed Header and

    • TLV Fields

  • Each TLV includes the following info about each known LSP:

    • LSP ID

    • Remaining Lifetime

    • Sequence number

    • Checksum


Partial sequence number packets psnps

Partial Sequence Number Packets (PSNPs)

  • PSNPs are similarly constructed as CSNPs but have summaries of only specific LSPs

  • PSNPs are used in 2 ways:

    • To acknowledge receipt of LSP on pt-to-pt links

    • To request transmission of the latest version of an LSP


Level 1 tlvs

TLV Name

Type

Origin

Area Address

ISO 10589

1

2

Intermediate System Neighbors

ISO 10589

End System Neighbors

3

ISO 10589

Authentication information

10

ISO 10589

IP Internal Reachability Information

128

RFC 1195

Protocols Supported

129

RFC 1195

IP Interface Address

132

RFC 1195

Level-1 TLVs


Level 2 tlvs

TLV Name

Type

Origin

Area Address

ISO 10589

1

2

ISO 10589

Intermediate System Neighbors

Partition Designated Level-2 IS

4

ISO 10589

Prefix Neighbors

5

ISO 10589

10

ISO 10589

Authentication information

128

RFC 1195

IP Internal Reachability Information

129

RFC 1195

Protocols Supported

130

RFC 1195

IP External Reachability Information

131

Inter-domain Routing Protocol Information

RFC 1195

132

RFC 1195

IP Interface Address

Level-2 TLVs


New tlvs

New TLVs

TLV Name

Type

Comments

Extended IS Reachability Information

22

TE Extension. Replaces TLV 2

134

TE Extension

Router-Id

TE extension used in place of

TLV 128 or 130

Extended IP Reachability Information

135

For dynamic distribution of

Hostname to NET mapping via

LSP Flooding

Dynamic Hostname Information

137

Point-to-Point Adjacency State

240

Reliable Pt-to-pt adjacency

formation


Old is is metrics

Old IS-IS Metrics

  • ISO 10589 specifies 4 metric types

    • Default - Supported by all routers.

    • Delay - measures transit delay

    • Expense - Measures the monetary cost of link utilization

    • Error - measures error probability

  • Default metric type must be supported by all implementations

  • Other metric types specified for QoS routing. Not supported in Cisco IOS and most other vendor implementations


Old is is metrics1

Old IS-IS Metrics

  • Metric Information is carried in the following TLVs:

    • IS Neighbors

    • ES Neighbors

    • Prefix Neighbors

    • IP Internal Reachability

    • IP External Reachability

    • Extended IP Reachability

    • Extended IS Reachability


Old is is metrics2

Old IS-IS Metrics

Byte(s)

1

Default Metric (6 bits)

0

I/E

S

1

I/E

Delay Metric

  • Maximum metric per interface is 63

  • Maximum path metric is 1023

  • There is no automatic assignment based on interface bandwidth

  • Cisco uses default of 10 on all interfaces regardless of bandwidth

Expense Metric

1

S

I/E

I/E

Error Metric

S

1

4

IP Address

Subnet Mask

4


Flooding and lsdb synchronization

Flooding and LSDB synchronization

  • Acknowledgement-based reliable mechanism on pt-to-point links

  • Flooding on broadcast links depends on periodic advertisements of CSNPs for reliable flooding and synchronization


Srm and ssn flags

SRM and SSN Flags

  • Send Routing Message flag (SRMflag) and Send Sequence Number flag (SSNflag) are used by the Update Process to control delivery and acknowledgement of LSPs

    SRMFlag - If set for a LSP on a specific link, indicates the LSP should be flooded on that link

    SSNFlag - If set for a LSP on a link, means send a PSNP over that link to acknowledge receipt of LSP

.


Flooding on pt to pt links

Flooding on Pt-to-pt links

RTA

RTB

RTC

Interface 1

Interface 4

Interface 2

Interface 3

LSP

RTA.00-00

SEQ#100

LSP

RTA.00-00

SEQ#100

PSNP

RTA.00-00

SEQ#100

PSNP

RTA.00-00

SEQ#100


Flooding on broadcast links

Flooding on Broadcast Links

RTX

RTA (DIS)

RTB

RTC

RTX

LSP

RTX.00-00

SEQ#1

RTA

PSNP

RTX.00-00

SEQ#1

LSP

RTX.00-00

SEQ#1

X

RTA

CSNP

RTA.00

RTB.00

RTC.00

RTX.00

RTA

PSNP

RTX.00-00

SEQ#1

RTB

PSNP

RTX.00-00

SEQ#1

RTC

RTA

LSP

RTX.00-00

SEQ#1


Is is database timers

IS-IS Database Timers

Timer

Default Value

Cisco IOS Command

Maxage

1200s

isis max-lsp-interval

isis refresh-interval

900s

LSP Refresh Interval

isis lsp-interval

LSP Transmission Interval

33ms

LSP Retransmit Interval

5s

isis retransmit-interval

isis csnp-interval

CSNP Interval

10s


Spf algorithm

SPF Algorithm

  • Shortest Path First Algorithm (SPF), also known as Dijkstra (named after Dutch Mathematician) is used by link state protocols to obtain best paths through network

  • Works by building shortest path tree from calculating router (root) to all destinations in the network

  • SPF Process runs over level-1 and level-2 databases separately


Spf algorithm1

SPF Algorithm

  • In default mode, SPF process runs no frequent than every 5s

  • Full SPF is run when topology changes

  • When leaf elements such as IP prefixes change, routing table is adjusted with Partial Route Calculation (PRC)

  • PRC evaluates only routes that changed hence less CPU intensive and relatively fast


Spf algorithm2

SPF Algorithm

  • Duration of SPF depends on many factors such as:

    • Number of nodes

    • Number of links

    • Number of IP prefixes

    • Degree of mesh (especially for NBMA)

    • Speed of Route Processor


5 is is extensions for mpls te

5. IS-IS Extensions for MPLS TE

  • Wide Metrics

  • Extended IS Reachability Information

  • Extended IP Reachability Information

  • Sub TLVs


Is is extensions for mpls te wide metric

TLV Name

Type

Comments

TE Extension to replace

TLV 2

Extended IS Reachability Information

22

TE extension to IS-IS, used

in place of TLV 128 or 130

Extended IP Reachability Information

135

IS-IS Extensions for MPLS TEWide Metric

  • Traffic engineering extensions to IS-IS introduces reuse fields for non-implemented QoS metrics for larger Default metric values in TLV 22 and TLV 135

  • 3 byte metric field in TLV 22

  • 4 byte metric field in TLV 135


Is is extensions for mpls te tlvs 22

IS-IS Extensions for MPLS TETLVs 22

  • Type (1 byte): 22

  • Length (1 byte): Total Length of Value Field

  • Value:

    • 3 bytes default metric information

    • 7 bytes of system ID + pseudonode number

    • 1 byte of length of sub-TLVs

    • 0-244 bytes of sub-TLVs


Is is extensions for mpls te tlvs 135

IS-IS Extensions for MPLS TETLVs 135

  • Type (1 byte): 135

  • Length (1 byte): Total Length of Value Field

  • Value:

    • 4 bytes default metric information

    • 1 byte of control information

    • 1 bit up/down status

    • 1 bit sub-TLV presence indication

    • 6 bits prefix length

    • 0-4 bytes of IPV4 Prefix

    • 0-250 bytes of optional sub-TLVs

    • 1 byte to specify length of sub-TLVs

    • 0-249 bytes of sub-TLVs


Is is extensions for mpls te sub tlvs

IS-IS Extensions for MPLS TE Sub-TLVs

Sub-TLV Name

Type

Length (bytes)

Administrative Group ( color )

3

4

  • Sub-TLVs are used to flood MPLS TE resource information and link attributes

6

IPV4 Interface Address

4

IPV4 Neighbor Address

8

4

Maximum Link Bandwidth

4

9

Reservable Link Bandwidth

10

4

Unreserved Link Bandwidth

11

32


6 isp network design considerations

6. ISP Network Design Considerations

  • Sub-Optimal Level 1 Routing

  • 2 Layer Domain-wide Prefix distribution

  • Running IS-IS over NBMA

  • Routing Convergence


Isp network design considerations sub optimal level 1 routing

ISP Network Design ConsiderationsSub-optimal level-1 routing

  • IS - IS Areas in 1142 and RFC 1195 are stubs.

  • No inter-area routes leaked from L-1-2

  • L-1 routers point default to nearest L-1-2 router based on attach bit set in L-1 LSP by level-1-2 routers


Isp network design considerations sub optimal level 1 routing1

ISP Network Design ConsiderationsSub-optimal level-1 routing

Area 49.001

Backbone

Area 49.0002

RTC

RTA

  • RTA points default towards RTC because it is closer

  • Nearest L2 Router may not be best path out

10

OC12

RTE

RTF

L1L2

L1

10

L1

L1L2

RTB

L1L2

OC48

10

RTD

L1


Isp network design considerations sub optimal level 1 routing2

ISP Network Design ConsiderationsSub-optimal level-1 routing

Area 49.001

RTC

RTA

  • Workaround is to put every router into single area and run level-1 or level-2 routing

  • Make every router level-1 or level-2 only. By default Cisco routers come up as level-1-2

10

OC12

RTE

RTF

L2

L2

10

L2

L2

RTB

L2

OC48

10

RTD

L2


Isp network design considerations domain wide prefix distribution

ISP Network Design ConsiderationsDomain Wide Prefix Distribution

  • AKA Route Leaking

  • Allows L-1-2 routers to advertise inter-area routes into L1

  • L1 routers can then determine optimal paths for destinations in other areas

  • Allows scaling IS-IS networks by building hierarchy into network architecture

  • draft-ietf-isis-domain-wide-02.txt


Isp network design considerations mesh group

ISP Network Design ConsiderationsMesh-group

RTB

RTA

  • Configure RTA, RTB,RTC, RTD into mesh-group to reduce redundant flooding. RTE on Redundant path

  • LSPs received from a member of mesh-group will be flooded to only non-members

  • draft-balya-parker-mesh-00.txt

RTC

RTD

RTE


Isp network design considerations routing convergence

ISP Network Design ConsiderationsRouting Convergence

  • Current networks configured for stability and decent convergence

  • Optimizing for faster convergence desirable given improved quality of optical links

  • Risks in case of unexpected instabilities

    • Constant LSP regeneration

    • Extra Flooding

    • Processor intensive SPF runs, etc


Isp network design considerations routing convergence1

ISP Network Design ConsiderationsRouting Convergence

  • Challenges with SPF reduced by PRC

  • Redundant flooding can be alleviated with mesh-groups

  • Distributed or separate forwarding engines should take load off Route Processors

  • Above gains have been leveraged to improve routing convergence in some versions of Cisco IOS.

  • How? By using small hold-downs and short interval between SPF runs and intelligent stabilization algorithms in case of persistent churns

  • Enhancements in Cisco IOS 12.1 provide 8x faster convergence than current 12.0S releases for large networks of the order of 1000s


7 configuring is is on ciscos

7. Configuring IS-IS on Ciscos

  • Basic Configuration

  • Multi-point configuration (ATM and FR)

  • Typical ISP router configuration

  • Default route

  • Redistribution and Summarization

  • MPLS TE Configuration


Basic configuration

Basic Configuration

12.1.1.0/24

GSR1

GSR2

GSR4

.8

.2

198.168.1.4/30

.5

.6

e0

Pos1/0

Pos1/0

hostname GSR2

clns routing

!

interface Loopback0

ip address 13.1.1.2 255.255.255.0

ip router isis SJ

interface Ethernet0

ip address 12.1.1.2 255.255.255.0

ip router isis SJ

!

interface POS2/0

ip address 10.1.1.1 255.255.255.252

ip router isis SJ

!

router isis SJ

net 49.0001.0000.0000.0002.00

!

clns host GSR1 49.0001.0000.0000.0008.00

hostname GSR4

clns routing

!

interface Loopback0

ip address 13.1.1.2 255.255.255.0

ip router isis SJ

!

interface POS2/0

ip address 10.1.1.2 255.255.255.0

ip router isis SJ

!

router isis SJ

net 49.0002.0000.0000.0004.00


Verifying operation show clns neighbors

Verifying Operationshow clns neighbors

GSR2#show clns neighbors

System Id Interface SNPA State Holdtime Type Protocol

GSR1 Et0 00d0.58eb.d601 Up 8 L1L2 IS-IS

GSR4 PO2/0 *HDLC* Up 25 L2 IS-IS

GSR2#show clns neighbors detail

System Id Interface SNPA State Holdtime Type Protocol

GSR1 Et0 00d0.58eb.d601 Up 9 L1L2 IS-IS

Area Address(es): 49.0001

IP Address(es): 12.1.1.8*

Uptime: 00:08:57

GSR4 PO2/0 *HDLC* Up 24 L2 IS-IS

Area Address(es): 49.0002

IP Address(es): 10.1.1.2*

Uptime: 00:24:08


Verifying operation show clns interface

Verifying operationshow clns interface

GSR2#sh clns interface pos2/0

POS2/0 is up, line protocol is up

Checksums enabled, MTU 4470, Encapsulation HDLC

ERPDUs enabled, min. interval 10 msec.

RDPDUs enabled, min. interval 100 msec., Addr Mask enabled

Congestion Experienced bit set at 4 packets

CLNS fast switching disabled

CLNS SSE switching disabled

DEC compatibility mode OFF for this interface

Next ESH/ISH in 43 seconds

Routing Protocol: IS-IS

Circuit Type: level-1-2

Interface number 0x0, local circuit ID 0x100

Level-1 Metric: 10, Priority: 64, Circuit ID: GSR4.00

Number of active level-1 adjacencies: 0

Level-2 Metric: 10, Priority: 64, Circuit ID: GSR2.00

Number of active level-2 adjacencies: 1

Next IS-IS Hello in 2 seconds


Verifying operation show clns interface1

Verifying operationshow clns interface

GSR2#sh clns interface e0

Ethernet0 is up, line protocol is up

Checksums enabled, MTU 1497, Encapsulation SAP

ERPDUs enabled, min. interval 10 msec.

RDPDUs enabled, min. interval 100 msec., Addr Mask enabled

Congestion Experienced bit set at 4 packets

CLNS fast switching disabled

CLNS SSE switching disabled

DEC compatibility mode OFF for this interface

Next ESH/ISH in 4 seconds

Routing Protocol: IS-IS

Circuit Type: level-1-2

Interface number 0x1, local circuit ID 0x1

Level-1 Metric: 10, Priority: 64, Circuit ID: GSR1.01

Number of active level-1 adjacencies: 1

Level-2 Metric: 10, Priority: 64, Circuit ID: GSR1.01

Number of active level-2 adjacencies: 1

Next IS-IS LAN Level-1 Hello in 3 seconds

Next IS-IS LAN Level-2 Hello in 5 seconds


Verifying operation show clns protocol

Verifying operationshow clns protocol

GSR2#sh clns protocol

IS-IS Router: SJ

System Id: 0000.0000.0002.00 IS-Type: level-1-2

Manual area address(es):

49.0001

Routing for area address(es):

49.0001

Interfaces supported by IS-IS:

Loopback0 - IP

Ethernet0 - IP

POS2/0 - IP

Redistributing:static

Distance: 110

RRR level: none

Generate narrow metrics: level-1-2

Accept narrow metrics: level-1-2

Generate wide metrics: none

Accept wide metrics: none


Verifying operation show isis topology

Verifying Operationshow isis topology

GSR2#sh isis topology

IS-IS paths to level-1 routers

System Id Metric Next-Hop Interface SNPA

GSR2 --

GSR1 10 GSR1 Et0 00d0.58eb.d601

IS-IS paths to level-2 routers

System Id Metric Next-Hop Interface SNPA

GSR2 --

GSR4 10 GSR4 PO2/0 *HDLC*

GSR1 10 GSR1 Et0 00d0.58eb.d601


Verifying operation show isis database level n detail lspid

Verifying Operationshow isis database level-n detail <lspid>

GSR2#show isis database level-1 detail GSR2.00-00

IS-IS Level-1 LSP GSR2.00-00

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

GSR2.00-00 * 0x0000000E 0xDAE4 1197 1/0/0

Area Address: 49.0001

NLPID: 0xCC

Hostname: GSR2

IP Address: 13.1.1.2

Metric: 10 IP 12.1.1.0 255.255.255.0

Metric: 10 IP 10.1.1.0 255.255.255.252

Metric: 10 IP 13.1.1.2 255.255.255.255

Metric: 10 IS GSR2.02

Metric: 10 IS GSR1.01

Metric: 0 ES GSR2


Verifying operation show isis database level n detail lspid1

Verifying Operationshow isis database level-n detail <lspid>

GSR2#show isis database level-2 detail GSR2.00-00

IS-IS Level-2 LSP GSR2.00-00

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

GSR2.00-00 * 0x0000000E 0x08B5 986 0/0/0

Area Address: 49.0001

NLPID: 0xCC

Hostname: GSR2

IP Address: 13.1.1.2

Metric: 10 IS GSR2.02

Metric: 10 IS GSR1.01

Metric: 10 IS GSR4.00

Metric: 10 IP 10.1.1.0 255.255.255.252

Metric: 10 IP 12.1.1.0 255.255.255.0

Metric: 10 IP 13.1.1.2 255.255.255.255


Verifying operation show isis database level n detail lspid2

Verifying Operationshow isis database level-n detail <lspid>

GSR2#sh isis dat level-1 detail GSR1.01-00

IS-IS Level-1 LSP GSR1.01-00

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

GSR1.01-00 0x00000007 0xAF8E 616 0/0/0

Metric: 0 IS GSR1.00

Metric: 0 IS GSR2.00

  • Pseudonode LSP (GSR1.01-00) is generated by GSR1 which is DIS on ethernet0 of GSR2

  • PSN LSP Lists all known routers connected to LAN


Verifying operation show ip route isis

Verifying Operationshow ip route [isis]

GSR2#sh ip route

Codes: C - connected, S - static,

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

10.0.0.0/30 is subnetted, 1 subnets

C 10.1.1.0 is directly connected, POS2/0

12.0.0.0/24 is subnetted, 1 subnets

C 12.1.1.0 is directly connected, Ethernet0

13.0.0.0/32 is subnetted, 3 subnets

i L1 13.1.1.8 [115/20] via 12.1.1.8, Ethernet0

i L2 13.1.1.4 [115/20] via 10.1.1.2, POS2/0

C 13.1.1.2 is directly connected, Loopback0


Atm multi pt configuration

GSR3

GSR4

10.1.1.0/24

.3

.4

hostname GSR3

!

clns routing

!

interface ATM6/0.1 multipoint

ip address 10.1.1.3 255.255.255.0

no ip directed-broadcast

ip router isis

atm pvc 1 0 8 aal5snap

map-group GSR_Lab

!

router isis

net 49.0001.0000.0000.0003.00

is-type level-2-only

!

map-list GSR_Lab

ip 10.1.1.4 atm-vc 1 broadcast

clns 49.0001.0000.0000.0004.00 atm-vc 1 broadcast

hostname GSR4

!

clns routing

!

interface ATM6/0.1 multipoint

ip address 10.1.1.4 255.255.255.0

no ip directed-broadcast

ip router isis

atm pvc 1 0 8 aal5snap

map-group GSR_Lab

!

router isis

net 49.0001.0000.0000.0004.00

is-type level-2-only

!

map-list GSR_Lab

ip 10.1.1.3 atm-vc 1 broadcast

clns 49.0001.0000.0000.0003.00 atm-vc 1 broadcast

ATM Multi-pt Configuration


Atm multi pt configuration1

ATM Multi-pt Configuration

GSR3#sh clns neighbors

System Id Interface SNPA State Holdtime Type Protocol

GSR4 AT6/0.1 VC 1 Up 7 L2 IS-IS

GSR3#show clns int atm6/0.1

ATM6/0.1 is up, line protocol is up

Checksums enabled, MTU 4467, Encapsulation ATM

ERPDUs enabled, min. interval 10 msec.

RDPDUs enabled, min. interval 100 msec., Addr Mask enabled

Congestion Experienced bit set at 4 packets

CLNS fast switching disabled

CLNS SSE switching disabled

DEC compatibility mode OFF for this interface

Next ESH/ISH in 8 seconds

Routing Protocol: IS-IS

Circuit Type: level-1-2

Interface number 0x0, local circuit ID 0x1

Level-2 Metric: 10, Priority: 64, Circuit ID: GSR4.01

Number of active level-2 adjacencies: 1

Next IS-IS LAN Level-2 Hello in 7 seconds


Atm pt to pt configuration

ATM Pt-to-pt Configuration

GSR3

GSR4

10.1.1.0/24

.3

.4

hostname GSR3

!

clns routing

!

interface ATM6/0.2 point-to-point

ip address 192.168.1.1 255.255.255.252

no ip directed-broadcast

ip router isis

atm pvc 2 0 10 aal5snap

!

router isis

net 49.0001.0000.0000.0003.00

is-type level-2-only

hostname GSR4

!

clns routing

!

interface ATM6/0.2 point-to-point

ip address 192.168.1.2 255.255.255.252

no ip directed-broadcast

ip router isis

atm pvc 2 0 10 aal5snap

!

router isis

net 49.0001.0000.0000.0004.00

is-type level-2-only


Atm point pt configuration

GSR3#show clns neighbors

System Id Interface SNPA State Holdtime Type Protocol

GSR4 AT6/0.2 VC 2 Up 26 L2 IS-IS

GSR4 AT6/0.1 VC 1 Up 9 L2 IS-IS

GSR3#show clns int atm6/0.2

ATM6/0.2 is up, line protocol is up

Checksums enabled, MTU 4467, Encapsulation ATM

ERPDUs enabled, min. interval 10 msec.

RDPDUs enabled, min. interval 100 msec., Addr Mask enabled

Congestion Experienced bit set at 4 packets

CLNS fast switching disabled

CLNS SSE switching disabled

DEC compatibility mode OFF for this interface

Next ESH/ISH in 16 seconds

Routing Protocol: IS-IS

Circuit Type: level-1-2

Interface number 0x1, local circuit ID 0x100

Level-2 Metric: 10, Priority: 64, Circuit ID: GSR3.00

Number of active level-2 adjacencies: 1

Next IS-IS Hello in 3 seconds

ATM Point-pt Configuration


Frame relay multi pt configuration

Frame Relay Multi-pt Configuration

RTA

RTB

.1

FR CLOUD

.2

192.168.1.0/24

hostname RTA

!

clns routing

!

interface Serial0

ip address 192.168.1.1 255.255.255.0

ip router isis

encapsulation frame-relay

frame-relay map clns 200 broadcast

frame-relay map ip 192.168.1.2 200

!

router isis

net 49.0002.0000.0000.0001.00

is-type level-2-only

Hostname RTB

!

clns routing

!

interface Serial0

ip address 192.168.1.2 255.255.255.0

ip router isis isp

encapsulation frame-relay

frame-relay map clns 200 broadcast

frame-relay map ip 192.168.1.1 200

!

router isis

net 49.0001.0000.0000.0002.00

is-type level-2-only


Typical isp router configuration

Typical ISP Router Configuration

GSR1#

interface Loopback0

ip address 172.160.250.1 255.255.255.255

!

interface POS1/0

ip address 192.168.1.1 255.255.255.0

isis metric 100 level-2

isis hello-interval 12 level-2

isis hello-multiplier 5 level-2

isis retransmit-interval 100

!

router isis SJ

summary-address 172.160.0.0 255.255.0.0

passive-interface Loopback0

distance 15 ip

net 49.0001.0001.0000.0001.0002.0001.1721.6025.0001.00

is-type level-2-only

metric-style wide

spf-interval 30

log-adjacency-changes


Default information originate

default-information originate

Used for originating default into level-2

Level-1 routers automatically point default to nearest

level-2 router based on attach bit information

Hostname RTE

!

router isis SJ

default-information originate

net 49.0002.0000.0000.0002.00

!

RTB#sh isis database RTE.00-00 detail level-2

IS-IS Level-2 LSP RTE.00-00

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

RTE.00-00 * 0x0000008D 0xDBD0 848 0/0/0

Area Address: 49.0002

NLPID: 0x81 0xCC

IP Address: 172.16.2.2

Metric: 10 IS RTE.01

Metric: 10 IS RTB.00

Metric: 0 IP-External 0.0.0.0 0.0.0.0

Metric: 20 IP 172.16.5.16 255.255.255.252

Metric: 20 IP 172.16.5.12 255.255.255.252

Metric: 10 IP 172.16.5.4 255.255.255.252

Metric: 10 IP 172.16.2.0 255.255.255.0


Verifying operation show isis database

Verifying Operationshow isis database

GSR2#sh isis database

IS-IS Level-1 Link State Database

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

GSR2.00-00 * 0x00000008 0x7399 716 1/0/0

GSR1.00-00 0x00000002 0x7307 545 1/0/0

GSR1.01-00 0x00000003 0xB78A 574 0/0/0

IS-IS Level-2 Link State Database

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

GSR2.00-00 * 0x00000009 0xC049 1054 0/0/0

GSR4.00-00 0x00000009 0x71D6 999 0/0/0

GSR1.00-00 0x0000626A 0x1963 701 0/0/0

GSR1.01-00 0x0000696F 0x32C2 906 0/0/0


Summarization

Summarization

RTB

RTE

172.16.5.0/30

172.170.1.0/24

.5

.6

hostname RTB

!

interface Ethernet0

ip address 172.170.1.1 255.255.255.0

ip router isis SJ

!

router isis SJ

summary-address 172.170.0.0 255.255.0.0

net 49.0001.0000.0000.0001.00


Summarization1

Summarization

  • RTE#sh ip route

  • Gateway of last resort is not set

  • i L2 172.170.0.0/16 [115/20] via 172.16.5.5, Serial 0

  • 172.16.0.0/16 is subnetted, 1 subnets

  • C 172.16.5.4/30 is directly connected, Serial0

    • RTB#sh isis dat RTB.00-00 l2 detail

    • IS-IS Level-2 LSP RTB.00-00

    • LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

    • RTB.00-00 * 0x00000096 0x86F6 877 0/0/0

    • Area Address: 49.0001

    • NLPID: 0x81 0xCC

    • IP Address: 172.170.1.1

    • Metric: 10 IS RTB.02

    • Metric: 10 IS RTE.00

    • Metric: 10 IS RTF.00

    • Metric: 10 IP 172.16.5.4 255.255.255.252

    • Metric: 10 IP 172.170.0.0 255.255.0.0


  • Redistribution

    Redistribution

    IS-IS Domain

    OSPF Domain

    RTB

    RTE

    172.16.5.0/30

    RTG

    .4

    .3

    .5

    .6

    172.170.1.0/24

    172.16.2.0/24

    172.80.1.1/24

    RTE

    router ospf 1

    network 172.16.2.0 0.0.0.255 area 0

    !

    router isis SJ

    redistribute ospf 1 metric 20 metric-type internal level-2

    net 49.0002.0000.0000.0002.00


    Redistribution1

    Redistribution

    RTE#sh isis dat rte.00-00 level-2 detail

    IS-IS Level-2 LSP RTE.00-00

    LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

    RTE.00-00 * 0x000003B3 0x66A7 859 0/0/0

    Area Address: 49.0002

    NLPID: 0x81 0xCC

    IP Address: 172.16.2.2

    Metric: 10 IS RTE.01

    Metric: 10 IS RTB.00

    Metric: 20 IP-External 172.180.0.0 255.255.0.0

    Metric: 20 IP 172.16.5.16 255.255.255.252

    Metric: 20 IP 172.16.5.12 255.255.255.252

    Metric: 10 IP 172.16.5.4 255.255.255.252

    Metric: 10 IP 172.16.2.0 255.255.255.0


    Mpls te configuration

    MPLS TE Configuration

    GSR1

    GSR2

    GSR4

    12.1.1.0/30

    .8

    10.1.1.0/30

    Pos 2/0

    .1

    .2

    Pos 2/0

    .4

    Eth 0

    Eth 0

    Pos 3/0

    Pos 4/0

    .9

    .5

    Pos 2/2

    10.1.1.4/30

    10.1.1.8/30

    Pos 4/0

    .10

    .6

    GSR6


    Mpls te configuration is is configuration

    MPLS TE ConfigurationIS-IS configuration

    hostname GSR2

    !

    mpls traffic-eng tunnels

    interface Loopback0

    ip address 13.1.1.2 255.255.255.255

    no ip directed-broadcast

    ip router isis SJ

    !

    interface POS2/0

    ip address 10.1.1.1 255.255.255.252

    ip router isis SJ

    mpls traffic-eng tunnels

    isis metric 100 level-2

    ip rsvp bandwidth 10000 10000

    !

    interface POS3/0

    ip address 10.1.1.9 255.255.255.252

    ip router isis SJ

    mpls traffic-eng tunnels

    isis metric 100 level-2

    ip rsvp bandwidth 10000 10000

    !

    router isis SJ

    net 49.0001.0000.0000.0002.00

    is-type level-2-only

    metric-style wide

    log-adjacency-changes

    mpls traffic-eng router-id Loopback0

    mpls traffic-eng level-2

    !


    Mpls te configuration dynamic path

    MPLS TE ConfigurationDynamic Path

    hostname GSR2

    !

    interface Tunnel1

    ip unnumbered Loopback0

    no ip directed-broadcast

    tunnel destination 13.1.1.4

    tunnel mode mpls traffic-eng

    tunnel mpls traffic-eng autoroute announce

    tunnel mpls traffic-eng bandwidth 10000

    tunnel mpls traffic-eng path-option 1 dynamic

    • Tunnel is configured on head end router

    • For dynamic path discovery, dynamic path option is used


    Mpls te configuration explicit path

    MPLS TE ConfigurationExplicit Path

    hostname GSR2

    !

    interface Tunnel2

    ip unnumbered Loopback0

    no ip directed-broadcast

    tunnel destination 13.1.1.4

    tunnel mode mpls traffic-eng

    tunnel mpls traffic-eng autoroute announce

    tunnel mpls traffic-eng path-option 1 explicit name ViaGSR6

    !

    ip explicit-path name ViaGSR6 enable

    next-address 13.1.1.6

    next-address 13.1.1.4

    !

    ip route 192.168.5.0 255.255.255.0 Tunnel2

    • Tunnel is configured on head end router

    • Explicit path defined


    Mpls te configuration1

    MPLS TE Configuration

    GSR2#show mpls traffic-eng tunn brief

    Signalling Summary:

    LSP Tunnels Process: running

    RSVP Process: running

    Forwarding: enabled

    Periodic reoptimization: every 3600 seconds, next in 1180 seconds

    TUNNEL NAME DESTINATION STATUS STATE

    GSR2_t1 13.1.1.4 up up

    GSR2_t2 13.1.1.4 up up

    Displayed 2 (of 2) heads, 0 (of 0) midpoints, 0 (of 0) tails


    Mpls te configuration2

    MPLS TE Configuration

    GSR2#sh mpls traffic-eng tunnels name GSR2_t1

    Name: GSR2_t1 (Tunnel1) Destination: 13.1.1.4

    Status:

    Admin: up Oper: up Path: valid Signalling: connected

    path option 1, type dynamic (Basis for Setup, path weight 100)

    Config Paramters:

    Bandwidth: 1000 Priority: 7 7 Affinity: 0x0/0xFFFF

    AutoRoute: enabled LockDown: disabled

    InLabel : -

    OutLabel : POS2/0, implicit-null

    RSVP Signalling Info:

    Src 13.1.1.2, Dst 13.1.1.4, Tun_Id 1, Tun_Instance 1

    RSVP Path Info:

    My Address: 13.1.1.2

    Explicit Route: 10.1.1.2 13.1.1.4

    Record Route: NONE

    Tspec: ave rate=1000 kbits, burst=1000 bytes, peak rate=1000 kbits

    RSVP Resv Info:

    Record Route: NONE

    Fspec: ave rate=1000 kbits, burst=1000 bytes, peak rate=Inf


    Mpls te configuration tunnel1

    MPLS TE Configuration Tunnel1

    GSR2#sh mpls traffic-eng tunnels name GSR2_t1

    Name: GSR2_t1 (Tunnel1) Destination: 13.1.1.4

    Status:

    Admin: up Oper: up Path: valid Signalling: connected

    path option 1, type dynamic (Basis for Setup, path weight 100)

    Config Paramters:

    Bandwidth: 1000 Priority: 7 7 Affinity: 0x0/0xFFFF

    AutoRoute: enabled LockDown: disabled

    InLabel : -

    OutLabel : POS2/0, implicit-null

    RSVP Signalling Info:

    Src 13.1.1.2, Dst 13.1.1.4, Tun_Id 1, Tun_Instance 1

    RSVP Path Info:

    My Address: 13.1.1.2

    Explicit Route: 10.1.1.2 13.1.1.4

    Record Route: NONE

    Tspec: ave rate=1000 kbits, burst=1000 bytes, peak rate=1000 kbits

    RSVP Resv Info:

    Record Route: NONE

    Fspec: ave rate=1000 kbits, burst=1000 bytes, peak rate=Inf


    Mpls te configuration tunnel 2

    MPLS TE Configuration Tunnel 2

    GSR2#sh mpls traffic-eng tunnels name GSR2_t1

    Name: GSR2_t2 (Tunnel2) Destination: 13.1.1.4

    Status:

    Admin: up Oper: up Path: valid Signalling: connected

    path option 1, type explicit ViaGSR6 (Basis for Setup, path weight 110)

    Config Paramters:

    Bandwidth: 0 Priority: 7 7 Affinity: 0x0/0xFFFF

    AutoRoute: enabled LockDown: disabled

    InLabel : -

    OutLabel : POS3/0, 26

    RSVP Signalling Info:

    Src 13.1.1.2, Dst 13.1.1.4, Tun_Id 2, Tun_Instance 1

    RSVP Path Info:

    My Address: 13.1.1.2

    Explicit Route: 10.1.1.10 10.1.1.5

    Record Route: NONE

    Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

    RSVP Resv Info:

    Record Route: NONE

    Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=Inf


    Mpls te configuration show isis database verbose

    MPLS TE Configurationshow isis database verbose

    GSR2#show isis database verbose GSR2.00-00

    IS-IS Level-2 LSP GSR2.00-00

    LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

    GSR2.00-00 * 0x00000009 0x5304 1125 0/0/0

    Area Address: 49.0001

    NLPID: 0xCC

    Hostname: GSR2

    Router ID: 13.1.1.2

    IP Address: 13.1.1.2

    Metric: 100 IS-Extended GSR6.00

    Affinity: 0x00000000

    Interface IP Address: 10.1.1.9

    Neighbor IP Address: 10.1.1.10

    Physical BW: 622000000 bits/sec

    Reservable BW: 10000000 bits/sec

    BW Unreserved[0]: 10000000 bits/sec, BW Unreserved[1]: 10000000 bits/sec

    BW Unreserved[2]: 10000000 bits/sec, BW Unreserved[3]: 10000000 bits/sec

    BW Unreserved[4]: 10000000 bits/sec, BW Unreserved[5]: 10000000 bits/sec

    BW Unreserved[6]: 10000000 bits/sec, BW Unreserved[7]: 10000000 bits/sec


    Mpls te configuration show isis database verbose cont d

    MPLS TE Configurationshow isis database verbose cont’d

    GSR2#show isis database verbose GSR2.00-00

    [snip]

    Metric: 100 IS-Extended GSR4.00

    Affinity: 0x00000000

    Interface IP Address: 10.1.1.1

    Neighbor IP Address: 10.1.1.2

    Physical BW: 2488000000 bits/sec

    Reservable BW: 10000000 bits/sec

    BW Unreserved[0]: 10000000 bits/sec, BW Unreserved[1]: 10000000 bits/sec

    BW Unreserved[2]: 10000000 bits/sec, BW Unreserved[3]: 10000000 bits/sec

    BW Unreserved[4]: 10000000 bits/sec, BW Unreserved[5]: 10000000 bits/sec

    BW Unreserved[6]: 10000000 bits/sec, BW Unreserved[7]: 9000000 bits/sec

    Metric: 100 IP 10.1.1.8/30

    Metric: 100 IP 10.1.1.0/30

    Metric: 10 IP 13.1.1.2/32


    Mpls te is is show commands

    MPLS TE IS-IS show commands

    GSR2#sh isis mpls traffic-eng ?

    adjacency-log Adjacency Log

    advertisements Agent advertisements

    downstream-tree MPLS TE Optimized Autoroute Calculation downstream tree

    tunnel Tunnel Information

    GSR2#sh isis mpls traffic-eng adjacency-log

    IS-IS MPLS TE log

    When Neighbor ID IP Address Interface Status Level

    00:50:13 GSR4.00 10.1.1.2 PO2/0 Up level-2

    00:50:12 GSR6.00 10.1.1.10 PO3/0 Up level-2

    GSR2#sh isis mpls traffic-eng tunnel

    GSR2#sh isis mpls traffic-eng tunnel

    System Id Tunnel Name Bandwidth Nexthop Metric Mode

    GSR4.00 Tunnel2 0 13.1.1.4

    Tunnel1 1000 13.1.1.4


    Mpls te configuration3

    MPLS TE Configuration

    hostname GSR4

    mpls traffic-eng tunnels

    !

    interface Loopback0

    ip address 13.1.1.4 255.255.255.255

    ip router isis SJ

    !

    interface Loopback5

    ip address 192.168.5.1 255.255.255.0

    !

    interface Ethernet0

    ip address 12.1.1.4 255.255.255.0

    ip router isis SJ

    !

    interface POS2/0

    ip address 10.1.1.2 255.255.255.252

    ip router isis SJ

    mpls traffic-eng tunnels

    ip rsvp bandwidth 1000 1000

    interface POS4/0

    ip address 10.1.1.5 255.255.255.252

    no ip directed-broadcast

    ip router isis SJ

    mpls traffic-eng tunnels

    ip rsvp bandwidth 1000 1000

    !

    router isis SJ

    net 49.0001.0000.0000.0004.00

    is-type level-2-only

    metric-style wide

    mpls traffic-eng router-id Loopback0

    mpls traffic-eng level-2


    Mpls te configuration4

    MPLS TE Configuration

    hostname GSR6

    !

    mpls traffic-eng tunnels

    !

    interface Loopback0

    ip address 13.1.1.6 255.255.255.255

    ip router isis SJ

    !

    interface POS4/0

    ip address 10.1.1.6 255.255.255.252

    no ip directed-broadcast

    ip router isis SJ

    mpls traffic-eng tunnels

    ip rsvp bandwidth 1000 1000

    interface POS2/2

    ip address 10.1.1.10 255.255.255.252

    no ip directed-broadcast

    ip router isis SJ

    mpls traffic-eng tunnels

    ip rsvp bandwidth 1000 1000

    router isis SJ

    net 49.0001.0000.0000.0006.00

    is-type level-2-only

    metric-style wide

    mpls traffic-eng router-id Loopback0

    mpls traffic-eng level-2


    Mpls te configuration show ip route

    MPLS TE Configurationshow ip route

    GSR2#sh ip route

    Codes: C - connected, S - static, i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2

    ia - IS-IS inter area

    Gateway of last resort is not set

    S 192.168.5.0/24 is directly connected, Tunnel2

    10.0.0.0/30 is subnetted, 3 subnets

    C 10.1.1.8 is directly connected, POS3/0

    C 10.1.1.0 is directly connected, POS2/0

    i L2 10.1.1.4 [115/20] via 10.1.1.10, POS3/0

    [115/20] via 13.1.1.4, Tunnel2

    12.0.0.0/24 is subnetted, 1 subnets

    i L2 12.1.1.0 [115/20] via 13.1.1.4, Tunnel2

    13.0.0.0/32 is subnetted, 3 subnets

    i L2 13.1.1.4 [115/20] via 13.1.1.4, Tunnel2

    i L2 13.1.1.6 [115/20] via 10.1.1.10, POS3/0

    C 13.1.1.2 is directly connected, Loopback0


    8 basic troubleshooting

    8. Basic Troubleshooting

    • Show Commands

    • Debugging Commands

    • Error logs

    • MPLS TE troubleshooting


    Troubleshooting clns commands

    TroubleshootingCLNS Commands

    show clns int

    show clns protocol

    show clns neighbors detail

    show clns is-neighbors

    show clns es-neighbors

    show clns route

    show clns cache

    show clns traffic


    Troubleshooting show isis commands

    Troubleshooting show isis commands

    show isis spf-log

    show isis database detail

    show isis database<lspid>

    show isis route

    show isis database L1|L2


    Troubleshooting debugging commands

    Troubleshooting Debugging Commands

    debug clns:

    events CLNS error events

    filters CLNS filters

    packets CLNS packet switching activity

    routing CLNS routing table activity

    debug isis:

    adj-packets IS-IS Adjacency related packets

    checksum-errors IS-IS LSP checksum errors

    local-updates IS-IS local update packets

    snp-packets IS-IS CSNP/PSNP packets

    spf-events IS-IS Shortest Path First Events

    spf-statistics IS-IS SPF Timing and Statistic Data

    spf-triggers IS-IS SPF triggering events

    update-packets IS-IS Update related packet


    Troubleshooting error logging

    Troubleshooting Error Logging

    log-adjacency-changes Command

    Used to keep track of changes in the state of adjacent neighbors

    Helpful in tracking connectivity problems

    RTX#show log

    %CLNS-5-ADJCHANGE: ISIS: Adjacency to 0000.0000.0001 (ethernet 0)

    %CLNS-5-ADJCHANGE: ISIS: Adjacency to 0000.0000.0002 (ethernet 0)

    BAD Clns Packet Errors

    Nov 16 02:18:04.848 EDT: %CLNS-4-BADPACKET: ISIS: P2P hello, option 8

    length 53 remaining bytes (51) from VC 2 (ATM4/0.2)

    Nov 16 02:18:04.848 EDT: ISIS: P2P hello, option 8 length 53 > remaining

    bytes (51) from VC 2 (ATM4/0.2)


    Troubleshooting spf logs

    TroubleshootingSPF Logs

    RTB#sh isis spf-log

    Level 1 SPF log

    When Duration Nodes Count Triggers

    00:25:27 8 4 1 PERIODIC

    00:18:09 12 5 2 NEWLSP TLVCONTENT

    00:10:27 8 5 1 PERIODIC

    Level 2 SPF log

    When Duration Nodes Count Triggers

    00:40:35 8 3 1 PERIODIC

    00:25:35 8 3 1 PERIODIC

    00:18:17 8 3 1 TLVCONTENT

    00:10:34 8 3 1 PERIODIC


    Troubleshooting mpls te

    TroubleshootingMPLS TE

    • Show mpls traffic-eng tunnel

    • show mpls traffic-eng topology

    • show mpls traffic-eng autoroute

    • show mpls traffic-eng link advertisements

    • show isis traffic-eng tunnels

    • show isis database [verbose|detail]

    • show ip rsvp

    • Debug traffic-eng path calc

    • debug ip rsvp


    9 further reading

    9. Further Reading

    • ISO 8473 Connectionless Network Protocol (CNLP)

    • ISO 10589 ISO IS-IS Routing Protocol

    • ISO 9542 ES-IS Routing Protocol

    • ISO 8348/Ad2 Network Services Access Points

    • RFC 1195 Integrated (Dual) IS-IS

    • RFC 1237 Guidelines for OSI NSAP allocation in the Internet

    • http://www.cisco.com/univercd/cc/td/doc/product/software/ios113ed/113ed_cr/np1_c/1cisis.htm

    • http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t3/traffeng.htm


    9 further reading1

    9. Further Reading

    • RFC Drafts:

    • draft-ietf-isis-traffic-02.txt

    • draft-ietf-isis-3way-01.txt

    • draft-ietf-isis-domain-wide-01.txt

    • draft-ietf-isis-dyname-01.txt

    • draft-hsmit-mpls-igp-spf-00.txt

    • draft-ietf-isis-hmac-00.txt


    Q and a

    Q and A

    • Thank You


  • Login