Configuring eigrp l.jpg
This presentation is the property of its rightful owner.
Sponsored Links
1 / 24

Configuring EIGRP PowerPoint PPT Presentation


  • 190 Views
  • Uploaded on
  • Presentation posted in: General

Configuring EIGRP. BSCI Module 2-2 – Implementing and Verifying EIGRP. Objectives. Upon completing this lesson, you will be able to describe how to implement EIGRP routing. This ability includes being able to meet these objectives:

Download Presentation

Configuring EIGRP

An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -

Presentation Transcript


Configuring eigrp l.jpg

Configuring EIGRP

BSCI Module 2-2 – Implementing and Verifying EIGRP


Objectives l.jpg

Objectives

  • Upon completing this lesson, you will be able to describe how to implement EIGRP routing. This ability includes being able to meet these objectives:

    • Describe the commands used in a basic EIGRP configuration task

    • Explain how to configure a router to use wildcard masks to select the interfaces and networks that will participate in EIGRP routing

    • Configure the gateway of last resort or default route

    • Verify that the router recognizes EIGRP neighbors and routes

    • Verify EIGRP operations


Purpose of this lesson l.jpg

Purpose of this Lesson

Coverage of topics new to the “EIGRP” module of BSCI.

  • What’s new in this module?

    • Describe the commands used in a basic EIGRP configuration task

    • Explain how to configure a router to use wildcard masks to select the interfaces and networks that will participate in EIGRP routing

    • Configure the gateway of last resort or default route.


Configuring eigrp4 l.jpg

Configuring EIGRP

Router(config)#

router eigrp autonomous-system-number

  • Defines EIGRP as the IP routing protocol.

  • All routers in the internetwork that must exchange EIGRP routing updates must have the same autonomous system number.

Router(config-router)#

network network-number [wildcard-mask]

  • Identifies attached networks participating in EIGRP.

  • The wildcard-mask is an inverse mask used to determine how to interpret the address. The mask has wildcard bits, where 0 is a match and 1 is “don’t care.”


Configuring eigrp cont l.jpg

Configuring EIGRP (Cont.)

Router(config-if)#

bandwidth kilobits

  • Defines the interface’s bandwidth for the purposes of sending routing update traffic.


Configuring eigrp for ip l.jpg

Configuring EIGRP for IP

Network 192.168.1.0 is not configured on router A,because it is not directly connected to router A.


Configuring eigrp with ip cont l.jpg

Configuring EIGRP with IP (cont.)

Classful configuration example:

routerA(config)#router eigrp 109

routerA(config-router)#network 10.1.0.0

routerA(config-router)#network 10.4.0.0

routerA(config-router)#network 172.16.7.0

routerA(config-router)#network 172.16.2.0

Classless configuration example:

routerA(config)#router eigrp 109

routerA(config-router)#network 10.1.0.0 0.0.255.255

routerA(config-router)#network 10.4.0.0 0.0.255.255

routerA(config-router)#network 172.16.2.0 0.0.0.255

routerA(config-router)#network 172.16.7.0 0.0.0.255


Using the wildcard mask in eigrp l.jpg

Using the Wildcard Mask in EIGRP


Using and configuring the ip default network command for eigrp l.jpg

Using and Configuring the ip default-network command for EIGRP


Example r1 eigrp configuration l.jpg

Example R1 EIGRP Configuration


R2 eigrp configuration l.jpg

R2 EIGRP Configuration

<output omitted>

interface FastEthernet0/0

ip address 172.17.2.2 255.255.255.0

<output omitted>

interface Serial0/0/1

bandwidth 64

ip address 192.168.1.102 255.255.255.224

<output omitted>

router eigrp 100

network 172.17.2.0 0.0.0.255

network 192.168.1.0


Verifying eigrp show ip eigrp neighbors l.jpg

Verifying EIGRP: show ip eigrp neighbors

R1#show ip eigrp neighbors

IP-EIGRP neighbors for process 100

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 192.168.1.102 Se0/0/1 10 00:07:22 10 2280 0 5

R1#


Verifying eigrp show ip route eigrp l.jpg

Verifying EIGRP: show ip route eigrp

R1#show ip route eigrp

D 172.17.0.0/16 [90/40514560] via 192.168.1.102, 00:07:01, Serial0/0/1

172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

D 172.16.0.0/16 is a summary, 00:05:13, Null0

192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks

D 192.168.1.0/24 is a summary, 00:05:13, Null0

R1#show ip route

<output omitted>

Gateway of last resort is not set

D 172.17.0.0/16 [90/40514560] via 192.168.1.102, 00:06:55, Serial0/0/1

172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

D 172.16.0.0/16 is a summary, 00:05:07, Null0

C 172.16.1.0/24 is directly connected, FastEthernet0/0

192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.1.96/27 is directly connected, Serial0/0/1

D 192.168.1.0/24 is a summary, 00:05:07, Null0


Verifying eigrp show ip protocols l.jpg

Verifying EIGRP: show ip protocols

R1#show ip protocols

Routing Protocol is "eigrp 100"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Default networks flagged in outgoing updates

Default networks accepted from incoming updates

EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

EIGRP maximum hopcount 100

EIGRP maximum metric variance 1

Redistributing: eigrp 100

EIGRP NSF-aware route hold timer is 240s

<output omitted>

Maximum path: 4

Routing for Networks:

172.16.1.0/24

192.168.1.0

Routing Information Sources:

Gateway Distance Last Update

(this router) 90 00:09:38

Gateway Distance Last Update

192.168.1.102 90 00:09:40

Distance: internal 90 external 170


Verifying eigrp show ip eigrp interfaces l.jpg

Verifying EIGRP: show ip eigrp interfaces

R1#show ip eigrp interfaces

IP-EIGRP interfaces for process 100

Xmit Queue Mean Pacing Time Multicast Pending

Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

Fa0/0 0 0/0 0 0/10 0 0

Se0/0/1 1 0/0 10 10/380 424 0


Verifying eigrp show ip eigrp topology l.jpg

Verifying EIGRP: show ip eigrp topology

R1#show ip eigrp topology

IP-EIGRP Topology Table for AS(100)/ID(192.168.1.101)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status

P 192.168.1.96/27, 1 successors, FD is 40512000

via Connected, Serial0/0/1

P 192.168.1.0/24, 1 successors, FD is 40512000

via Summary (40512000/0), Null0

P 172.16.0.0/16, 1 successors, FD is 28160

via Summary (28160/0), Null0

P 172.16.1.0/24, 1 successors, FD is 28160

via Connected, FastEthernet0/0

P 172.17.0.0/16, 1 successors, FD is 40514560

via 192.168.1.102 (40514560/28160), Serial0/0/1


Verifying eigrp show ip eigrp traffic l.jpg

Verifying EIGRP: show ip eigrp traffic

R1#show ip eigrp traffic

IP-EIGRP Traffic Statistics for AS 100

Hellos sent/received: 429/192

Updates sent/received: 4/4

Queries sent/received: 1/0

Replies sent/received: 0/1

Acks sent/received: 4/3

Input queue high water mark 1, 0 drops

SIA-Queries sent/received: 0/0

SIA-Replies sent/received: 0/0

Hello Process ID: 113

PDM Process ID: 73


Summary l.jpg

Summary

  • The configuration commands for basic EIGRP include:

    • router eigrp autonomous-system

    • network network-number [wildcard-mask]

    • bandwidth kilobits

  • The optional wildcard-mask parameter in the network command is an inverse mask used to determine how to interpret the network-number. A wildcard bit of 0 is a match and of 1 is “don’t care”.

  • Create and advertise a default route in an EIGRP autonomous system with the ip default-network network-number command.


  • Summary cont l.jpg

    Summary (cont.)

    • Use the show ip eigrp neighbors command to verify that the router recognizes its neighbors. Use the show ip route eigrp command to verify that the router recognizes routes from its neighbors.

    • Use the show ip protocols, show ip eigrp interfaces, show ip eigrp neighbors, show ip eigrp topology, and show ip eigrp traffic commands to verify EIGRP operations.

      • .


    Activity l.jpg

    Activity

    • Create a simple network using EIGRP as your routing protocol. These steps were discussed at the beginning of this module.

    • Verify your connections by running the show commands discussed in the module:

      • show ip protocols, show ip eigrp interfaces, show ip eigrp neighbors, show ip eigrp topology, and show ip eigrp traffic

    • Reflection: Are your routes displayed correctly in the routing table and identified as both directly connected or EIGRP?


    Self check l.jpg

    Self Check

    • Which show command verifies the router can recognize its neighbors?

    • Show ip route eigrp has what function?

    • What command establishes EIGRP as the routing protocol?

    • Identify the command to create and advertise a default route in an EIGRP autonomous system.


    Resources l.jpg

    Resources

    • http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009405c.shtml

    • http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_command_reference_chapter09186a00800ca5a9.html

    • http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080093f07.shtml

      • .


    Q and a l.jpg

    Q and A


  • Login