Hiseasnet data layer
This presentation is the property of its rightful owner.
Sponsored Links
1 / 54

HiSeasNet Data Layer PowerPoint PPT Presentation


  • 126 Views
  • Uploaded on
  • Presentation posted in: General

HiSeasNet Data Layer. What happens after the modems are talking through the satellite. Overview. Big picture The subnet collection Tunnels (GRE and IPsec ) Cisco router use in HiSeasNet ( not an IOS primer) Troubleshooting Advanced topics. The Big Picture. Legend:

Download Presentation

HiSeasNet Data Layer

An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -

Presentation Transcript


Hiseasnet data layer

HiSeasNet Data Layer

What happens after the modems are talking through the satellite

SIO Aug '09


Overview

Overview

  • Big picture

  • The subnet collection

  • Tunnels (GRE and IPsec)

  • Cisco router use in HiSeasNet(not an IOS primer)

  • Troubleshooting

  • Advanced topics

SIO Aug '09


Hiseasnet data layer

The Big Picture

Legend:

Purple is Satellite RF

Teal is Synchronous Serial

Orange is “foreign” IP space

Blue is local IP space

SIO Aug '09


Internet protocol fundamentals

Internet Protocol Fundamentals

Overview/review of concepts and how they apply to HiSeasNet

SIO Aug '09


Fundamental concepts

Fundamental concepts

  • The Internet Protocol (IP) is a set of rules that are followed when computers talk on the Internet, regardless of content.

  • IP is a layer of networking above modems where packets are relayed from one host to another until they get to their destination.

  • The IP layer is in “Layer 3” from the OSI model

  • The act of accepting a packet, looking at the header, and sending it closer to its destination is called routing and is performed by devices called routers.

  • Routers are like people:

    • Have many interfaces that handle information

    • Must think a little to determine where that info goes

  • Switches do brainless transactions on lower level packets (Layer 2), not routing.

SIO Aug '09


Typical network layout

Typical network layout

  • A packet must always go from ship to earth station to institution’s campus, then maybe Internet. All are physical places/interfaces, so…

  • At least 3 hops between subnets for a packet to take to get to the Internet on at least 3 routers (not switches, so we have to route in layer 3)

  • 3 IP subnets with routes in between those hops

    • HiSeasNet subnet on the ship (“DMZ”)

    • Ship/shore point-to-point (“Sat P2P”)

    • Earth station to home institution P2P (“Tunnel P2P”)

  • Not just a block of address assignments, but full-fledged, subnetted IP blocks that everyone in the subnet can agree on

SIO Aug '09


Ip subnet review

IP subnet review

  • IP Networks are like…Castles? Hamster habitats? Multi-track conferences? Carrier pigeons?

  • All IP networks are broken into “subnets” that define what addresses are considered local (who the neighbors are that can be reached with just a broadcast packet) to an address

  • Subnets have a “network” part and a “host” part.

  • The network part is defined by the subnet mask, notated by the number of bits (ie “/24”) from left to right that indicate the network (bits must be 1s).

  • The remaining bits are the host part or decimal value of octets (the 0s on the right).

  • For example:

    • Binary: 11111111 11111111 1111111100000000

    • Decimal: 255 255 255 0

SIO Aug '09


Ip subnet review cont d

IP subnet review cont’d

  • Each subnet must have a network address (the bottom most address in the block) and a broadcast address (the top most address in the block).

  • Remaining addresses in the block can be used for the hosts are in the network.

    • If those hosts want to talk outside that subnet (usually the case), there must be a router/gateway that ferries traffic to another network via another interface (serial, ethernet, etc.)

  • Subnets can occur only at certain places in an address range…where network addresses can be on bit divisions (depends on the size of the subnet)

  • RFC 1918 defines “private” subnet ranges to be 192.168.0.0/16, 172.16.0.0/12, and 10.0.0.0/8

SIO Aug '09


Class c ip subnet example

Class C IP subnet example

  • The typical “Class C” address block

    • Subnet mask of 255.255.255.0 (aka “/24”)

    • 11111111 11111111 1111111100000000

    • The last 8 host bits can vary giving 255 host addresses, but 2 (network and broadcast) are used in definition of subnet

    • Network address could be, for example, 192.168.0.0

    • Broadcast address is then 192.168.0.255

    • Usable addresses are 192.168.0.1 through 192.168.0.254

SIO Aug '09


Hiseasnet dmz subnet example

HiSeasNet DMZ subnet example

  • The typical “DMZ” block in HiSeasNet

    • Subnet mask of 255.255.255.240 (aka “/28”)

    • 11111111 11111111 11111111 11110000

    • The last 4 host bits can vary giving 16 host addresses, but 2 (network and broadcast addresses) are used in definition of subnet

    • Network address could be, for example, 172.16.1.16

    • Broadcast address is then 172.16.1.31

    • 14 usable addresses are 172.16.1.17 through 172.16.1.30

    • One address gets used by the router/gateway (usually the first one, 172.16.1.17 in this case), so really only 13 free addresses if you want to actually use HiSeasNet

SIO Aug '09


172 16 1 x 28 network possibilities

172.16.1.x/28 network possibilities

Confused about valid network address locations?

Use a table. Generate one by hand, or cheat and use an IP calculator.

I like the one at www.subnetmask.info

SIO Aug '09


172 16 1 x 29 network possibilities

172.16.1.x/29 network possibilities

Confused about valid network address locations?

Use a table. Generate one by hand, or cheat and use an IP calculator.

I like the one at www.subnetmask.info


Hiseasnet p2p subnet example

HiSeasNet P2P subnet example

  • The point-to-point “transit network”

    • Subnet mask of 255.255.255.252 (aka “/30”)

    • 11111111 11111111 11111111 11111100

    • The last 2 host bits can vary giving 4 host addresses, but 2 (network and broadcast addresses) are used in definition of subnet

    • Network address could be, for example, 192.168.68.4

    • Broadcast address is then 192.168.68.7

    • Usable addresses are 192.168.68.5 and 192.168.68.6

  • Allows us to route between two routers. They each get an address in the transit network and have a very small place where just they can talk to each other. Only room for two in this network. Each is the other’s gateway.

  • Used between ship and earth station

  • Used between earth station and home institution (wrapped in a tunnel)

SIO Aug '09


Hiseasnet subnet collection

HiSeasNet subnet collection

  • DMZ (subnet before firewall) is usually a /29 (5 usable addresses + router/gateway) or, better yet, a /28 subnet (13 usable addresses + router/gateway)

  • Sat P2P (between ship and earth station) is a /30 subnet

  • Tunnel P2P (between earth station and home institution) is a /30 subnet. Physical end points are internet hosts, logical addresses in tunnel are /30.

  • All three of these subnets come from home institution address space be it public or private. This is the key to making the ship appear as though it is part of the home institution network!

SIO Aug '09


Ip tunnels

IP Tunnels

Overview of GRE and IPsec and how those protocols apply to HiSeasNet

SIO Aug '09


Logical oceanus networking

Logical Oceanus networking

Random

Internet Host

Campus Net

128.128.x.x

Internet

Ship Net

128.128.252.33

SIO Aug '09


Actual oceanus networking

Actual Oceanus networking

Random

Internet Host

Internet

UCSD

Network

Ship Net

128.128.252.33

Campus Net

128.128.x.x

SIO Aug '09


What is an ip tunnel

What is an IP tunnel?

  • Analogy: Campus mail system

    • You send a internal memo to a colleague on another campus, addressed by building and/or mail code.

    • That message is bundled with other mail headed to that same campus destination and may travel in a USPS package.

    • When it arrives, your colleague gets the message without the intermediate USPS address on it and it appears to have simply come through your internal mail system.

  • Another analogy: Container shipment

    • May travel any way the forwarder wants, but your toolbox is still in the container when it gets to you in a foreign port.

  • A way of designating a collection of packets as part of a higher level virtual link (think wormhole)

  • Done through additional identifying headers on packets. Only endpoints of tunnels look inside packets.

  • The effect might be to:

    • Shorten a long path logically

    • Use foreign IP space in a network

    • Encrypt a link

    • Use other protocols (ie IPX) through IP

  • Examples include GRE, IPsec, L2TP, SSL, PPTP

SIO Aug '09


Gre tunnels

GRE tunnels

  • Generic Routing Encapsulation (GRE) standard defined in RFC 1701

  • Not TCP or UDP, but GRE…it rides on IP directly

  • Very simple, efficient, easy to configure, well supported in most firewalls and routers

  • Has no authentication or encryption by default…just for packaging strange packets in normal links

  • Configured as a simple tunnel interface on a Cisco

  • 24 byte header is added, so the new payload in a standard 1500 byte packet is now 1476 bytes.

    • Data coming into tunnel is 24 bytes too big and needs to be repackaged into smaller packets on shore.

    • Sometimes repackaging is done on the ship.

    • Either way, it is less efficient, adds to router CPU load, but works fine for slow links.

SIO Aug '09


Gre tunnel packets

GRE tunnel packets

The GRE header just indicates that it is carrying another packet of some sort that should be pulled out

IP Header

To: campus front door

From: ship front door

20 bytes

GRE Header

Protocol: IP

4 bytes

IP Header

To: Campus internal mail server

From: Ship internal mail server

Payload

(web page or something)

  • Normal Internet packet, as sent by computer on ship and seen inside campus

  • Addresses may be private

  • Added by Earth Station

  • Travels through Internet

  • Removed by Campus

SIO Aug '09


Ipsec tunnels

IPsec tunnels

  • “IP Security” standard defined in RFC 2401

  • Can act like a tunnel, but not necessarily. They are still valid IP packets that contain a complete IP packet in their payload.

  • Look like any other IP packet to routers

  • Implemented in a host networking stack or in a router or switch

  • Work may be offloaded to a hardware accelerator

  • Encrypts and authenticates between ends

  • Bridges a network, so no need for tunnel subnet

  • Trickier to configure on end points (filter-based)

  • Very standard and supported by many routers/firewalls now

SIO Aug '09


Tunnels in hiseasnet

Tunnels in HiSeasNet

  • Primarily used for shortening routes between earth station and institution and carrying that institutions IP addresses to the ship.

  • We prefer to use GRE tunnels for efficiency and ease of setup. They also separate traffic a little better with clear endpoints and no bridging.

  • Some institutions want security over the shore links (may be internal networks they are passing to the ship or no GRE support), so we have run IPsec links for them.

  • We can run IPsec over GRE, but we don’t in HiSeasNet anywhere

SIO Aug '09


Why bother with tunnels

Why bother with tunnels?

  • So why even bother with tunnels and subnets when a single IP address could be offered to a ship and set up NAT like a cable/DSL modem?

    • Not all ships want to NAT (especially bigger ones)

    • Would require a VPN on the ship to see private networks at the home institution

    • Doesn’t allow incoming connections very easily

    • UCSD networking will not offer permanent IP space to folks that don’t sign up for UCSD networking policies

SIO Aug '09


Cisco routers

Cisco Routers

Not an IOS review, but a larger picture of how Ciscos are used in HiSeasNet

SIO Aug '09


Why use cisco routers

Why use Cisco routers?

  • There is a lot going on at the IP layer

    • IP packets on the ships need to come off via synchronous serial satellite modems

    • IP packets at the earth station need to go to the home institution through the internet

  • We need IP routing to be done in a simple, efficient, reliable, hands-off way.

  • Cisco Systems, Inc. makes routers that support synchronous serial interfaces that work with Comtech modems. These routers can reliably handle all the strange shore routing that HiSeasNet does with minimal interaction.

  • Doesn’t have to be a Cisco box, but it is a known, solid solution that we have experience with.

SIO Aug '09


Cisco gear on shore

Cisco gear on shore

  • Ship and earth station require synchronous serial interfaces (WIC-1T or WIC-2T module board) and accompanying EIA-530 cable (CAB-530MT or CAB-SS-530MT depending on the serial board)

  • Earth station uses a pair of 2821 routers to handle more serial connections and more routing capacity. Should handle at least 5Mbit okay, but may need to upgrade for larger data rate events.

  • Earth station routers split for Ku-band vs. C-band

  • Home institutions terminate GRE or IPsec links on campus Cisco routers, switches, PIX firewalls, or even Netscreen firewalls…anything that supports tunnel protocol and is in the right network place on the campus network.

SIO Aug '09


Cisco out at sea

Cisco out at sea

  • Doesn’t take much at the ship…usually a fairly low end router (2600 series or newer 2800 series…usually a 2811) with a switch attached for the DMZ.

  • Basic ship Cisco config is a serial-to-ethernet box with minor routing and BGP announcement, plus a few other options on some ships.

  • Some ships handle more in their router configs (firewalling, failover interfaces for shore connections, links to SWAP, etc.). May require additional hardware modules.

  • Do you need a backup router? Possibly. Had a small Cisco die in the first month of HiSeasNet.

  • No one is terminating a HiSeasNet link at a Linux box, but it is theoretically possible.

SIO Aug '09


Cisco configuration

Cisco configuration

  • Routers keep a configuration file in NVRAM.

  • The initial loading of this file can be tricky

  • The configuration can be modified on the router, then saved to the startup file

  • Routers have user accounts and one or two layers of passwords

  • Routers are usually named “rv-shipname-gw”

  • Generally a configuration gets set and is left alone

    • Any fiddling you want to do is at your own risk

  • Firmware should be updated from time to time when security problems are announced.

  • HiSeasNet does not buy or maintain routers on ships, but we will help spec or configure where we can. Maintenance and upgrades are up to the ship.

SIO Aug '09


Basic ship config

interface Serial0/0/0

description "Serial line to satellite modem"

ip address 131.128.19.225 255.255.255.252

ip access-group 131 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip accounting output-packets

ip mtu 1400

no ip mroute-cache

no keepalive

fair-queue

no cdp enable

!

router bgp 64521

no synchronization

bgp log-neighbor-changes

network 131.128.0.0

redistribute connected

neighbor 131.128.19.226 remote-as 64521

neighbor 131.128.19.226 description ucsd-sdsc-roadnet-2611

neighbor 131.128.19.226 next-hop-self

neighbor 131.128.19.226 weight 30000

neighbor 131.128.19.226 distribute-list 28 out

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 Serial0/0/0 205

access-list 28 permit 131.128.217.224 0.0.0.31

access-list 131 permit ip any 131.128.217.224 0.0.0.31

access-list 131 permit ip any 131.128.19.224 0.0.0.3

access-list 131 deny ip any any log

Basic Ship Config

hostname rv-endeavor-gw

!

boot-start-marker

boot system flash:c2800nm-entservicesk9-mz.123-14.T7.bin

boot system flash:c2800nm-entservicesk9-mz.123-8.T9.bin

boot-end-marker

!

enable secret 5 $1$/nBM$yIEQ7v/blahblahblah

!

no ip dhcp use vrf connected

ip dhcp excluded-address 131.128.217.225 131.128.217.239

!

ip dhcp pool dmz

network 131.128.217.224 255.255.255.224

default-router 131.128.217.225

!

interface FastEthernet0/0

description Ships Network

ip address 131.128.217.225 255.255.255.224

no ip mroute-cache

duplex auto

speed auto

no cdp enable

SIO Aug '09


More cisco resources

More Cisco Resources

  • Internetwork Operating System (IOS) is the operating system Cisco routers run. It has a steep learning curve and lots of ways to get into trouble.

  • If you feel the need to fiddle with your router:

    • You are on your own.

    • Get a good reference

      • Cisco IOS Cookbook (ISBN: 0596527225)

      • Cisco: The Complete Reference (ISBN: 0072192801)

      • Anything else that seems fit to your interest/skill level

  • Really handy to know how to ping from router

  • It can be handy to know how to update firmware…but you will probably mess it up the first time or two.

SIO Aug '09


Troubleshooting

Troubleshooting

Ways to go about troubleshooting the data layer of HiSeasNet

SIO Aug '09


Problem solved

Problem solved!

  • The vast majority of routing problems are on shore

    • If you think you found a routing problem:

      • Contact HiSeasNet tech team and ask us to look into our routing on shore.

      • We probably know about it already, but sometimes our routers spontaneously hang or otherwise go quiet.

    • Sometimes the problem is an outage at the home institution somewhere between the internet and the tunnel to the earth station (often both)

  • Those problems on the ship may be:

    • Problems getting to the HiSeasNet router

    • Due to a router change after installation (accidental, intentional mistake, unplugged cable, reboot, etc.)

    • Cabling – unplugged ports are turned off by the router!

SIO Aug '09


Troubleshooting overview

Troubleshooting overview

  • The data link is only in question if:

    • The antenna is successfully tracking the bird AND

    • The modem is locked up happily and is transmitting and receiving AND

    • The router is powered up and all cable connections are correct (must have a link light on the ethernet port!)

  • …but no packets are going across the link

  • Important to note that packets must go in both directions for the data path to be established

  • Tools to use are “ping”, “traceroute”, sometimes “telnet”, and a packet sniffer if you know how

  • Clueless? Follow the packet path on the next slide, and tell us what you find (substitute your own addresses, though)

SIO Aug '09


Warning

Warning!

Not all ships have the same router setup. HiSeasNet flexibility causes some things to be different for how institutions connect in.

Know how you connect for best troubleshooting results.

SIO Aug '09


Oceanus example

Ship DMZ

.32 Net

.33 Gateway

.34-.46 Hosts

.47 Broadcast

Sat P2P

.212 Net

.213 Ship

.214 Shore

.215 Broadcast

Tunnel P2P

.216 Net

.217 WHOI

.218 SIO

.219 Broadcast

Oceanus example

SIO Aug '09


Example packet path from the ship

Example packet path from the ship

  • See diagram on the previous slide

  • Packet leaving workstation in Oceanus’s DMZ

    • Workstation in DMZ [/28] (128.128.252.34)

    • Into DMZ side of router (128.128.252.33)

    • Out serial side of ship router in Sat P2P [/30] (128.128.252.213)

    • In shore side of Sat P2P (128.128.252.214)

    • Out earth station side of tunnel [/30] (128.128.252.218)

      • Ignore Internet hops from 137.110.255.81 to 128.128.252.194 here…its all in a tunnel.

    • In institution side of tunnel (128.128.252.217)

    • Inside WHOI network…can stay here, go to Internet, or be ignored.

  • If packets go to Internet, they must return through reverse path (ie via WHOI)

SIO Aug '09


Hiseasnet data layer

Ping

  • The DMZ side (“inside”) of the router on the ship should respond to pings from the Internet if the network is public. That is the end-to-end test.

  • Pings should be about 800ms round-trip on a clean link. When the link is congested, it could be many thousands of ms.

  • Since congested links give lots of delay, use a ping command that handles a large delay. Windows ping command needs a -w (?) option, Cisco needs a “timeout” option.

  • If you ping from the router, be sure to set your source correctly if you have many interfaces.

  • Far ends of tunnels don’t ping so well.

SIO Aug '09


Ping testing

Ping testing

  • If end-to-end ping doesn’t work, try a closer destination, possibly from the router (if you are ok with IOS): “ping <dest> timeout 10 source serial0/0/0”

    • <dest> can be the other address in the Sat P2P network

    • Dest can be other hosts, possibly along the way, possibly on the Internet.

  • Looks like:

ucsd-sdsc-roadnet-gw#ping knorr timeout 4 source serial0/0/0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 128.128.252.209, timeout is 4 seconds:

Packet sent with a source address of 137.110.255.93

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 620/620/624 ms

Cisco ->

[email protected] 4> ping -s 128.128.252.17

PING 128.128.252.17: 56 data bytes

64 bytes from hsnkr.whoi.edu (128.128.252.17): icmp_seq=0. time=871. ms

64 bytes from hsnkr.whoi.edu (128.128.252.17): icmp_seq=1. time=795. ms

64 bytes from hsnkr.whoi.edu (128.128.252.17): icmp_seq=2. time=795. ms

^C

Unix ->

SIO Aug '09


Traceroute

Traceroute

  • Is supposed to show all hops between two hosts

  • Does not work well through NAT connections

  • May not work due to firewalling at campus

  • Source is important…sourcing from router’s ethernet interface is always helpful

  • Will take a very long time from the ship due to satellite delay

SIO Aug '09


Traceroute output from router

Traceroute output from router

rv-pelican-gw#traceroute 132.239.4.66 source 204.196.250.129

Type escape sequence to abort.

Tracing the route to 132.239.4.66

1 192.168.2.6 572 msec 572 msec 576 msec

2 192.168.2.1 628 msec 628 msec 628 msec

3 162.75.221.73 632 msec 632 msec 636 msec

4 64.200.121.22 640 msec 640 msec 644 msec

5 64.200.121.21 648 msec 648 msec 648 msec

6 64.200.210.53 644 msec 648 msec 648 msec

7 64.200.210.65 648 msec 648 msec 648 msec

8 64.200.249.130 656 msec 648 msec 648 msec

9 4.68.110.13 648 msec 648 msec 648 msec

10 4.68.19.126 656 msec 660 msec 648 msec

11 4.69.136.157 656 msec 656 msec 652 msec

12 4.69.132.77 684 msec 680 msec 684 msec

13 4.69.137.18 692 msec

4.69.137.22 740 msec

4.69.137.26 692 msec

14 4.68.20.4 680 msec

4.68.20.68 680 msec

4.68.20.132 716 msec

15 4.78.194.82 680 msec 680 msec 684 msec

16 137.164.24.210 684 msec 684 msec 688 msec

17 132.239.255.145 712 msec 684 msec 684 msec

18 132.239.4.66 684 msec 684 msec 684 msec

  • Traceroute to generic host on UCSD campus from Pelican’s router

  • Looks like:

    • 1 is shore side of Sat P2P

    • 2 is institution side of tunnel

    • 3 is inside institution

    • 4 to15 is Internet

    • 16 is UCSD front door

    • 17 is UCSD campus

    • 18 is end node

SIO Aug '09


Packet sniffing

Packet sniffing

  • Probably overkill for simple problems…most HiSeasNet issues are just about connectivity

  • Looks at what packets are flowing across an interface

  • Great tool for seeing what is really going on, but may not be easy to use

  • Often more than you want to know

  • Not standard on all computers

  • Check out snoop, tcpdump, WireShark (formerly Ethereal), snort, or something else

  • Traces can be very helpful for subtle problems (like MTU issues, worms, link saturation, etc.)

SIO Aug '09


Other tools that might help

Other tools that might help

  • mtr

    • Like traceroute, but Seems to get through some firewalls and make more sense

    • http://www.bitwizard.nl/mtr/

  • Long-term network monitoring from shore or ship

    • MRTG or Cricket

    • Smokeping

    • Nagios

    • Intermapper

SIO Aug '09


Advanced topics

Advanced topics

A few extra things to think about after it is all working

Starts with answers, ends with questions

SIO Aug '09


Common carrier routing

Common carrier routing

  • We automatically share the shore-to-ship link via Cisco fair queuing

  • Allows for bursting when other ships are quiet

  • All shore-to-ship routes for a satellite go through one transmitting modem

  • Ship routers receive all traffic for all ships in that footprint on the serial port, but filter out just theirs

  • Modems on shore are largely receive-only

  • Shore routing is a bit tricky to split traffic in on one modem, but sent on another

SIO Aug '09


The mtu problem

The MTU problem

  • Maximum Transmission Unit (MTU) is the largest amount of data that can be sent in one bundle through an interface

    • Default for Ethernet is 1500

    • Smaller if tunnel overhead is added

  • Bigger MTU means fewer headers and more efficiency. Smaller MTU means less efficient.

  • All routers along the way must agree on this or be willing to adjust to meet something else

  • Hard to agree since many routers block agreement protocols for security reasons.

  • In HiSeasNet, we want smaller packets for better VoIP, but shared outroute causes problems. Every institution chokes on different values.

SIO Aug '09


Quality of service qos

Quality of Service (QoS)

  • Is it a delay problem or a jitter problem?

  • Wouldn’t it be great to increase the priority of certain packets?

    • Yes: VoIP connections might be smoother, important traffic could be faster, etc.

    • No: It really doesn’t do much good if the packets are small

  • We do this for VoIP boxes, and have found that such small packets get stuck behind large ones if they are just a little too late.

    • (If you setup VoIP and want an IP included here, let us know and we will add it to the list)

  • Solution: Smaller MTUs…but not so good in HiSeasNet as discussed earlier

SIO Aug '09


Accelerator capabilities

Accelerator capabilities

  • Goes in-line between router and DMZ

  • Creates a routing tunnel between ship accelerator and one at the earth station

  • Invisible to campus, Internet, and DMZ

  • Over that tunnel, all packets can be inspected and:

    • Compressed if not already compressed

    • Cached so duplicate packets don’t get sent completely multiple times

    • Fragmented so that all packets are broken and small real-time data can flow better

    • Given dedicated amounts (minimums or maximums) of bandwidth per application (QoS)

  • Some also do web and DNS caching for ships that don’t already do this

SIO Aug '09


Accelerators in hiseasnet

Accelerators in HiSeasNet

  • We have been testing on Revelle and Atlantis in 2009.

  • Improvements of shore-to-ship bandwidth about 20% and 70% ship-to-shore. Depends on traffic patterns.

  • Funded for fleet roll out soon

    • Will get things setup on shore, and have boxes shipped to institutions for plug-in on ships.

    • Should be racking, cabling, and setting IP address…rest is configured from shore.

  • Work with us over time to get it tuned to your ship needs

SIO Aug '09


Services offered

Services offered

  • What services are you willing to offer your users?

    • VoIP (Skype, Vonage, campus PBX, etc.), instant messaging, video conferencing

    • Web, FTP, mail, rsync

    • SSH, VPNs

    • Streaming data

    • Software updates, license key servers, etc.

  • How will these services be maintained and advertised to the user?

  • Will they fit into your network layout?

SIO Aug '09


Security

Security

  • This comes in many flavors and may include:

    • Privacy of communications

      • Data can be encrypted (ship-to-shore? shore-to-shore?)

    • Permission to use network services

      • Are you in a public or private network?

      • Access to resources can be restricted

    • Viruses and spam getting onto the ship

    • Wasting bandwidth (denial of service)

  • What threats are you afraid of?

  • What risks are you willing to take?

  • HiSeasNet can be flexible, but define your policy first, then look for the technical solution

SIO Aug '09


Policy

Policy

  • Who gets access to HiSeasNet?

  • What priorities are there for HiSeasNet use?

  • Where can HiSeasNet be used on a ship?

  • What sort of guest access is available?

  • How is bandwidth used efficiently?

  • Can shore staff change configurations on the ship?

  • Can the ship be contacted from shore, or should connections only be one-way?

  • What VoIP services are offered and to who?

  • Discussion about who is doing what in the fleet?

SIO Aug '09


Earth station network

Earth station network

SIO Aug '09


Monitoring

Monitoring

  • How does one monitor a network where links are expected to go out?

  • How does one monitor a network with status that is not under his control or knowledge?

  • How does one monitor through firewalls into private IP space?

  • Links go down, stations go offline, and sirens do not go off at the earth station. It is hard to tell what is a problem and what is normal behavior.

SIO Aug '09


Hiseasnet data layer

The Big Picture

Legend:

Purple is Satellite RF

Teal is Synchronous Serial

Orange is “foreign” IP space

Blue is local IP space

SIO Aug '09


  • Login