Asnt labwork
Download
1 / 44

asnt labwork - PowerPoint PPT Presentation


  • 293 Views
  • Uploaded on

ASNT Labwork. M Clements. Introduction. Networking scenario Network proposal Network design Network implementation Network testing. asnt.com network. asnt are a young web-based company selling games They have offices in 4 major cities worldwide

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

PowerPoint Slideshow about 'asnt labwork' - johana


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript
Asnt labwork l.jpg

ASNT Labwork

M Clements

ASNT Network Design


Introduction l.jpg
Introduction

  • Networking scenario

  • Network proposal

  • Network design

  • Network implementation

  • Network testing

ASNT Network Design


Asnt com network l.jpg
asnt.com network

  • asnt are a young web-based company selling games

  • They have offices in 4 major cities worldwide

  • The original network design focussed the network segments and their functions geographically

  • To avoid having a single point of failure in case of terrorism, cyber attack etc, they have decided to redesign their network

  • They have been told that a VLAN solution would allow the 4 departments to be distributed globally

ASNT Network Design



Current network l.jpg
Current network

  • The current network has 4 centres in London, Paris, Rome, New York

  • The server farm is in London

  • E-commerce is in New York

  • Research is in Paris

  • Marketing is in Rome

  • If any of the 4 centres were to be targeted, the company would suffer badly

ASNT Network Design


Server farm london l.jpg
Server farm - London

  • Currently has these 4 servers

  • Public webserver

  • Intranet webserver

    • Both webservers have custom pages

  • DNS server

    • Contains DNS details for both webservers

  • TFTP server

ASNT Network Design


Routing l.jpg
Routing

  • This is currently RIP version 2

  • Routers are fully meshed

  • The company has been told that migration to OSPF would be a good idea

ASNT Network Design


Original design parameters l.jpg
Original Design Parameters

  • asnt has the network range 195.10.8.0 /22

  • All departments have a /24 address range

  • Private addressing is used on all serial links

  • Telnet is set up on all routers

  • DHCP server exists on all routers for their attached LAN

ASNT Network Design


Proposal for new network l.jpg
Proposal for new network

  • Servers are to be distributed globally

  • Staff and PCs from Paris, Rome and New York are to be distributed to the 4 worldwide locations

  • The 3 departments and the servers are to exist on separate VLANs

  • Network is to be upgraded to OSPF

ASNT Network Design


First step model original network l.jpg
First Step – Model Original Network

  • Use A3 paper to design the current network

  • Include all network and interface details

  • Decide where the DCE and DTE will reside for each serial link

  • Decide on clock rate for serial links

  • Include all names as per slide 4

  • There is no need to name the PCs on the LANs

  • Decide on addressing for the servers – these will not use DHCP

ASNT Network Design


Serial link addressing l.jpg
Serial Link Addressing

  • Use RFC 1918 addresses

  • All serial links need /30 addresses

  • It is good practice to use a set of contiguous addresses

  • Mark these clearly on your diagram

ASNT Network Design


Fastethernet lan interface addressing l.jpg
FastEthernet (LAN) Interface Addressing

  • Create 4 /24 networks from the network range 195.10.8.0 /22

  • Decide which of the 4 city routers will have each of the address ranges

  • Choose an appropriate address for the FastEthernet interface for each router

  • Mark these addresses on your diagram

ASNT Network Design


Completing the design l.jpg
Completing the design

Do not continue until your paper design is complete

ASNT Network Design


Open packet tracer 5 x l.jpg
Open Packet Tracer 5.x

You must use Packet tracer 5.x for this network design

Please ask if you need a copy

ASNT Network Design


Implementation steps l.jpg
Implementation Steps

  • Use 4 x 2811 routers

  • You will need to add at least 3 serial interfaces to each router

  • It may be easier to create one router with the serial interfaces then use copy and paste to duplicate it 3 times

  • You decide . . . . .

  • Do not add any other hardware yet

ASNT Network Design


Naming the routers l.jpg
Naming the routers

  • Give each router the name that you have decided upon

    Router(config)#hostname Rome

    Rome(config)#

  • Make sure the the router’s name also appears on the PT4 working area – this is in the ‘Config’ tab of the router

ASNT Network Design


Add serial interface links l.jpg
Add Serial Interface Links

  • Use the ‘Connections’ feature in Packet Tracer

  • Create the serial links as you have indicated in your diagram

  • Be sure to put the DCE interfaces where your diagram has shown

  • Make a fully meshed network

  • Only begin to add addresses once you have finished placing the serial links

ASNT Network Design


Serial addressing l.jpg
Serial Addressing

  • Make sure that you know the names of all serial interfaces and that they are the same as you have shown on your diagram

    Router#show ip interface brief is the command to show the interface names

  • Add the 12 serial interface addresses

  • Remember to turn the interfaces on

    Router(config-if)#no shutdown

ASNT Network Design


Serial link verification l.jpg
Serial link verification

  • When all serial links are numbered correctly the indicators will turn from red to green

If any links remain red, check your addressing and link assignments

ASNT Network Design


Check connectivity l.jpg
Check connectivity

Router#sh ip int brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES manual administratively down down

FastEthernet0/1 unassigned YES manual administratively down down

Serial0/0/0 1.1.1.2 YES manual up up

Serial0/0/1 1.2.2.1 YES manual up up

Etc. etc.

  • All 3 serial interfaces should appear as Status up, Protocol up

ASNT Network Design


Save your work l.jpg
SAVE YOUR WORK!

  • Remember to save your configurations on each router and also the entire network within Packet Tracer

  • I will have no sympathy if you do not save and your PC crashes

ASNT Network Design


Slide22 l.jpg

Do not continue until you have established connectivity across all serial links

ASNT Network Design


Adding lan interface addresses l.jpg
Adding LAN interface addresses across all serial links

  • Use the fa0/0 interface on each router

  • Add the addresses that you have already created on your diagram

  • Remember to turn the interfaces on

  • Check using Rome#sh ip int brief

  • They should both appear as up, up

  • Troubleshoot as necessary

ASNT Network Design


Routing protocol l.jpg
Routing Protocol across all serial links

  • For each router, add RIP version 2 and enter all connected networks – not interfaces

    Rome#conf t

    Enter configuration commands, one per line. End with CNTL/Z.

    Rome(config)#router rip

    Rome(config-router)#version 2

    Rome(config-router)#network 172.16.10.0

    Rome(config-router)#network 192.168.1.0

    Rome(config-router)#etc etc

ASNT Network Design


Verify routing l.jpg
Verify routing across all serial links

Rome#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B – BGP, D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area, N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2, E1 - OSPF external type 1, E2 - OSPF external type 2, E – EGP, i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

  • Below here you should be able to see all RIP reported networks – troubleshoot if they do not appear

ASNT Network Design


Slide26 l.jpg

Do not continue until you have established that the routing is working properly

ASNT Network Design


Add dhcp to each router l.jpg
Add DHCP to each router is working properly

  • Decide on a name for the 4 address pools that DHCP will use to allocate addresses for each LAN

    Use YOUR OWN IP details here:

    Rome(config)#ip dhcp pool marketing

    Rome(dhcp-config)#default-router 1.2.3.4

    Rome(dhcp-config)#dns-server 4.5.6.7

    Rome(dhcp-config)#network 1.2.3.0 255.255.255.0

    Rome(dhcp-config)#exit

ASNT Network Design


Save your work28 l.jpg
SAVE YOUR WORK! is working properly

  • Remember to save your configurations on each router and also the entire network within Packet Tracer

  • I will have no sympathy if you do not save and your PC crashes

ASNT Network Design


Add 2960 switches l.jpg
Add 2960 switches is working properly

  • Add 4 x 2960 switches

  • Name them appropriately

  • Connect using the ‘Copper Straight-through’

  • Be sure to connect to the fa0/0 interface of the router

  • Connect to the fa0/24 of each switch

ASNT Network Design


Add pcs to switches l.jpg
Add PCs to switches is working properly

  • Add 6 PCs to each switch except for the London switch

  • Add only one PC to the London switch

  • Connect the PCs to the switches using the lowest available port

  • Use the ‘Copper Straight-through’ connector

  • Enable DHCP for each PC in the Desktop, IP Configuration window

  • Wait until all 4 fields are filled

  • Troubleshoot if DHCP fails

ASNT Network Design


Save your work31 l.jpg
SAVE YOUR WORK! is working properly

  • Remember to save your configurations on each router and also the entire network within Packet Tracer

  • I will have no sympathy if you do not save and your PC crashes

ASNT Network Design


Slide32 l.jpg

Do not continue until you have established that DHCP is working properly

ASNT Network Design


Adding servers l.jpg
Adding Servers working properly

  • Add 4 servers (server-PT) to the London LAN

  • Attach to the switch with the ‘Copper Straight-through’ connector

  • Name the servers as to their individual functions – see slide 4

  • Enter the configuration of each router and turn off all services EXCEPT the one required (name of server)

  • Add your IP addresses and default gateway to each server

ASNT Network Design


Configuring web servers l.jpg
Configuring Web Servers working properly

  • In the HTTP configuration of the intranet and public webservers, change the HTML a little so it is easy to see where you have connected

  • The webserver will accept simple text only – no hyperlinks or diagrams

ASNT Network Design


Configuring dns server l.jpg
Configuring DNS server working properly

  • In the DNS server, add two URLs to the DNS listing so that the URLs are mapped to the correct IP addresses for the two web servers

ASNT Network Design


Network testing l.jpg
Network Testing working properly

  • Ensure that each PC can reach the two webservers via their url

  • Use Desktop, Web browser

  • If this fails, try the IP address instead

  • If this fails, try to ping your local router interface

  • Troubleshoot as necessary

ASNT Network Design


Adding value to your network l.jpg
Adding value to your network working properly

  • Map host names to IP addresses for each router

    ip host Rome 1.2.3.4 192.168.1.2 172.16.22.5

  • The ip host will accept up to 3 addresses for each router

  • You will need to add 3 router hostnames to each router

ASNT Network Design


Setup telnet l.jpg
Setup TELNET working properly

  • Use the following for each router

    Router(config)#line vty 0 4

    Router(config-line)#password cisco

    Router(config-line)#login

    Router(config-line)#exit

ASNT Network Design


Setup passwords l.jpg
Setup passwords working properly

  • Use the following to setup an encrypted password of class on each router

    Router(config)#enable secret class

  • Be sure to save your configuration on each router often

ASNT Network Design


Save your work40 l.jpg
SAVE YOUR WORK! working properly

  • Remember to save your configurations on each router and also the entire network within Packet Tracer

  • I will have no sympathy if you do not save and your PC crashes

ASNT Network Design


Network testing41 l.jpg
Network testing working properly

  • Check that you can ping all points of the network from PCs

  • Carry out tracert from the PCs to webservers

  • Try to establish a TELNET session to another router by typing its name only at the Priv Exec prompt

ASNT Network Design


Troubleshooting l.jpg
Troubleshooting working properly

  • If you have a failure of any of these tasks, try to work out a plan to diagnose the problem

  • Ask your lecturer to help if you have no luck

  • Remember that most problems will be due to badly typed commands, IP addresses and other parameters

  • This means YOU MUST BE ACCURATE

ASNT Network Design


Upgrade analysis l.jpg
Upgrade Analysis working properly

  • Now you should begin to analyse your network for the planned upgrade

  • Draw up a plan for VLANs and where the users and servers will eventually be

  • Consider the addressing issues involved with setting up VLANs

  • Be sure to bring your diagrams and thoughts next week

ASNT Network Design


Summary l.jpg
Summary working properly

  • You have created the start network

  • You have a careful design on paper

  • You have added services to the network

  • You have tested the network

  • You have begun troubleshooting

  • You have started thinking about the network upgrade

ASNT Network Design