implementing voice gateways
Download
Skip this Video
Download Presentation
Implementing Voice Gateways

Loading in 2 Seconds...

play fullscreen
1 / 20

Implementing Voice Gateways - PowerPoint PPT Presentation


  • 123 Views
  • Uploaded on

Implementing Voice Gateways. Lecture 3. Voice Gateways. Any device with one or more TDM PSTN interfaces on them TDM - Time Division Multiplexing (i.e. traditional telephony) PSTN - Public Switched Telephone Network To be really useful, gateways also need an IP interface on them

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

PowerPoint Slideshow about ' Implementing Voice Gateways' - cherokee-stewart


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript
voice gateways
Voice Gateways
  • Any device with one or more TDM PSTN interfaces on them
  • TDM - Time Division Multiplexing (i.e. traditional telephony)
  • PSTN - Public Switched Telephone Network
  • To be really useful, gateways also need an IP interface on them
  • Many vendors, but we will look at Cisco IOS based voice gateways
  • Both analogue and digital interfaces, we’ll look at the more common ones
interface types digital
Interface Types - Digital
  • ISDN primary rate circuits
  • E1 (primarily used in Europe) 2 Mbit/s bearer
  • 32x 64kbit/s channels. 30 for voice, 1 for signalling (timeslot 16), 1 framing
  • Common interfaces for ISP dial-in, PBX to carrier trunks, etc.
  • DSL – ADSL and HDSL
  • Wireless – 802.11x
interface types digital1
Interface Types - Digital
  • Basic Rate ISDN
  • 144kbit/s bearer
  • 2x 64kbit/s channels + 1x 16kbit/s signalling channel
  • 2B + D
  • B channels = 64kbit/s voice/data channels
  • D channel(s) = signalling data channels
interface types analogue
Interface Types - Analogue
  • Only really two types:
  • FXO interface - plugs into your Service provider (Exchange or company PBX)
  • FXS interface - plugs into a telephone. e.g. ATAs
  • Uses analogue signalling, limited to one DDI per line
  • Signalling is generally more ambiguous and harder to work with than digital signalling
ios voice configuration
IOS Voice Configuration
  • For VoIP we need to configure:
  • voice-port - the voice ‘interface’
  • FXS / FXO - e.g. voice-port 1/0/0
  • E1/T1 signallingchannel - e.g. voice-port 1/0:D
  • dial-peer - tells the gateway how to connect voice ports to VoIP call legs
  • For E1/T1 links we also need to configure the physical bearer controller E1 / controller T1
  • interface serial 0:15 (the signalling timeslot for an E1)
fxs fxo configuration
FXS / FXO Configuration

! Some useful settings

!

voice-port 1/0/0

no comfort-noise ! needs ‘no vad’ on VoIP dial-peer

cptone GB

timeouts interdigit 3 ! timeout when gathering dialled digits

description Analog phone line

!

! Or, if you’re just having a play, the defaults will work:

!

voice-port 1/0/1

!

dial peers
Dial Peers
  • Basic building block on Cisco voice gateways, the dial-peer
  • All calls consists of at least two call legs:
  • Originating device to originating gateway (POTS)
  • Originating gateway to IP network (VoIP)
  • ...and/or
  • IP network to destination gateway
  • Destination gateway to destination device
1 two analogue phones 1 gateway
(1) Two Analogue Phones – 1 Gateway

Voice Gateway Router Configuration File

voice-port 1/0/0

!

voice-port 1/0/1

!

!

dial-peer voice 1 pots

destination-pattern 5551234

port 1/0/0

!

dial-peer voice 2 pots

destination-pattern 5555678

port 1/0/1

2 two analogue phones 2 gateways
(2) Two Analogue phones – 2 Gateways

Voice Gateway Router 1 Configuration File

voice-port 1/0/0

!

dial-peer voice 1 pots

destination-pattern 5551234

port 1/0/0

!

dial-peer voice 10 voip

destination-pattern 5555678

session target ipv4:10.5.6.7

codec g711ulaw

Voice Gateway Router 2 Configuration File

voice-port 1/0/0

!

dial-peer voice 2 pots

destination-pattern 5555678

port 1/0/0

!

dial-peer voice 20 voip

destination-pattern 5551234

session target ipv4:10.2.3.4

codec g711ulaw

3 each connected to their own voice gateway routers using the g 729 codec as 1 st choice
(3) Each Connected to Their Own Voice Gateway Routers Using the G.729 Codec as 1st choice

Voice Gateway Router 1 Configuration File

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

!

voice-port 1/0/0

!

voice-port 1/0/1

!

!

dial-peer voice 1 pots

destination-pattern 5551234

port 1/0/0

!

dial-peer voice 2 voip

destination-pattern 5555678

voice-class codec 1

session target ipv4:10.5.6.7

Voice Gateway Router 2 Configuration File

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

!

voice-port 1/0/0

!

voice-port 1/0/1

!

!

dial-peer voice 1 pots

destination-pattern 5555678

port 1/0/0

!

dial-peer voice 2 voip

destination-pattern 5551234

voice-class codec 1

session target ipv4:10.2.3.4

4 analogue phone and an ip phone connected over an ip network
(4) Analogue Phone and an IP Phone Connected over an IP Network

Voice Gateway Router 1 Configuration File

voice-port 1/0/0

!

dial-peer voice 1 pots

destination-pattern 5551234

port 1/0/0

!

dial-peer voice 2 voip

destination-pattern 5555678

session target ipv4:10.5.6.7

Voice Gateway Router 2 Configuration File

voice-port 1/0/0

!

dial-peer voice 1 pots

destination-pattern 5555678

port 1/0/0

!

dial-peer voice 2 voip

destination-pattern 5551234

session target ipv4:10.2.3.4

5 two ip phones connected over a frame relay network
(5) Two IP Phones Connected over a Frame Relay Network

Voice Gateway Router 1 Configuration File

interface Serial0/0

ip address 10.5.6.6 255.0.0.0

encapsulation frame-relay

Voice Gateway Router 2 Configuration File

interface Serial0/0

ip address 10.5.6.7 255.0.0.0

encapsulation frame-relay

clock rate 2000000

dial-peer voice 1 pots

destination-pattern 5551234

port 1/0/0

dial-peer voice 1000 voip

preference 1

destination-pattern 5555678

session target ipv4:10.5.6.7

dial-peer voice 1 pots

destination-pattern 5555678

port 1/0/0

dial-peer voice 2000 voip

preference 1

destination-pattern 5551234

session target ipv4:10.5.6.6

slide15

Configuration for Router 1

translation-rule 21

Rule 1 ^2 5552

translation-rule 11

Rule 1 ^5551 1

interface FastEthernet0/0

ip address 10.1.1.2 255.255.255.0

voice-port 1/0/0

translate called 11

dial-peer voice 1 pots

destination-pattern 1000

port 1/1/0

dial-peer voice 2000 voip

preference 1

destination-pattern 2000

session target ipv4:10.1.1.3

dial-peer voice 20 pots

preference 2

destination-pattern 2000

translate-outgoing called 21

port 1/0/0

forward-digits all

slide16

Configuration for Router 2

translation-rule 11

Rule 1 ^1 5551

translation-rule 21

Rule 1 ^5552 2

interface Ethernet0/0

ip address 10.1.1.3 255.255.255.0

voice-port 1/1/0

translate called 21

!

dial-peer voice 1 pots

destination-pattern 2000

port 1/0/0

!

dial-peer voice 1000 voip

preference 1

destination-pattern 1000

session target ipv4:10.1.1.2

!

dial-peer voice 10 pots

preference 2

destination-pattern 1000

translate-outgoing called 11

port 1/1/0

forward-digits all

digit stripping
Digit stripping
  • We want to dial 5554329

#dial-peer voice 3 pots

#destination-pattern 555....

#port 2/0/0

  • The default behaviour for the router is to strip the first three digits from the number because these are the numbers matched in the dial-peer and send 4329 forward
digit stripping ctd
Digit stripping ctd..
  • We want to send all digits to 5554329

#dial-peer voice 3 pots

#destination-pattern 555....

#no digit-strip

#port 2/0/0

prefixes
Prefixes
  • The prefix dial-peer command adds digits to the beginning of the dial string

#dial-peer voice 3 pots

#destination-pattern 1904678

#prefix 8

#port 1/0/1

  • The peer at other end might require a 5 digit number so the number 84678 is forwarded
number expansion
Number Expansion
  • People find it easier to just remember the 3 digit extension number e.g.363

ExtDest-PatternNum Expand Command

363 719155363 num-exp 00353 719155363

ad