网络通信实验
This presentation is the property of its rightful owner.
Sponsored Links
1 / 72

网络通信实验 PowerPoint PPT Presentation


  • 60 Views
  • Uploaded on
  • Presentation posted in: General

网络通信实验. 实验 2. 课程内容. VLAN 基础配置. 交换机端口配置. VLAN 间的路由. 流量控制. 当通过交换机一个端口的流量过大,超过了它的处理能力时,就会发生端口阻塞。流量控制的作用是防止在出现阻塞的情况下丢帧。 在半双工方式下,流量控制是通过后退压力( backpressure )技术实现的,模拟产生碰撞,使得信息源降低发送速度。 在全双工方式下流量控制一般遵循 IEEE 802.3x 标准。. 假装有冲突了,这样你 就不会发个不停了!. backpressure. 半双工流量控制. 全双工流量控制.

Download Presentation

网络通信实验

An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -

Presentation Transcript


5985845

网络通信实验

实验2


5985845

课程内容

VLAN基础配置

交换机端口配置

VLAN间的路由


5985845

流量控制

  • 当通过交换机一个端口的流量过大,超过了它的处理能力时,就会发生端口阻塞。流量控制的作用是防止在出现阻塞的情况下丢帧。

  • 在半双工方式下,流量控制是通过后退压力(backpressure)技术实现的,模拟产生碰撞,使得信息源降低发送速度。

  • 在全双工方式下流量控制一般遵循IEEE 802.3x标准。


5985845

假装有冲突了,这样你

就不会发个不停了!

backpressure

半双工流量控制


5985845

全双工流量控制

  • IEEE802.3x标准定义在全双工环境中实现流量控制的方法——交换机产生一个PAUSE帧,使用保留的组播地址:01-80-C2-00-00-01,发送给正在发送的站,发送站接收到该帧后,就会暂停或停止发送。

  • PAUSE帧利用保留的组播地址,它不会被网桥和交换机所转发,PAUSE帧不会产生附加信息量。


5985845

全双工流量控制

  • PAUSE功能的应用场合:

    • 一对终端(简单的两点网络)

    • 一个交换机和一个终端

    • 交换机和交换机之间的链路

  • PAUSE功能不解决下列问题:

    • 稳定状态的网络拥塞

    • 端到端流量控制

    • 比简单“停—启”更复杂的机制


5985845

端口汇聚定义

  • 端口汇聚 (Link Aggregation),也称为端口捆绑、端口聚集或链路聚集。

  • 为交换机提供了端口捆绑的技术,允许两个交换机之间通过两个或多个端口并行连接同时传输数据以提供更高的带宽。

  • 端口汇聚是目前许多交换机支持的一个高级特性。


5985845

端口汇聚应用

Server D

Server B

Server C

2*1000Mb/s

2*100Mb/s

1000Mb/s

2*1000Mb/s

Server A

2*100Mb/s

2*100Mb/s

4*100Mb/s

100Mb/s

100Mb/s

100Mb/s

100Mb/s

10Mb/s

10Mb/s

10Mb/s

10Mb/s


5985845

配置端口工作速率

  • Quidway S3526/S3026以太网交换机具有24个10/100Base-T端口,端口的默认工作速率为10/100M自协商。

  • 端口速率的配置命令为:

    • speed { 10 | 100 | auto}

    • undo speed

    • 用于恢复接口速率缺省值


5985845

配置端口双工工作状态

  • duplex {half | full |Auto} (半双工/全双工/速率自动协商)

  • undo duplex

  • 缺省值:Auto


5985845

配置端口流控

  • flow-control 开启端口流控

  • undo flow-control 关闭端口流控

  • 系统缺省值为Disable


Mdi mdix

配置端口MDI/MDIX状态

  • mdi {across | auto | normal} (交叉/自动识别/普通)

  • 缺省值:Auto


5985845

配置端口汇聚

  • 汇聚

    • link-aggregation port_num1 to port_num2 { ingress| both }

  • 清除端口汇聚

    • undo link-aggregation {master_port_num | all}


5985845

查看当前端口汇聚配置

  • display link-aggregation [master_port_num]

    显示所有汇聚接口的信息。

  • 如果不指定master port,显示所有的汇聚端口。

  • 需要注意的是:物理连接上的两端设备均要设置。


5985845

显示端口配置信息

  • display interface [port_num]

    • port_num:单个以太网端口,表示方式为port_num={ interface_type interface_number | interface_name }


5985845

课程内容

VLAN基础配置

交换机端口配置

VLAN间的路由


5985845

通过VLAN划分广播域

广播域1

VLAN 10

广播域3

VLAN 30

广播域2

VLAN 20

工程部

财务部

市场部


5985845

基于端口的VLAN

VLAN表

以太网交换机

端口

所属VLAN

Port 1

VLAN 5

Port 1

Port 2

Port 7

Port 10

Port 2

VLAN 10

……

……

Port 7

VLAN 5

……

……

Port 10

VLAN 10

主机A

主机B

主机C

主机D


Mac vlan

以太网交换机

VLAN表

MAC地址

所属VLAN

VLAN 5

VLAN 10

MAC A

MAC B

VLAN 5

MAC D

VLAN 10

MAC C

主机A

主机B

主机C

主机D

MAC A

MAC B

MAC C

MAC D

基于MAC地址的VLAN


5985845

以太网交换机

VLAN表

协议类型

所属VLAN

IPX协议

VLAN 5

IP协议

VLAN 10

……

……

主机A

主机B

主机C

主机D

使用IPX协议

运行IP协议

使用IPX协议

运行IP协议

基于协议的VLAN


5985845

以太网交换机

VLAN表

所属VLAN

VLAN 5

IP网络

VLAN 10

IP 1.1.1.1/24

IP 1.1.2.1/24

……

……

主机A

主机B

主机C

主机D

1.1.2.88

1.1.1.8

1.1.2.99

1.1.1.5

基于子网的VLAN


Ieee802 1q

IEEE802.1Q概述


5985845

Data

Data

CRC

CRC

标准以太网帧

DA

DA

SA

SA

tag

Type

Type

TCI

CFI

VLAN ID

带有IEEE802.1Q标记的以太网帧

TPID

Priority

VLAN的帧格式


Access link trunk link

干道链路

接入链路

Access Link和Trunk Link


5985845

帧在网络通信中的变化

VLAN 2

VLAN 1

带有VLAN 1标签的以太网帧

不带VLAN标签的

以太网帧

带有VLAN 2标签的以太网帧

VLAN 2

VLAN 1


Trunk vlan

Trunk和VLAN

VLAN 1

Trunk Link

VLAN 5

广播报文发送

VLAN 1

VLAN 5

VLAN 2

VLAN 1

VLAN 3

VLAN 2

VLAN 5

VLAN 2


Vlan vlan

进入VLAN视图及创建/剔除VLAN

  • 用途:

    进入vlan视图,如果指定的vlan没有创建则先创建它

  • [undo] vlan vlan_id

    undo vlan :剔除已创建的vlan


5985845

给VLAN指定端口

  • 用途:

    给指定vlan增加/剔除以太网接口

  • 命令格式:

    • port interface_list

    • undo port interface_list

  • 参数含义:

    interface_list:由端口类型和端口序号组成;端口序号由槽号和端口号的二元组组成,如果是百兆口,则槽号为0,端口号取值范围为1~24;如果是千兆口,则槽号为1或2,端口号取值为1。


5985845

给端口指定VLAN

  • 用途:

    给指定vlan增加/剔除以太网接口

  • 命令格式:

    • port access vlan vlan-id

    • Undo port access vlan vlan-id

  • 参数说明:

    vlan-id:VLAN接口的ID,取值范围为1~4000。


Vlan trunk

设置/取消端口为VLAN Trunk

  • 用途:

    打开/关闭以太网接口的vlan trunk功能,基于IEEE 802.1Q标准

  • 命令格式:

    • port link-type { access | trunk | hybrid }

  • 缺省值:缺省为关闭vlan trunk功能


Trunk vlan1

设置/取消Trunk端口中允许通过的VLAN

  • 用途:

    该命令用来设置或取消Trunk端口中允许通过的VLAN

  • 命令格式:

    • [undo] port trunk permit vlan { vlan_id_list | all }

  • 缺省值:端口为非Trunk端口,不具备Trunk功能。


Trunk vlan id pvid

设置Trunk端口的缺省VLAN ID(pvid)

  • 用途:

    该命令用来设置Trunk端口的缺省VLAN ID(pvid),此命令的undo形式用来恢复端口的缺省VLAN ID。

  • 命令格式:

    • port trunk pvid vlan vlan_id

    • undo port trunk pvid

  • 缺省值:vlan_id的缺省值为1


5985845

其它常用命令

  • 指定/删除VLAN描述字符:

    • description string

    • undo description

  • 查看VLAN设置:

    • display vlan [vlan_id ]

  • 开启/关闭VLAN接口:

    • down

    • up


Pvlan

S3026

access

access

access

access

S2016A

S2016B

PVLAN的引入

  • 交换机上存在一个或多个primary vlan和多个secondary vlan。

  • 一个primary vlan包含几个secondary vlan,对于上层交换机只能见到primary vlan。

  • 一个primary vlan就是一个IP子网,即同一个primary vlan中包含的所有secondary vlan处在同一个子网中,节省了vlan资源。


Pvlan1

PVLAN的配置

  • 配置primary VLAN

    • isolate-user-vlan enable

    • undo isolate-user-vlan enable

  • 配置secondary VLAN

    • vlan vlan-id

  • 设置primary VLAN和secondary VLAN的映射关系

    • isolate-user-vlan primary_vlan_num secondary secondary_vlan_numlist

    • undo Isolate-user-vlan primary_vlan_num [ secondary secondary_vlan_numlist ]


Pvlan2

PVLAN的配置举例

S3526

e0/7

e0/8

VLAN 5

VLAN 6

S2008A

e0/9

e0/9

S2008B

e0/1

e0/2

e0/3

e0/4

VLAN 1

VLAN 2

VLAN 3

VLAN 4


Pvlan3

PVLAN的注意事项

  • 使用版本的注意点

  • 配置映射关系前的注意点

    • primary vlan和secondary vlan中必须已经包含了端口。

  • 建立映射关系后的注意点

    • 不可以向primary VLAN和secondary VLAN执行添加和删除端口的操作,也不可以执行删除vlan的操作。

    • 要重新建立映射关系必须先解除原有的映射关系。

  • primary vlan中的端口类型

    • primary vlan中的所有端口都不是802.1Q的trunk端口,包括与其它 交换机相连的uplink口。

    • 每个port的PVID就是它所属secondary vlan的ID。

    • uplink端口的PVID是primary vlan的ID。


Hybrid

Hybrid端口的配置

  • 设置以太网端口的工作模式

    • port link-type { access | hybrid | trunk }

    • Undo port link-type

  • 设置Hybrid端口的缺省 ID

    • port hybrid pvid vlan vlan_id

    • undo port hybrid pvid

  • 将Hybrid端口加入到指定的已经存在的VLAN

    • port hybrid vlan vlan_id_list {tagged|untagged}

    • undo port hybrid vlan vlan_id_list


Hybrid1

S3026A

S3026B

Hybrid

Hybrid

access

access

PCA

PCB

Hybrid端口实例一

  • PCA和PCB均属于VLAN 2。

  • 配置Hybrid端口为属于VLAN 2的帧打上tag头。

  • 不改变Hybrid端口的PVID,仍保持为1。


Hybrid2

S3026A

S3026B

Hybrid

Hybrid

access

access

PCA

PCB

Hybrid端口实例二

  • PCA和PCB均属于VLAN 2。

  • 配置 Hybrid 端口不为属于VLAN 2的帧打上tag头。

  • 改变 Hybrid 端口的PVID为2。


Vlan disable

S3526

S3026

S2403F

S2403F

Vlan Disable

  • S3026下挂的两台2403F每个端口在二层进行两两隔离,并要求2403F上所有的VLAN ID都要透传到S3526上。


Vlan disable1

Vlan Disable的配置

VlanDisable的设置非常简单,在系统视图下,只需一条命令,具体操作如下:

  • 使能Vlan Disable功能:

    • [S3026] vlan disable

  • 使能Vlan Enable功能:

    • [S3026] vlan enable


5985845

课程内容

VLAN基础配置

交换机端口配置

VLAN间的路由


5985845

VLAN 100

VLAN 200

VLAN 300

VLAN 隔离二层广播域

  • VLAN隔离了二层广播域,也就严格地隔离了各个VLAN之间的任何流量,分属于不同VLAN的用户不能互相通信。


5985845

VLAN间通信

  • 不同VLAN之间的流量不能直接跨越VLAN的边界,需要使用路由,通过路由将报文从一个VLAN转发到另外一个VLAN。

VLAN 100

VLAN 200

VLAN 300


5985845

VLAN间通信的路由选择

VLAN 100

VLAN 200

Ping 2.2.2.20

非本地通信

使用默认网关

  • 在主机上配置默认网关,对于非本地的通信,主机会自动寻找默认网关,并把报文交给默认网关转发而不是直接发给目的主机。

1.1.1.10/24

2.2.2.20/24

网络1.1.1.0/24在接口1

网络2.2.2.0/24在接口2


5985845

每个VLAN一个物理连接

  • 在二层交换机上配置VLAN,每一个VLAN使用一条独占的物理连接连接到路由器的一个接口上。

VLAN 100

VLAN 200

VLAN 300


Vlan trunking

使用VLAN Trunking

  • 二层交换机上和路由器上配置他们之间相连的端口使用VLAN Trunking,使多个VLAN共享同一条物理连接到路由。

VLAN 100

VLAN 200

VLAN 300


5985845

交换和路由的集成

VLAN 100

VLAN 200

  • 二层交换机上和路由器在功能上的集成构成了三层交换机,三层交换机在功能上实现了VLAN的划分、VLAN内部的二层交换和VLAN间路由的功能。

VLAN 300

VLAN 100

VLAN 200

VLAN 300


5985845

三层交换机功能模型

ETH0:10.110.0.254/24

ETH2:10.110.2.254/24

ETH1:10.110.1.254/24

10.110.0.113/24

G:10.110.0.254

10.110.1.69/24

G:10.110.1.254

10.110.1.88/24

G:10.110.1.254

10.110.2.200/24

G:10.110.2.254


5985845

三层交换机中的路由和二层交换

  • 二层交换引擎:实现同一网段内的快速二层转发

  • 三层路由引擎:实现跨网段的三层路由转发


5985845

3

3

3

3

2

2

2

2

1

1

1

1

报文到报文的三层交换技术

  • 传统三层技术对每个报文进行处理,并基于第三层地址转发报文。这一方法称为报文到报文(Px P)。


5985845

基于流交换的三层交换技术

  • 不在三层处理所有报文的的方法称之为流交换(FS)。

3

3

3

3

2

2

2

2

1

1

1

1

第一个报文

后续报文


Vlan route interface

创建/删除VLAN的Route Interface属性

  • 用途:

    • 为了给VLAN指定IP地址,需要给vlan创建一个虚拟路由接口。

  • [undo] interface vlan vif_id

  • 参数含义:

    • vif_id :虚接口号,且虚接口号与vlan id相等


Vlan ip

给VLAN指定/删除IP地址和掩码

  • 用途:

    • 给VLAN指定IP地址和掩码/掩码长度

  • ip address ip_address {mask | mask_length}

  • undo ip address [ip_address]

    • undo ip address:删除vlan的ip地址

  • 参数含义:

    • ip_address: vlan的ip地址

    • mask: 对应的子网掩码

    • mask_length:对应的掩码长度


5985845

配置VLAN

  • [Quidway] vlan 100

  • [Quidway-vlan100] port e0/1 to e0/10

  • [Quidway] vlan 200

  • [Quidway-vlan200] port e0/11 to e0/20

VLAN 100

VLAN 200


5985845

给VLAN配置路由接口

  • [Quidway] vlan 100

  • [Quidway-vlan100] interface vlan 100

  • [Quidway-vlan- interface 100] ip address 1.1.1.254 255.255.255.0

  • [Quidway] vlan 200

  • [Quidway-vlan200] interface vlan 200

  • [Quidway-vlan- interface 200] ip address 2.2.2.254 255.255.255.0

1.1.1.254/24

2.2.2.254/24

VLAN 100

VLAN 200


5985845

给主机配置默认网关

  • 在主机上配置主机的默认网关,将默认网关指向所在VLAN在三层交换机上的接口的地址。

2.2.2.100/24

默认网关:

2.2.2.254

1.1.1.100/24

默认网关:

1.1.1.254

1.1.1.254/24

2.2.2.254/24

VLAN 200

VLAN 100


5985845

配置路由协议

  • 在三层交换机上,根据网络的路由规划配置使用路由协议和配置路由协议参数。

1.1.1.100/24

默认网关:

1.1.1.254

2.2.2.100/24

默认网关:

2.2.2.254

1.1.1.254/24

2.2.2.254/24

VLAN 100

VLAN 200


5985845

网络地址

131.109.1.0/24

接口地址

131.109.1.1/24

S3526A

网络地址

接口地址

10.24.40.0/24

10.24.40.1/24

S3526B

S3526C

接口地址

接口地址

129.102.0.1/16

202.38.165.1/24

网络地址

网络地址

129.102.0.0/16

202.38.165.0/24

配置RIP路由协议


5985845

配置OSPF路由协议

LSW 1

LSW 2

VLAN 1 1.1.1.1

VLAN 3 1.1.1.3

VLAN 2 1.1.1.2

LSW 3

Area 1

VLAN 4 1.1.2.3

AS 1

VLAN 5 1.1.2.4

AS 2

LSW 4

VLAN 6 2.2.2.3

VLAN 7 2.2.2.5

Area 0

3.3.3.6

LSW 5


Cisco 3550

Cisco 3550的交换机命令

  • 配置二层端口

    3550的所有端口缺省是二层口,如果此端口已经配置成三层端口,可用switchport来使其成为二层端口。

  • 配置端口速率及双工模式

    可以配置快速以太口的速率为10/100Mbps、千兆以太口的速率为10/100/1000-Mbps; GBIC端口则不能配置速率及双工模式


5985845

二层端口配置命令

  • configure terminal进入配置状态

  • interfaceinterface-id进入端口配置状态

  • speed {10 | 100 | 1000 | auto | nonegotiate}设置端口速率

    1000只工作在千兆口. nonegotiate只能在GBIC上用

  • duplex {auto | full | half}设置全双工或半双工

  • end退出

  • show interfacesinterface-id显示有关配置情况

  • copy running-config startup-config 保存


5985845

端口描述命令

  • configure terminal 进入配置模式

  • interfaceinterface-id进入要加入描述的端口

  • descriptionstring加入描述 (最多240个字符)

  • end退回

  • descriptionorshow running-config验证

  • copy running-config startup-config保存


5985845

端口描述举例

  • Switch# config terminal

  • Switch(config)# interface f0/4

  • Switch(config-if)# description Connects to Marketing

  • Switch(config-if)# end

  • Switch# show interfaces fastethernet0/4 description

  • Interface Status Protocol Description

  • Fa0/4 up down Connects to Marketing


5985845

三层端口配置命令

  • configure terminal进入配置状态

  • interface {{fastethernet | gigabitethernet} interface-id} | {vlanvlan-id} | {port-channelport-channel-number}进入端口配置状态

  • no switchport把物理端口变成三层口

  • ip addressip_address subnet_mask配置IP地址和掩码

  • no shutdown激活端口

  • show interfaces [interface-id]

  • show ip interface [interface-id]

  • show running-config interface [interface-id]验证配置


5985845

监控端口和控制器的状态

  • show interfaces [interface-id]显示端口的状态和配置

  • show interfacesinterface-id status [err-disabled]显示一系列端口的状态或错误-关闭的状态

  • show interfaces [interface-id] switchport显示二层端口的状态,可以用来决定此口是否为二层或三层口。

  • show interfaces [interface-id] description显示端口描述

  • show ip interface [interface-id]显示所有或某一端口的IP可用性状态

  • show running-config interface [interface-id]显示当前配置中的端口配置情况

  • show version显示软硬件等情况


5985845

配置正常范围的VLAN

  • VLAN号1, 1002到1005是自动生成的不能被去掉。

  • VLAN号1到1005的配置被写到文件vlan.dat中, 可以用show vlan命令查看, vlan.dat文件存放在NVRAM中. 不要手工删除它


5985845

生成、修改、删除VLAN的命令

  • configure terminal进入配置状态

  • vlan vlan-id输入VLAN号, 进入vlan配置状态,可以输入新的VLAN号或旧的来进行修改。

  • namevlan-name(可选)输入一个VLAN名,如果没有名字,缺省是VLAN号前面用0填满的4位数

  • mtumtu-size(可选) 改变MTU大小

  • show vlan {namevlan-name | id vlan-id}验证

  • 用no vlanname或 no vlan mtu 退回到缺省的vlan配置状态

  • no vlan vlan-id 删除某一VLAN.


5985845

分配端口给VLAN

  • configure terminal进入配置状态

  • interfaceinterface-id进入要分配的端口

  • switchport mode access定义端口为access

  • switchport access vlanvlan-id把端口分配给某一VLAN

  • show running-config interface interface-id验证端口的VLAN号

  • show interfaces interface-id switchport验证端口的管理模式和VLAN情况


Vlan trunks

配置VLAN Trunks

  • configure terminal进入配置状态

  • interface interface-id进入端口配置状态

  • switchport trunk encapsulation {isl | dot1q | negotiate}配置trunk封装ISL 或 802.1Q 或自动协商

  • switchport mode {dynamic {auto | desirable} | trunk}配置二层trunk模式。

    auto—自动协商是否成为trunk;desirable—把端口设置为trunk如果对方端口是trunk, desirable, 或自动模式;trunk—设置端口为强制的trunk方式,而不理会对方端口是否为trunk

  • switchport access vlanvlan-id(可选) 指定一个缺省VLAN, 如果此端口不再是trunk

  • switchport trunk native vlanvlan-id指定802.1Q native VLAN号

  • show interfaces interface-id switchport显示有关switchport 的配置

  • show interfaces interface-id trunk显示有关trunk的配置


Trunk vlan2

定义trunk允许的VLAN

  • 缺省情况下trunk允许所有的VLAN通过。可以去掉某一VLAN

  • switchport trunk allowed vlan {add | all | except | remove} vlan-list (可选) 配置trunk允许的VLAN. 使用add, all, except, remove关健字


  • Login