Support for vista
This presentation is the property of its rightful owner.
Sponsored Links
1 / 6

Support for Vista PowerPoint PPT Presentation


  • 33 Views
  • Uploaded on
  • Presentation posted in: General

Support for Vista. Unity 5.0(1). Background. Background Microsoft has released Windows Vista on January 2007. Vista will be one of the operating systems that we supported for Unity subscriber workstations.

Download Presentation

Support for Vista

An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -

Presentation Transcript


Support for vista

Support for Vista

Unity 5.0(1)


Background

Background

  • Background

    • Microsoft has released Windows Vista on January 2007. Vista will be one of the operating systems that we supported for Unity subscriber workstations.

    • Windows Vista has a few new security features to protect computers from malware. Two of the new security features that have impact on Unity system are User Account Control (UAC) and Protected Mode of Internet Explorer 7. Refer to “Support for IE7.ppt” presentation for details of Unity support for Protected Mode of Internet Explorer 7.

    • With the new ability of User Account Control (UAC) to limit the risk of malware, IT professionals can deploy users as Standard users (with limited privileges), rather than Administrators. This helps prevent users from making potentially dangerous changes to their computers without limiting their ability to control simple things on their computer. Even the users logon to Vista as theadministrators, they are running with standard user privileges by default. Therefore all users (including administrators) run with standard user privileges on Vista by default.


Problem solution

Problem & Solution

  • Problem

    • When running as Standard users on Vista, the users only have read access to the registry in HKEY_LOCAL_MACHINE. VMO does keep a few configuration settings in HKEY_LOCAL_MACHINE and it asks for full access to HKEY_LOCAL_MACHINE. With Standard users privilege, VMO fails to access the configuration settings and it will not function correctly.

  • Solution

    • Fortunately VMO only needs to read the configuration settings in HKEY_LOCAL_MACHINE and no write access is required. When running as Standard users, Vista does give read privilege to Standard users to access the registry in HKEY_LOCAL_MACHINE. We could modify the way that VMO accesses the registry in HKEY_LOCAL_MACHINE.


Implementation basics

Implementation Basics

  • For Unity 5.0(1) release, we modified the code so that VMO only asks for read access when it opens the registry in HKEY_LOCAL_MACHINE. With the modification, VMO can read the configuration setting and everything works fine on Vista. We don’t have to make any installation or user interface changes.

  • 5.0(1) VMO also works with other Windows systems such as Windows XP, Windows 2000 and etc.

  • VMO does write to the registry in HKEY_CURRENT_USER for some user-specific VMO settings. It is not a problem on Vista. Standard users do have write access to the registry in HKEY_CURRENT_USER.

  • The following are the versions of Vista that we have qualified and support right now:

    • Vista Business (x86)

    • Vista Enterprise (x86)

    • Business N (x86)


Support for vista

Q & A

  • Do we support 64-bit Vista?

    Not at this time. We did not qualify the 64-bit Vista. If there is a need, we could qualify it and we do not see any potential problem with it.

  • Do we have plan to modify old versions of VMO so that they are compatible with Vista?

    No. 5.0(1) VMO is the only version will works with Vista right now. It is compatible with the following versions of Unity:

    Unity 4.2(1) with Exchange

    Unity 4.1(1) with Exchange (with Windows XP and Windows 2000 only)

    Unity 4.0(x)with Exchange (with Windows XP and Windows 2000 only)

    Please refer to “Compatibility Matrix: Cisco Unity and the Software on Subscriber Workstations” document for details.


  • Login