Kiv laszt s
This presentation is the property of its rightful owner.
Sponsored Links
1 / 17

Kiválasztás PowerPoint PPT Presentation


  • 79 Views
  • Uploaded on
  • Presentation posted in: General

Kiválasztás. Kiválasztás ( N,A,sorszam) i := 1 Ciklus amíg (A(i) nem T) i := i+1 Ciklus vége sorszam := i Eljárás vége. Kiválasztás tételénél előfeltétel, hogy a keresett elem biztosan megtalálható a tömbben. Példa kiválasztásra Adott egy 5 elemű tömb nevekkel feltöltve.

Download Presentation

Kiválasztás

An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -

Presentation Transcript


Kiv laszt s

Kiválasztás

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(i) nem T)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége


Kiv laszt s t tel n l el felt tel hogy a keresett elem biztosan megtal lhat a t mbben

Kiválasztás tételénél előfeltétel, hogy a keresett elem biztosan megtalálható a tömbben.


Kiv laszt s

  • Példa kiválasztásra

  • Adott egy 5 elemű tömb nevekkel feltöltve.

  • Hányadik helyen találjuk a „Gábor” nevet?

    • A: szöveges tömb (5 elemű)

    • N:=5

    • T tulajdonság: „Gábor”


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(i) nem T)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

↓ ↓

1

N


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(i) nem T)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

i = 1

1

N


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(1) nem „Gábor”)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

igaz

i = 1

1

N


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(i) nem T)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

1

i = 2

N


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(i) nem T)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

1

i = 2

N


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(2) nem „Gábor”)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

igaz

1

i = 2

N


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(i) nem T)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

1

i = 3

N


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(i) nem T)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

1

i = 3

N


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(3) nem „Gábor”)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

igaz

1

i = 3

N


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(i) nem T)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

1

i = 4

N


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(i) nem T)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

1

i = 4

N


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(4) nem „Gábor”)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

hamis

1

i = 4

N


Kiv laszt s

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(i) nem T)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

1

i = 4

N

4


Kiv laszt s

4 (a Gábor név ezen a helyen áll)

Kiválasztás (N,A,sorszam)

i := 1

Ciklus amíg (A(i) nem T)

i := i+1

Ciklus vége

sorszam := i

Eljárás vége

1

i = 4

N


  • Login