AutoQoS Technical Presentation, 1/03
Download
1 / 54

Cisco Presentation Guide - PowerPoint PPT Presentation


  • 918 Views
  • Updated On :

AutoQoS Technical Presentation, 1/03. 1. 1. 1. © 2002, Cisco Systems, Inc. All rights reserved. Cisco AutoQoS Technical Presentation . Ramya Venkatraman Technical Marketing Engineer – QoS Internet Technologies Group. Agenda. Introduction Cisco AutoQoS Framework

loader
I am the owner, or an agent authorized to act on behalf of the owner, of the copyrighted work described.
capcha
Download Presentation

PowerPoint Slideshow about 'Cisco Presentation Guide' - LionelDale


An Image/Link below is provided (as is) to download presentation

Download Policy: Content on the Website is provided to you AS IS for your information and personal use and may not be sold / licensed / shared on other websites without getting consent from its author.While downloading, if for some reason you are not able to download a presentation, the publisher may have deleted the file from their server.


- - - - - - - - - - - - - - - - - - - - - - - - - - E N D - - - - - - - - - - - - - - - - - - - - - - - - - -
Presentation Transcript
Slide1 l.jpg

AutoQoS Technical Presentation, 1/03

1

1

1

© 2002, Cisco Systems, Inc. All rights reserved.


Cisco autoqos technical presentation l.jpg

Cisco AutoQoS Technical Presentation

Ramya VenkatramanTechnical Marketing Engineer – QoSInternet Technologies Group


Agenda l.jpg
Agenda

  • Introduction

  • Cisco AutoQoS Framework

  • Automation with Cisco AutoQoS

  • AutoQoS Deployment Case Study

  • Summary

Introduction


Introduction ietf diffserv architecture rfc 2475 l.jpg
Introduction –IETF DiffServ Architecture (RFC-2475)

  • The idea: different service levels for packets

  • The service: some significant characteristics of packet transmission in one direction across the network

    Examples: bandwidth and latency


A new paradigm for automating the delivery of network quality of service l.jpg
A New Paradigm for Automating the Delivery of Network Quality of Service

  • Key Takeaways:

    • Simpler QoS deployments – Reduces operator errors

    • Cheaper QoS deployments – Up to 2/3rds reduction in cost

    • Faster QoS deployments – Up to 2/3rds reduction in deployment time

  • Cisco AutoQoS initial focus: QoS for Voice over IP

    • IP Telephony is here!

    • IP Telephony requires QoS

    • QoS deployment can be challenging

    • Cisco AutoQoS makes VoIP deployments simpler, cheaper, and faster

  • Cisco AutoQoS retains 100% customer control over configuration


Cisco qos introduction a complete diffserv toolkit l.jpg
Cisco QoS Introduction: Quality of ServiceA Complete Diffserv Toolkit

Classification (CoS, DSCP, ACLs, VLAN, Port-based)

SWITCH

Classification (CoS, DSCP, ACLs, VLAN, Port-based)

PROVISIONING & MONITORING

CBQoSMIB, QPM 3.0

Buffer Management & WRED

Queuing & Scheduling (WRR, PQ)

Policing & Marking (Aggregate & Micro Flow Policing)

ROUTER

Classification & Marking (DSCP, IP Precedence, nBAR, etc.)

Congestion Avoidance Mechanisms (WRED, WRED-ECN)

Traffic Conditioners (Policing, Shaping)

Congestion Management Techniques (WFQ,CBWFQ,LLQ)

Link Efficiency Mechanisms (Compression, Fragmentation)

FRAME

RELAY

PPP

HDLC

ATM

GE

FE


Agenda7 l.jpg
Agenda Quality of Service

  • Introduction

  • Cisco AutoQoS Framework

  • Automation with Cisco AutoQoS

  • AutoQoS Deployment Case Study

  • Summary

Cisco AutoQoS Framework


Cisco autoqos voip framework diffserv functions automated l.jpg
Cisco Quality of ServiceAutoQoS - VoIP FrameworkDiffServ Functions Automated

  • Automation and simplification of the existing user interface to expedite deployment of QoS features for VoIP

  • Fine-tuning of AutoQoS generated parameters by user, if desired


Cisco autoqos framework network based application recognition l.jpg

Link Utilization Quality of Service

Citrix 25%

Netshow 15%

Fasttrack 10%

FTP 30%

HTTP 20%

Cisco AutoQoS Framework –Network Based Application Recognition

What Applications are running through my network?

  • Benefits

    • Identifies Layer 4 to Layer 7 applications and protocols

      • Stateful & deep packet inspection

    • Protocol Discovery analyzes application traffic patterns in real time and identifies traffic is running on the network

  • Platform Support

    • Cisco 1700, 2600, 3600, 7100, 7200, FlexWan Series Routers

    • Switches: MSFC support on Sup 1a & Sup 2 introduced in Release 12.1(13)E


Cisco autoqos framework nbar rtp payload type classification l.jpg
Cisco AutoQoS Framework – Quality of ServicenBAR RTP Payload Type Classification

  • Eases classification of voice and video traffic

    • VoIP, streaming / real time video, audio / video conferencing, Fax Over IP

  • Distinguishes betweenRTP packets based on payload type and CODECS

  • Removes dependencies on UDP Port Range & DSCP markings


Cisco autoqos framework percentage based policies l.jpg
Cisco AutoQoS Framework – Quality of ServicePercentage Based Policies

  • Problems

    • Fixed CIR imposes scalability issues

    • Service policies differ by interface, with a wide range of interface bandwidths

  • Solution

    • Configure policies as a percentage of available bandwidth

  • Advantage

    • Increased Scalability & Manageability

      Same Policy Map can be applied on multiple interfaces and on interfaces with varying bandwidth

      Build Once, Apply Many Policies


Slide12 l.jpg

56kb WAN Quality of Service

Cisco AutoQoS Framework –MLPPP Link Fragmentation & Interleaving

Problem: large packets “freeze out” voice

Voice Packet

60 bytes

Every 20 ms

Voice Packet

60 bytes

Every >214 ms

Voice Packet

60 bytes

Every >214 ms

~214ms Serialization Delay

Voice

1500 Data Bytes

Voice

Voice

1500 Data Bytes

Voice

Voice

1500 Data Bytes

Voice

10mbps Ethernet

10mbps Ethernet

  • Implemented via Multilink PPP (MLP) over FR, ATM, and leased lines

  • Fragments are interleaved with the real-time packets, reducing the Serialization delay experienced by Voice packets

Benefit: reduce the jitter in voice calls


Cisco autoqos framework rtp header compression l.jpg
Cisco AutoQoS Framework – Quality of ServiceRTP Header Compression


Agenda14 l.jpg
Agenda Quality of Service

  • Introduction

  • Cisco AutoQoS Framework

  • Automation with Cisco AutoQoS

  • AutoQoS Deployment Case Study

  • Summary

Automation with Cisco AutoQoS


Automation with cisco autoqos voip intelligence in the lan l.jpg
Automation with Cisco AutoQoS – Quality of ServiceVoIP Intelligence in the LAN

Building

Building

Building

Access

Layer 2 Switch

Distribution

Layer 3 Switch

Core

Layer 3 Switched

Backbone

Server Farm

Server Farm

  • Enable Trust boundary (phone, access, uplink/downlink)

  • Enable Priority Queuing where required

  • Modify Queue Admission criteria where required

  • Configure CoS to DSCP and IP Prec to DSCP maps where required


Automation with cisco autoqos voip intelligence in the wan l.jpg
Automation with Cisco AutoQoS – Quality of ServiceVoIP Intelligence in the WAN

WAN

125 Remote Sites

  • Build MQC based policies for VoIP

    • Intelligent Classification (Trust / Untrust)

    • High Speed & Low Speed QoS Policies

  • Automatically enable QoS features specific to underlying transport protocol (FR, ATM, PPP, FR-to-ATM)

    • Enable Traffic Shaping where required

    • Enable LFI (FRF.12, MLP) where required

    • Enable CRTP

  • Monitoring & SNMP Alerts


Cisco autoqos benefits router platforms l.jpg
Cisco AutoQoS Benefits Quality of ServiceRouter Platforms

Cisco 2600, 2600-XM, 3600, 3700, and 7200 Series Routers

  • User can meet the voice QoS requirements without extensive knowledge about:

    • Underlying technologies (i.e.: PPP, FR, ATM)

    • Service policies

    • Link efficiency mechanisms

  • AutoQoS lends itself to tuning of all generated parameters & configurations


Automation with cisco autoqos router platforms l.jpg
Automation with Cisco AutoQoS Quality of ServiceRouter Platforms

  • Supported on serial (PPP & HDLC), ATM PVCs, FR DLCIs and FR/ATM links

    • Only on point-to-point sub-interfaces for FR and low speed ATM PVCs

    • Policies are specific to underlying transport layer protocol

  • Automatically identifies H.323, MGCP, H.225 (Unicast), SIP and Skinny Signaling Protocols

  • Command Line Interface

  • auto qos voip [trust] – Untrusted Mode by default

  • auto qos voip [fr-atm] – Enabled on FR DLCI for FR/ATM Interworking


Automation with cisco autoqos router platforms cont l.jpg
Automation with Cisco AutoQoS Quality of ServiceRouter Platforms (Cont)

  • Classification

    • Trust: relies on DSCP markings from switches (DSCP EF & AF31)

    • Un trust: nBAR RTP Payload Type Classification & Access Lists

  • Provisioning

    • LLQ protects voice bearer and voice signaling traffic

    • WFQ shares bandwidth fairly in the Best Effort Data class

  • Policy Generation

    • Enables high- (>768Kbps) and low- (<=768Kbps) speed QoS

  • Monitoring

    • SNMP monitoring events are reported if the SNMP server is enabled

    • Thresholds activated in RMON alarm table to monitor LLQ drops


Automation with cisco autoqos router platforms cont20 l.jpg

Frame Quality of Service

Relay

Automation with Cisco AutoQoSRouter Platforms (Cont)

Without

AutoQoS

Configuring QoS for VoIP on Low Speed Frame Relay WAN Link

class-map VoIP-Bearer

match protocol rtp audio

class-map VoIP-Control

match access-group 101

!

policy-map QoS-Policy

class VoIP-Bearer

priority percent 30

set ip dscp ef

class VoIP-Control

bandwidth percent 5

set ip dscp af31

class class-default

fair-queue

!

Access-list 101 permit tcp any any eq 1720 \\H.323

Access-list 101 permit tcp any any range 11000 11999 \\H.323

Access-list 101 permit udp any any eq 2427 \\MGCP

Access-list 101 permit udp any any eq 2428 \\MGCP

Access-list 101 permit tcp any any range 2000 2002 \\ Skinny

Classify the traffic of interest for QoS Policy

Define QoS Policy Treatment

Define ACLs to classify

VoIP Signaling


Automation with cisco autoqos router platforms cont21 l.jpg

Frame Quality of Service

Relay

Automation with Cisco AutoQoSRouter Platforms (Cont)

Without

AutoQoS

Enabling FRTS, FRF.12 & CRTP

interface Serial4/0

encapsulation frame-relay

frame-relay traffic-shaping

!

interface Serial4/0.1 point-to-point

bandwidth 256

ip address 10.1.71.1 255.255.255.0

frame-relay interface-dlci 100

class VoIP

Frame-relay ip rtp header-compression

!

map-class frame-relay VoIP

frame-relay cir 256000

frame-relay bc 2560

frame-relay be 0

frame-relay mincir 256000

service-policy output QoS-Policy

frame-relay fragment 320

Enable Frame Relay Traffic Shaping

Apply FR class-map to DLCI

Enable RTP Header Compression

Frame Relay Traffic Shaping

Apply QoS Policy

Enable FRF.12


Automation with cisco autoqos router platforms cont22 l.jpg

Frame Quality of Service

Relay

Automation with Cisco AutoQoSRouter Platforms (Cont)

With AutoQoS

FRTS enabled by AutoQoS

interface Serial4/0

encapsulation frame-relay

frame-relay traffic-shaping

!

interface Serial4/0.1 point-to-point

bandwidth 256

ip address 10.1.71.1 255.255.255.0

frame-relay interface-dlci 100

class AutoQoS-VoIP-FR-Serial4/0-100

auto qos voip

frame-relay ip rtp header-compression

!

map-class frame-relay AutoQoS-VoIP-FR-Serial4/0-100

frame-relay cir 256000

frame-relay bc 2560

frame-relay be 0

frame-relay mincir 256000

service-policy output AutoQoS-Policy-UnTrust

frame-relay fragment 320

You specify BW, IP Addr

& FR DLCI

You enable AutoQoS

CRTP configuration generated by AutoQoS

FRTS & FRF.12 settings generated by AutoQoS


Automation with cisco autoqos router platforms cont23 l.jpg

Frame Quality of Service

Relay

Automation with Cisco AutoQoSRouter Platforms (Cont)

With AutoQoS

class-map match-any AutoQoS-VoIP-RTP-Untrust

match protocol rtp audio

match access-group name AutoQoS-VOIP-RTCP

class-map AutoQoS-VoIP-Control-Untrust

match access-group name AutoQoS-VOIP-Control

class-map match-any AutoQoS-VOIP-Remark

match ip dscp ef

match ip dscp af31

!

policy-map AutoQoS-Policy-Untrust

class-map AutoQoS-VoIP-RTP-Untrust

priority percent 70

set dscp ef

class AutoQoS-VoIP-Control-Untrust

bandwidth percent 5

set dscp af31

class AutoQoS-VoIP-Remark

set dscp default

class class-default

fair-queue

Classification done by AutoQoS

Provisioning done by AutoQoS


Automation with cisco autoqos router platforms cont24 l.jpg

Frame Quality of Service

Relay

Automation with Cisco AutoQoSRouter Platforms (Cont)

With AutoQoS

Monitoring Drops in LLQ

  • Thresholds are activated in RMON alarm

  • table to monitor drops in Voice Class

  • Default drop threshold is 1bps

  • rmon event 33333 log trap AutoQoS description “AutoQoS

  • SNMP traps for Voice Drops” owner AutoQoS

  • rmon alarm 33350 cbQoSCMDDropBitRate.2881.2991 30

  • Absolute rising-threshold 1 33333 falling-threshold 0

  • Owner AutoQoS

  • RMON event configured generated by AutoQoS


    Slide25 l.jpg

    Cisco AutoQoS Benefits Quality of ServiceSwitch Platforms

    Cisco Catalyst 6500, 4500, 3550, and 2950EI Switches

    • User can meet the voice QoS requirements without extensive knowledge about:

      • Trust boundary

      • CoS to DSCP mappings

      • Weighted Round Robin (WRR) & Priority Queue (PQ) Scheduling parameters

    • Generated parameters and configurations are user tunable


    Slide26 l.jpg

    Automation with Cisco AutoQoS Quality of ServiceSwitch Platforms

    • Single command at the interface level configures interface and global QoS

      • Support for Cisco IP Phone & Cisco Soft Phone

        • Support for Cisco Soft Phone currently exists only on the Cat6500

      • Trust Boundary is disabled when IP Phone is moved / relocated

      • Buffer Allocation & Egress Queuing dependent on interface type (GE/FE)

    • Supported on Static, dynamic-access, voice VLAN access, and trunk ports

    • CDP must be enabled for AutoQoS to function properly

    • Cisco Catalyst 2950 EI supports WRR, Strict Priority Scheduling, and Strict Priority Queuing


    Slide27 l.jpg

    Automation with Cisco AutoQoS Quality of ServiceSwitch Platforms (Cont)

    Command Line Interface

    • Cisco Catalyst 6500 Switch

      • Global: set qos autoqos

      • Interface: set port qos autoqos <mod/port> voip [ciscosoftphone | ciscoipphone]

      • Trust Boundary: Set port qos autoqos <mod/port> trust [cos|dscp]

    • Cisco Catalyst 3550 and 2950EI Switches

      • auto qos voip trust – QoS Labels in ingress packets are trusted

      • auto qos voip Cisco-phone – Extends trust boundary if IP Phone detected

    • Cisco Catalyst 4500 Switch

      • Similar to Cat 3550/2950


    Slide28 l.jpg

    6500 Quality of Service

    6500

    6500

    6500

    6500

    Automation with Cisco AutoQoSSwitch Platforms (Cont)

    Without

    AutoQoS

    Configuring QoS for VoIP on Trusted & Untrusted Ports in the LAN

    set qos enable

    set port qos mod/port cos 0

    set port qos mod/port cos-ext 0

    set port qos mod/port trust-ext untrusted

    set port qos mod/port trust-device ciscoipphone

    set qos acl ip ACL_IP-PHONES trust-cos any

    commit qos acl ACL_IP-PHONES

    set qos acl map ACL_IP-PHONES mode/port

    set port qos mod/port trust trust-cos

    set qos ipprec-dscp-map 0 10 18 26 34 46 48 56

    set qos cos-dscp-map 0 10 18 26 34 46 48 56

    set qos map 2q2t tx queue 2 2 cos 5,6,7

    .............


    Slide29 l.jpg

    6500 Quality of Service

    6500

    6500

    6500

    6500

    Automation with Cisco AutoQoSCisco Catalyst 6500 Series Switch

    With AutoQoS

    User enables AutoQoS

    set port macro 4/1 ciscoipphone 10 110 Port 4/1 has been fully configured for ciscoipphone. Data vlan set to 10, auxiliary vlan set to 110, port based autoqos configured.

    Global autoqos configured on all ports.

    set qos autoqos

    All ingress and egress QoS scheduling parameters configured on all ports.CoS to DSCP, DSCP to COS and IP Precedence to DSCP maps configured.Global QoS configured

    set port qos autoqos 4/1 voip ciscoipphone

    Port 4/1 has been fully configured for voip.Global autoqos configured on all ports

    Generated by AutoQoS

    Generated by AutoQoS


    Slide30 l.jpg

    6500 Quality of Service

    6500

    3500

    3500

    3500

    Automation with Cisco AutoQoSCisco Catalyst 3550 Series Switch

    Without

    AutoQoS

    Configuring QoS for VoIP on Trusted Ports in the LAN

    mls qos map cos-dscp 0 10 18 26 34 46 48 56

    mls qos

    !

    interface FastEthernet0/1

    Description to IP Phone

    mls qos trust CoS

    wrr-queue cos-map 4 5

    priority-queue out

    switchport voice vlan 111

    switchport access vlan 11

    switchport priority extend cos 0

    Map CoS Values in incoming packets to DSCP values

    Ingress Classification set to trust CoS value received in the packet

    Assign packets with CoS 5 to Queue 4 (Expedite Queue)

    Enable Egress Expedite Queue

    Enable Trust Boundary on the phone


    Slide31 l.jpg

    6500 Quality of Service

    6500

    3500

    3500

    3500

    Automation with Cisco AutoQoSCisco Catalyst 3550 Series Switch

    With AutoQoS

    Interface FastEthernet0/1

    mls qos trust device cisco-phone

    mls qos trust cos

    auto qos voip cisco-phone

    wrr-queue bandwidth 20 1 80 0

    wrr-queue min-reserve 1 5

    wrr-queue min-reserve 2 6

    wrr-queue min-reserve 3 7

    wrr-queue min-reserve 4 8

    wrr-queue cos-map 1 0 1 2 4

    wrr-queue cos-map 3 3 6 7

    wrr-queue cos-map 4 5

    priority-queue out

    You enable AutoQoS

    Generated by

    AutoQoS

    Interface GigabitEthernet0/1

    mls qos trust device cisco-phone

    mls qos trust cos

    auto qos voip cisco-phone

    wrr-queue bandwidth 20 1 80 0

    wrr-queue queue-limit 80 1 20 1

    wrr-queue cos-map 1 0 1 2 4

    wrr-queue cos-map 3 3 6 7

    wrr-queue cos-map 4 5

    priority-queue out

    You enable AutoQoS

    Generated by AutoQoS


    Slide32 l.jpg

    6500 Quality of Service

    6500

    3500

    3500

    3500

    Automation with Cisco AutoQoSCisco Catalyst 2950EI Series Switch

    Without

    AutoQoS

    Configuring QoS for VoIP on Trusted & Untrusted Ports in the LAN

    mls qos

    mls qos map cos-dscp 0 10 18 26 34 46 48 56

    wrr-queue cos-map 1 0 1 2 4

    wrr-queue cos-map 3 3 6 7

    wrr-queue cos-map 4 5

    wrr-queue bandwidth 20 1 80 0

    !

    Interface GigabitEthernet0/1

    Description Uplink to Trusted Source

    mls qos trust dscp

    !

    interface FastEthernet0/1

    Description to IP Phone

    mls qos trust CoS

    switchport voice vlan 111

    switchport access vlan 11

    switchport priority extend cos 0

    Map CoS Values in incoming packets to DSCP values

    Assign packets with CoS 5 to Queue 4 (Expedite Queue)

    Ingress Classification set to trust CoS value received in the packet

    Enable Trust Boundary on the phone


    Slide33 l.jpg

    6500 Quality of Service

    6500

    3500

    3500

    3500

    Automation with Cisco AutoQoSCisco Catalyst 2950EI Series Switch

    With AutoQoS

    mls qos map cos-dscp 0 8 16 26 32 46 48 56

    wrr-queue bandwidth 20 1 80 0

    no wrr-queue cos-map

    wrr-queue cos-map 1 0 1 2 4

    wrr-queue cos-map 3 3 6 7

    wrr-queue cos-map 4 5

    !

    interface GigabitEthernet0/2

    auto qos voip trust

    mls qos trust cos

    !

    Interface FastEthernet0/1

    auto qos voip cisco-phone

    mls qos trust device cisco-phone

    Generated by AutoQoS

    You enable AutoQoS

    auto qos voip trust

    auto qos voip cisco-phone


    Agenda34 l.jpg
    Agenda Quality of Service

    • Introduction

    • Cisco AutoQoS Framework

    • Automation with Cisco AutoQoS

    • AutoQoS Deployment Case Study

    • Summary

    AutoQoS Deployment Case Study


    Slide35 l.jpg

    QoS Deployment for VoIP Quality of Service

    Goal: Deploy consistent, end-to-end QoS for VoIP

    WAN

    Distribution Layer

    WAN

    Access Layer

    Intelligent Classification

    Bandwidth Provisioning

    Admission Control

    Shaping

    Link Fragmentation & Interleaving

    Header Compression

    Classification & Trust Boundary

    Marking / Remarking

    Egress Queue Scheduling

    Buffer Management

    Layer 3 Policing

    Egress Scheduling

    (Multiple Queues with WRR)

    Priority Queuing for VOIP

    Buffer Management


    Slide36 l.jpg

    Application Quality of Service

    Classification

    Consistency

    Monitoring

    &

    Reporting

    Policy

    Generation

    Configuration

    QoS Deployment for VoIP –Without AutoQoS

    • Identify Traffic of Interest

    • Trust & Untrust

    • Consistent end-to-end QoS across LAN & WAN

    • Platform Consistency

    • Link Efficiency Mechanisms

    • CoS to DSCP to Queue mapping

    • WRR & WRED parameters

    • Transport specific features

    Key

    Elements

    of QoS

    Deployment

    • Monitor the performance of Voice traffic

    • Classes

    • Bandwidth requirements

    • High Speed Vs Low Speed QoS

    • Buffer Management


    Qos deployment for voip manual approach without autoqos l.jpg
    QoS Deployment for VoIP – Quality of ServiceManual Approach without AutoQoS

    In the WAN

    • Identify applications and protocols of interest

      Untrusted edge vs. trusted edge

    • Remark traffic based on classification

    • Determine how many classes should be configured, and what queuing should be enabled

    • Determine class bandwidth requirements

    • Configure transport specific features

      Traffic Shaping, MLPPP & TX-Ring settings

    • Enable bandwidth specific QoS features

      Header Compression & Fragmentation Settings (MLP/LFI or FRF.12)

    • Configure alarm and event settings for monitoring purposes


    Qos deployment for voip manual approach without autoqos38 l.jpg
    QoS Deployment for VoIP – Quality of ServiceManual Approach without AutoQoS

    In the LAN

    • Identify Trust Boundary & Extended Trust Boundary

    • Remark traffic based on classification

    • Determine CoS to DSCP and IP Precedence to DSCP mappings

    • Map CoS values to the different egress queues

    • Queue Size Settings & WRR weights

      FE Vs GE ports

    • Determine CoS to Egress queue mapping

    • Configure QoS on a per port basis


    Slide39 l.jpg

    QoS Deployment for VoIP– Quality of ServiceAutomation with Cisco AutoQoS (Phase I)

    Evaluate Network Environment & Generate Initial Policy

    Identify VoIP

    Bearer & Control Traffic

    VoIP Packet Drop Alerts

    CBQoSMIB Support

    One Command

    Full LAN & WAN

    Interoperability

    Monitoring

    Consistency

    Traffic

    Classification

    Policy

    Generation

    Provisioning

    Accomplish all of the above in just 4 steps

    • Configure Interface / Sub-Interface Bandwidth

    • Configure IP Address

    • Enable AutoQoS (Trust Vs Un Trust)

    • Fine Tune Parameters, if required


    Qos deployment for voip single step approach using cisco autoqos l.jpg
    QoS Deployment for VoIP - Single Step Approach Using Cisco AutoQoS

    In the LAN

    Enable Cisco AutoQoS for VoIP on the switch

    • Cisco Catalyst 2950 and 3550 Switches: enable Auto QoS on the interface

      • auto qos voip [trust | cisco-phone]

    • Cisco Catalyst 6500 Switch: enable Auto QoS on the port

      • set qos autoqos

      • set port qos autoqos <mod/port> voip [ciscosoftphone | ciscoipphone]

      • set port qos autoqos <mod/port> trust [cos|dscp]

    • Parameter Tuning

      Monitor Cisco AutoQoS on the Switch

    • sh mls qos interface <x> [buffers | queuing]

      • (above command not supported on 2950)

    • show mls qos maps cos-dscp

    • show auto qos interface <x>


    Qos deployment for voip single step approach using cisco autoqos cont l.jpg
    QoS Deployment for VoIP - Single Step Approach Using Cisco AutoQoS (Cont)

    In the WAN

    Enable Cisco AutoQoS for VoIP via Router CLI

    • Configure IP address on interface or sub interface

    • Configure bandwidth on interface or sub interface

    • Enable “autoqos voip [ trust | fr-atm ]” on PVC, DLCI or interface

    • Parameter tuning & Configuration modifications

      Monitor Cisco AutoQoS on the Router

    • show policy-map interface <x>

    • show auto qos [interface <interface type>]

    • show rmon [alarms | events]

      Monitor Cisco AutoQoS using QPM 3.0


    Qos deployment for voip class based qos mib cbqosmib l.jpg
    QoS Deployment for VoIP – AutoQoS (Cont)Class-Based QoS MIB (CBQoSMIB)

    • Provides read access to configuration and statistical information for MQC based QoS Policies

    • Provides MQC configuration information and application statistics

    • Provides CBQoS statistics on a per-policy/per-interface or PVC basis

    • Monitor pre- and post-policy bit rates on a device

    Interface 2

    Inbound Policy

    Interface 1

    Outbound Policy

    SNMP

    Interface 3

    Inbound

    Policy

    CBQoSMIB

    Provide CBQoS Statistics & Configuration Information Per policy

    ftp://ftp.cisco.com/pub/mibs/v2/CISCO-CLASS-BASED-QOS-MIB.my


    Qos deployment for voip monitoring reporting with qpm 3 0 l.jpg

    interface Multilink1 AutoQoS (Cont)

    ip address 10.1.61.1 255.255.255.0

    ip tcp header-compression iphc-format

    load-interval 30

    service-policy output QoS-Policy

    ppp multilink

    ppp multilink fragment-delay 10

    ppp multilink interleave

    interface Serial0

    • bandwidth 256

    • Ip address 10.1.61.1 255.255.255.0

    • auto qos voip

    QoS Deployment for VoIP – Monitoring & Reporting with QPM 3.0

    CLI

    Cisco Works QoS Policy Manager

    • Central web based tool

    • QoS config guidance

    • Templates, customize

    • Deployment control

    • File export

    • Monitoring

    • Reports

    • Troubleshooting

    • Multi-device, global

    • Device-Based

    • Single Command

    • Intelligent Classification

    • Reporting via Syslog & Traps


    Qos deployment for voip monitoring and reporting with cbqosmib qpm 3 0 l.jpg

    Bronze AutoQoS (Cont)

    Silver

    Bronze

    Gold

    Silver

    Gold

    Bronze

    Silver

    QoS Deployment for VoIP - Monitoring and Reporting with CBQoSMIB & QPM 3.0

    Before QOS

    After QOS Policies have been applied

    CMPrePolicyPkt

    CMPrePolicyByte

    CMPostPolicyPkt

    CMDropPkt

    CMDropByte

    CMNoBufDropPkt

    Drop=Pre- Post


    Qos deployment for voip an example using qpm 3 0 l.jpg
    QoS Deployment for VoIP – AutoQoS (Cont)An example using QPM 3.0


    Agenda46 l.jpg
    Agenda AutoQoS (Cont)

    • Introduction

    • Cisco AutoQoS Framework

    • Automation with Cisco AutoQoS

    • AutoQoS Deployment Case Study

    • Summary

    Summary


    Highlights cisco autoqos in the wan l.jpg
    Highlights – AutoQoS (Cont)Cisco AutoQoS in the WAN

    • Simplifies QoS configuration for VoIP

      • Phase I – a single command enables Cisco QoS for VoIP

    • End-to-end simplification, automation, and intelligence

      • Classifies VoIP bearer and signaling (H.323, Skinny, H.225 Unicast, SIP & MGCP) traffic

      • Provisioning based on Cisco Best Practices

    • Generated parameters and configuration can be user modified


    Highlights cisco autoqos in the wan cont l.jpg
    Highlights – AutoQoS (Cont)Cisco AutoQoS in the WAN (Cont)

    • Intelligent policy generation

      • Based on available bandwidth & underlying L2 technology

      • Enables IP RTP Header Compression and Frame Relay Traffic Shaping, if required

      • Decides on fragmentation settings (FRF.12, MLP/LFI), if required

    • Supported on FR, ATM, HDLC, PPP & FR-to-ATM links

    • Provides RMON alerts, if VoIP packet are dropped


    Highlights cisco autoqos in the lan l.jpg
    Highlights – AutoQoS (Cont)Cisco AutoQoS in the LAN

    • Simplifies QoS configuration for VoIP

      • Phase I – a single command enables Cisco QoS for VoIP

      • Support for Cisco IP Phone & Cisco SoftPhone

    • Optimal Voice Performance

      • Parameters based on Cisco Best Practices, extensive lab testing, and input from a broad base of AVVID installations


    Highlights cisco autoqos in the lan cont l.jpg
    Highlights – AutoQoS (Cont)Cisco AutoQoS in the LAN (Cont)

    • Intelligent Policy generation

      • Automatically decides on trust and extended trust boundary settings

        • User can bypass telephone and connect their PC directly to the switch

        • Disables trust when IP phone is relocated

      • Configures CoS to DSCP to Queue mapping

      • Decides on WRR settings

    • Supported on Static, Dynamic-access, voice VLAN, and trunk ports


    The cisco advantage m ost comprehensive qos functionality available l.jpg
    The Cisco Advantage – AutoQoS (Cont)Most Comprehensive QoS Functionality Available

    • First to ship Advanced Differentiated Services Toolkit in 2000

    • Comprehensive QoS language framework via MQC

    • First to ship Intelligent Application Level classification (Cisco Network Based Application Recognition - NBAR)

    • Complete QoS monitoring & reporting support with Cisco Works QPM 3.0

    • Broadest platform support (switch & router space) for QoS

    • Full interoperability across the LAN & WAN DiffServ nodes

    • Only vendor to ship a Complete End-to-End Differentiated Services solution

    First to ship QoS Automation & Simplification


    Availability l.jpg
    Availability AutoQoS (Cont)


    References l.jpg
    References AutoQoS (Cont)

    QoS Home Page

    http://www.cisco.com/go/qos

    CiscoWorks QPM 3.0

    http://www.cisco.com/en/US/products/sw/cscowork/ps2064

    AutoQoS Technical Documentation for Cat 3550 & 2950

    http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/12112cea/3550scg/swqos.htm

    http://www.cisco.com/univercd/cc/td/doc/product/lan/cat2950/12112cea/2950scg/swqos.htm

    AutoQoS Technical Documentation for Cat 6500

    http://lbj.cisco.com/push_targets1/ucdit/cc/td/doc/product/lan/cat6000/sw_7_5/confg_gd/autoqos.htm#10002


    Slide54 l.jpg

    AutoQoS Technical Presentation, 1/03 AutoQoS (Cont)

    54

    © 2002, Cisco Systems, Inc. All rights reserved.


    ad